Update to 9.0.0
Signed-off-by: Erico Nunes <ernunes@redhat.com>
This commit is contained in:
parent
d6acf2835b
commit
c95ecd2bd1
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ xdriinfo-1.0.3.tar.bz2
|
||||
/mesa-demos-20181118.tar.bz2
|
||||
/mesa-demos-20210504.tar.bz2
|
||||
/mesa-demos-8.5.0.tar.bz2
|
||||
/mesa-demos-9.0.0.tar.xz
|
||||
|
@ -3,17 +3,16 @@
|
||||
|
||||
Summary: Mesa demos
|
||||
Name: mesa-demos
|
||||
Version: 8.5.0
|
||||
Version: 9.0.0
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
URL: http://www.mesa3d.org
|
||||
Source0: https://mesa.freedesktop.org/archive/demos/%{version}/%{name}-%{version}.tar.bz2
|
||||
Source0: https://archive.mesa3d.org/demos/%{name}-%{version}.tar.xz
|
||||
Source1: http://www.x.org/pub/individual/app/%{xdriinfo}.tar.bz2
|
||||
Source2: mesad-git-snapshot.sh
|
||||
# Patch pointblast/spriteblast/dinoshade out for legal reasons
|
||||
# (not in public domain)
|
||||
Patch0: mesa-demos-8.5.0-legal.patch
|
||||
Patch1: meson-Fix-DEMOS_DATA_DIR-when-with-system-data-files.patch
|
||||
# Fix xdriinfo not working with libglvnd
|
||||
Patch2: xdriinfo-1.0.4-glvnd.patch
|
||||
BuildRequires: meson
|
||||
@ -21,12 +20,18 @@ BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: freeglut-devel
|
||||
BuildRequires: glslang
|
||||
BuildRequires: mesa-libGL-devel
|
||||
BuildRequires: mesa-libEGL-devel
|
||||
BuildRequires: mesa-libGLES-devel
|
||||
BuildRequires: mesa-libgbm-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libdecor-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libxkbcommon-x11-devel
|
||||
BuildRequires: vulkan-loader-devel
|
||||
BuildRequires: wayland-devel
|
||||
BuildRequires: wayland-protocols-devel
|
||||
BuildRequires: freetype-devel
|
||||
@ -53,7 +58,6 @@ The egl-utils package provides the eglinfo and es2_info utilities.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version} -b1
|
||||
%patch0 -p1 -b .legal
|
||||
%patch1 -p1
|
||||
pushd ../%{xdriinfo}
|
||||
%patch2 -p1
|
||||
popd
|
||||
@ -70,6 +74,7 @@ rm -rf src/demos/spriteblast.c
|
||||
-Dwayland=enabled \
|
||||
-Degl=enabled \
|
||||
-Dgles2=enabled \
|
||||
-Dvulkan=enabled \
|
||||
-Dlibdrm=enabled \
|
||||
-Dosmesa=disabled
|
||||
|
||||
@ -113,6 +118,10 @@ install -m 0755 %{_vpath_builddir}/src/egl/opengles2/es2_info %{buildroot}%{_bin
|
||||
%{_bindir}/es2_info
|
||||
|
||||
%changelog
|
||||
* Mon Mar 27 2023 Erico Nunes <ernunes@redhat.com> - 9.0.0-1
|
||||
- Update to 9.0.0
|
||||
- Enable vulkan demos
|
||||
|
||||
* Fri Feb 03 2023 Erico Nunes <ernunes@redhat.com> - 8.5.0-1
|
||||
- Update to 8.5.0
|
||||
- Change build system to meson
|
||||
|
@ -1,29 +0,0 @@
|
||||
From 49c89ab7a96a2ef5e3200e56d3043372e736e4c9 Mon Sep 17 00:00:00 2001
|
||||
From: Anders Kaseorg <andersk@mit.edu>
|
||||
Date: Mon, 11 Jul 2022 13:00:03 -0700
|
||||
Subject: [PATCH] meson: Fix DEMOS_DATA_DIR when with-system-data-files is
|
||||
enabled
|
||||
|
||||
DEMOS_DATA_DIR needs to be an absolute path with a trailing slash.
|
||||
|
||||
Signed-off-by: Anders Kaseorg <andersk@mit.edu>
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 282c3962..0c15274b 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -29,7 +29,7 @@ null_dep = dependency('', required : false)
|
||||
|
||||
demos_data_dir = '../data/'
|
||||
if get_option('with-system-data-files')
|
||||
- demos_data_dir = get_option('datadir') / 'mesa-demos'
|
||||
+ demos_data_dir = get_option('prefix') / get_option('datadir') / 'mesa-demos/'
|
||||
endif
|
||||
add_project_arguments(
|
||||
'-DDEMOS_DATA_DIR="@0@"'.format(demos_data_dir),
|
||||
--
|
||||
2.39.1
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (xdriinfo-1.0.4.tar.bz2) = 7d998d89c539dbb93c00bc0dd237e086bc3c6e91c02c251448dc6e34cc8f89b2a752ab6f1d86cfb8a0d3d4373a167c9dda2f6f817626c3c7b5cd02a58bc1e6dd
|
||||
SHA512 (mesa-demos-8.5.0.tar.bz2) = df6a7f09638ca389d6e8bc569e599dcc59c9aa280bcfb95976d83e5cd3edfe74bb3a31f0953956dc16faa540ee5b09990e3377e1341d836fc527e50ace6e60b8
|
||||
SHA512 (mesa-demos-9.0.0.tar.xz) = af33ef72a521416e39d93370b2b4ccb768f08084c9e4c0aa62868210d9465c858e5cb8e5d23952295a3073946f609eb8723ee60b39dd9fb6696c4e45aafbb2c1
|
||||
|
Loading…
Reference in New Issue
Block a user