- Update to current head of upstream git repo for various imsm related
fixes (fixes bz523262) - Fix display of metadata version in output of Detail mode - Add UUID output to --detail --export (bz523314)
This commit is contained in:
parent
bb4afe8c1c
commit
e83588671c
@ -13,3 +13,4 @@ mdadm-2.6.7.1.tar.bz2
|
||||
mdadm-3.0-devel2.tar.bz2
|
||||
mdadm-3.0-devel3.tar.bz2
|
||||
mdadm-3.0.tar.bz2
|
||||
mdadm-3.0-0.20090915git.tar.bz2
|
||||
|
29
mdadm-3.0-metadata.patch
Normal file
29
mdadm-3.0-metadata.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- mdadm-3.0/Detail.c.metadata 2009-09-11 02:10:24.000000000 -0400
|
||||
+++ mdadm-3.0/Detail.c 2009-09-15 14:54:56.849391192 -0400
|
||||
@@ -161,7 +161,7 @@
|
||||
if (sra && sra->array.major_version < 0)
|
||||
printf("MD_METADATA=%s\n", sra->text_version);
|
||||
else
|
||||
- printf("MD_METADATA=%d.%02d\n",
|
||||
+ printf("MD_METADATA=%d.%d\n",
|
||||
array.major_version, array.minor_version);
|
||||
}
|
||||
|
||||
@@ -208,7 +208,7 @@
|
||||
if (sra && sra->array.major_version < 0)
|
||||
printf(" metadata=%s", sra->text_version);
|
||||
else
|
||||
- printf(" metadata=%d.%02d",
|
||||
+ printf(" metadata=%d.%d",
|
||||
array.major_version, array.minor_version);
|
||||
}
|
||||
|
||||
@@ -241,7 +241,7 @@
|
||||
if (sra && sra->array.major_version < 0)
|
||||
printf(" Version : %s\n", sra->text_version);
|
||||
else
|
||||
- printf(" Version : %d.%02d\n",
|
||||
+ printf(" Version : %d.%d\n",
|
||||
array.major_version, array.minor_version);
|
||||
}
|
||||
|
15
mdadm-3.0-uuid.patch
Normal file
15
mdadm-3.0-uuid.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -up mdadm-3.0/Detail.c~ mdadm-3.0/Detail.c
|
||||
--- mdadm-3.0/Detail.c~ 2009-06-02 07:48:29.000000000 +0200
|
||||
+++ mdadm-3.0/Detail.c 2009-09-14 17:11:15.000000000 +0200
|
||||
@@ -185,6 +185,11 @@ int Detail(char *dev, int brief, int exp
|
||||
if (mp && mp->path &&
|
||||
strncmp(mp->path, "/dev/md/", 8) == 0)
|
||||
printf("MD_DEVNAME=%s\n", mp->path+8);
|
||||
+ if (mp && (mp->uuid[0] || mp->uuid[1] || mp->uuid[2] ||
|
||||
+ mp->uuid[3]))
|
||||
+ printf("MD_UUID=%08x:%08x:%08x:%08x\n",
|
||||
+ mp->uuid[0], mp->uuid[1], mp->uuid[2],
|
||||
+ mp->uuid[3]);
|
||||
}
|
||||
goto out;
|
||||
}
|
14
mdadm.spec
14
mdadm.spec
@ -1,14 +1,16 @@
|
||||
Summary: The mdadm program controls Linux md devices (software RAID arrays)
|
||||
Name: mdadm
|
||||
Version: 3.0
|
||||
Release: 2%{?dist}
|
||||
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.bz2
|
||||
Release: 3%{?dist}
|
||||
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}-0.20090915git.tar.bz2
|
||||
Source1: mdmonitor.init
|
||||
Source2: raid-check
|
||||
Source3: mdadm.rules
|
||||
Source4: mdadm-raid-check-sysconfig
|
||||
Patch1: mdadm-2.5.2-static.patch
|
||||
Patch2: mdadm-3.0-endian-FAIL.patch
|
||||
Patch3: mdadm-3.0-metadata.patch
|
||||
Patch4: mdadm-3.0-uuid.patch
|
||||
URL: http://www.kernel.org/pub/linux/utils/raid/mdadm/
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -31,6 +33,8 @@ file can be used to help with some common tasks.
|
||||
%setup -q
|
||||
%patch1 -p1 -b .static
|
||||
%patch2 -p1 -b .endian
|
||||
%patch3 -p1 -b .metadata
|
||||
%patch4 -p1 -b .uuid
|
||||
|
||||
%build
|
||||
make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" SYSCONFDIR="%{_sysconfdir}" mdadm.static mdadm mdmon
|
||||
@ -76,6 +80,12 @@ fi
|
||||
%attr(0700,root,root) %dir /var/run/mdadm
|
||||
|
||||
%changelog
|
||||
* Tue Sep 15 2009 Doug Ledford <dledford@redhat.com> - 3.0-3
|
||||
- Update to current head of upstream git repo for various imsm related fixes
|
||||
(fixes bz523262)
|
||||
- Fix display of metadata version in output of Detail mode
|
||||
- Add UUID output to --detail --export (bz523314)
|
||||
|
||||
* Fri Jul 24 2009 Doug Ledford <dledford@redhat.com> - 3.0-2
|
||||
- Improved raid-check script as well as the ability to configure what devices
|
||||
get checked
|
||||
|
Loading…
Reference in New Issue
Block a user