- Update to latest upstream version

- Remove the mdmpd daemon entirely. Now that multipath tools from the
    lvm/dm packages handles multipath devices well, this is no longer
    needed.
- Various cleanups in the spec file
This commit is contained in:
Doug Ledford 2007-01-26 19:17:05 +00:00
parent 22ba5f588f
commit ce0fff6111
4 changed files with 33 additions and 37 deletions

View File

@ -4,3 +4,4 @@ mdadm-2.3.1.tgz
mdadm-2.5.2.tar.bz2
mdadm-2.5.3.tar.bz2
mdadm-2.5.4.tgz
mdadm-2.6.tgz

View File

@ -1,6 +1,6 @@
--- mdadm-2.5.2/Makefile.static 2006-07-07 14:12:20.000000000 -0400
+++ mdadm-2.5.2/Makefile 2006-07-07 14:17:54.000000000 -0400
@@ -141,20 +141,22 @@ $(OBJS) : mdadm.h bitmap.h
--- mdadm-2.6/Makefile.static 2007-01-26 11:16:37.000000000 -0500
+++ mdadm-2.6/Makefile 2007-01-26 11:24:55.000000000 -0500
@@ -145,23 +145,26 @@
sha1.o : sha1.c sha1.h md5.h
$(CC) $(CFLAGS) -DHAVE_STDINT_H -o sha1.o -c sha1.c
@ -29,3 +29,7 @@
install-man: mdadm.8 md.4 mdadm.conf.5
$(INSTALL) -D -m 644 mdadm.8 $(DESTDIR)$(MAN8DIR)/mdadm.8
+ $(INSTALL) -D -m 644 mdassemble.8 $(DESTDIR)$(MAN8DIR)/mdassemble.8
$(INSTALL) -D -m 644 md.4 $(DESTDIR)$(MAN4DIR)/md.4
$(INSTALL) -D -m 644 mdadm.conf.5 $(DESTDIR)$(MAN5DIR)/mdadm.conf.5

View File

@ -1,20 +1,14 @@
Summary: mdadm controls Linux md devices (software RAID arrays)
Name: mdadm
Version: 2.5.4
Release: 3%{?dist}
Version: 2.6
Release: 1%{?dist}
Source: http://www.cse.unsw.edu.au/~neilb/source/mdadm/mdadm-%{version}.tgz
Source1: mdmonitor.init
Source2: mdmpd-0.4.tgz
Source3: mdmpd.init
Source4: mdassemble.8
Patch: mdadm-1.5.0-email.patch
Patch1: mdmpd-0.4-node.patch
Patch1: mdadm-1.5.0-email.patch
Patch2: mdadm-2.5.2-s390-build.patch
Patch3: mdadm-2.5.2-static.patch
Patch4: mdadm-2.5.4-guid-printout.patch
Patch5: mdadm-2.2-nodiet.patch
Patch6: mdadm-2.5.2-cflags.patch
Patch7: mdadm-2.3.1-fswab64.patch
Patch4: mdadm-2.2-nodiet.patch
Patch5: mdadm-2.5.2-cflags.patch
URL: http://www.cse.unsw.edu.au/~neilb/source/mdadm/
License: GPL
Group: System Environment/Base
@ -30,27 +24,20 @@ almost all functions without a configuration file, though a configuration
file can be used to help with some common tasks.
%prep
%setup -q -a 2
%patch -p1 -b .email
%patch1 -p1 -b .node
%setup -q
%patch1 -p1 -b .email
%patch2 -p1 -b .s390
%patch3 -p1 -b .static
%patch4 -p1 -b .printout
%patch5 -p1 -b .nodiet
%patch6 -p1 -b .cflags
#%patch7 -p1 -b .fswab64
%patch4 -p1 -b .nodiet
%patch5 -p1 -b .cflags
%build
make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" MDASSEMBLE_AUTO=1 mdadm mdadm.static mdassemble.static
make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" -C mdmpd mdmpd
%install
make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin install
make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin -C mdmpd install
install -D -m755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/mdmonitor
install -D -m755 %{SOURCE3} $RPM_BUILD_ROOT/%{_initrddir}/mdmpd
install -D -m644 %{SOURCE4} $RPM_BUILD_ROOT/%{_mandir}/man8/mdassemble.8
mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdmpd
mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdadm
%clean
@ -58,24 +45,24 @@ rm -rf $RPM_BUILD_ROOT
%post
/sbin/chkconfig --add mdmonitor
/sbin/chkconfig --add mdmpd
# If we are upgrading, the postun for mdmpd will not have deleted the init.d
# file, so clean the stale file out here. We should only have to carry this
# baggage around for a little while before we can assume that the old mdmpd
# stuff has been cleaned up.
if [ -x /etc/init.d/mdmpd ]; then
service mdmpd stop > /dev/null 2>&1 ||:
/sbin/chkconfig --del mdmpd
fi
%preun
if [ "$1" = 0 ]; then
service mdmonitor stop > /dev/null 2>&1 ||:
/sbin/chkconfig --del mdmonitor
if [ -e %{_initrddir}/mdmpd ]; then
service mdmpd stop > /dev/null 2>&1 ||:
/sbin/chkconfig --del mdmpd
fi
fi
%postun
if [ "$1" -ge "1" ]; then
service mdmonitor condrestart > /dev/null 2>&1
if [ -e %{_initrddir}/mdmpd ]; then
service mdmpd condrestart > /dev/null 2>&1
fi
fi
%files
@ -84,10 +71,15 @@ fi
/sbin/*
%{_initrddir}/*
%{_mandir}/man*/md*
%attr(0700,root,root) %dir /var/run/mdmpd
%attr(0700,root,root) %dir /var/run/mdadm
%changelog
* Fri Jan 26 2007 Doug Ledford <dledford@redhat.com> - 2.6-1
- Update to latest upstream version
- Remove the mdmpd daemon entirely. Now that multipath tools from the lvm/dm
packages handles multipath devices well, this is no longer needed.
- Various cleanups in the spec file
* Thu Nov 09 2006 Doug Ledford <dledford@redhat.com> - 2.5.4-3
- Add a fix for the broken printout of array GUID when using the -E --brief
flags

View File

@ -1,2 +1 @@
d173fc81f2cc11cb84522fac63e876f1 mdmpd-0.4.tgz
167f6fe5b55a82766cf397377e080bea mdadm-2.5.4.tgz
15019078eacc8c21eac7b0b7faf86129 mdadm-2.6.tgz