* Wed Aug 04 2010 Doug Ledford <dledford@redhat.com> - 3.1.3-0.git20100804.1
- Update to latest upstream release (resolves an issue with stale lock files on the md device map file)
This commit is contained in:
parent
0bcc450f61
commit
a6b97325ff
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ mdadm-3.1.1-gcd9a8b5.tar.bz2
|
||||
mdadm-3.1.2.tar.bz2
|
||||
mdadm-3.1.3-git07202010.tar.bz2
|
||||
mdadm-3.1.3-git20100722.tar.bz2
|
||||
mdadm-3.1.3-git20100804.tar.bz2
|
||||
|
@ -1,19 +1,19 @@
|
||||
--- mdadm-3.1.2/Makefile.static 2010-04-06 11:55:03.098505021 -0400
|
||||
+++ mdadm-3.1.2/Makefile 2010-04-06 11:55:44.120254408 -0400
|
||||
@@ -62,9 +62,9 @@ CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)
|
||||
--- mdadm-3.1.3-git20100804/Makefile.static 2010-07-28 23:50:15.000000000 -0400
|
||||
+++ mdadm-3.1.3-git20100804/Makefile 2010-08-04 10:42:10.974092317 -0400
|
||||
@@ -68,9 +68,9 @@ CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)
|
||||
# pivotroot from early boot to late boot.
|
||||
# If you don't have /lib/init/rw you might want to use /dev/.something
|
||||
# e.g. make MAP_DIR=/dev/.mdadm
|
||||
-MAP_DIR = /lib/init/rw/mdadm
|
||||
# /dev is an odd place to put this, but it is the only directory that
|
||||
# meets the requirements.
|
||||
-MAP_DIR=/dev/.mdadm
|
||||
-MAP_FILE = map
|
||||
-MDMON_DIR = /lib/init/rw/mdmon
|
||||
-MDMON_DIR = /dev/.mdadm
|
||||
+MAP_DIR=/dev/md
|
||||
+MAP_FILE = md-device-map
|
||||
+MDMON_DIR = /dev/md
|
||||
DIRFLAGS = -DMAP_DIR=\"$(MAP_DIR)\" -DMAP_FILE=\"$(MAP_FILE)\"
|
||||
DIRFLAGS += -DMDMON_DIR=\"$(MDMON_DIR)\"
|
||||
CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS) $(DIRFLAGS)
|
||||
@@ -206,16 +206,16 @@ install : mdadm mdmon install-man instal
|
||||
@@ -224,16 +224,16 @@ install : mdadm mdmon install-man instal
|
||||
$(INSTALL) -D $(STRIP) -m 755 mdmon $(DESTDIR)$(BINDIR)/mdmon
|
||||
|
||||
install-static : mdadm.static install-man
|
||||
@ -34,3 +34,23 @@
|
||||
|
||||
install-man: mdadm.8 md.4 mdadm.conf.5 mdmon.8
|
||||
$(INSTALL) -D -m 644 mdadm.8 $(DESTDIR)$(MAN8DIR)/mdadm.8
|
||||
--- mdadm-3.1.3-git20100804/mapfile.c.static 2010-08-04 10:42:21.262967297 -0400
|
||||
+++ mdadm-3.1.3-git20100804/mapfile.c 2010-08-04 10:44:23.364005761 -0400
|
||||
@@ -60,9 +60,15 @@
|
||||
dir "/" base ".lock", \
|
||||
dir }
|
||||
|
||||
-#define MAP_DIRS 2
|
||||
+/*
|
||||
+ * one ring to bind them all...
|
||||
+ *
|
||||
+ * We only use a single map file location. The multiple locations issue
|
||||
+ * has caused more confusion than it was worth.
|
||||
+ * Doug Ledford <dledford@redhat.com>
|
||||
+ */
|
||||
+#define MAP_DIRS 1
|
||||
char *mapname[MAP_DIRS][4] = {
|
||||
- mapnames("/var/run/mdadm", "map"),
|
||||
mapnames(MAP_DIR, MAP_FILE),
|
||||
};
|
||||
|
||||
|
10
mdadm.spec
10
mdadm.spec
@ -1,8 +1,8 @@
|
||||
Summary: The mdadm program controls Linux md devices (software RAID arrays)
|
||||
Name: mdadm
|
||||
Version: 3.1.3
|
||||
Release: 0.git20100722.2%{?dist}
|
||||
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}-git20100722.tar.bz2
|
||||
Release: 0.git20100804.1%{?dist}
|
||||
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}-git20100804.tar.bz2
|
||||
Source1: mdmonitor.init
|
||||
Source2: raid-check
|
||||
Source3: mdadm.rules
|
||||
@ -27,7 +27,7 @@ almost all functions without a configuration file, though a configuration
|
||||
file can be used to help with some common tasks.
|
||||
|
||||
%prep
|
||||
%setup -q -n mdadm-3.1.3-git20100722
|
||||
%setup -q -n mdadm-3.1.3-git20100804
|
||||
%patch19 -p1 -b .udev
|
||||
%patch20 -p1 -b .static
|
||||
|
||||
@ -74,6 +74,10 @@ fi
|
||||
%attr(0700,root,root) %dir /var/run/mdadm
|
||||
|
||||
%changelog
|
||||
* Wed Aug 04 2010 Doug Ledford <dledford@redhat.com> - 3.1.3-0.git20100804.1
|
||||
- Update to latest upstream release (resolves an issue with stale lock
|
||||
files on the md device map file)
|
||||
|
||||
* Thu Jul 22 2010 Doug Ledford <dledford@redhat.com> - 3.1.3-0.git20100722.2
|
||||
- Comment out the incremental assembly rules from the main udev rule file
|
||||
so we can control it in our own incremental assembly specific rule file
|
||||
|
Loading…
Reference in New Issue
Block a user