Update to mdadm-3.3
Resolves bz977826 Signed-off-by: Jes Sorensen <Jes.Sorensen@redhat.com>
This commit is contained in:
parent
f7e88a8ef4
commit
812436111f
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@ clog
|
||||
/mdadm-3.2.4.tar.xz
|
||||
/mdadm-3.2.5.tar.xz
|
||||
/mdadm-3.2.6.tar.xz
|
||||
/mdadm-3.3.tar.xz
|
||||
|
@ -1,32 +1,27 @@
|
||||
--- mdadm-3.2.3/udev-md-raid.rules.udev 2011-12-15 05:13:08.000000000 +0100
|
||||
+++ mdadm-3.2.3/udev-md-raid.rules 2011-12-28 17:18:02.753053345 +0100
|
||||
@@ -2,19 +2,21 @@
|
||||
--- mdadm-3.3rc1/udev-md-raid-assembly.rules.udev 2013-04-22 17:24:22.000000000 +0200
|
||||
+++ mdadm-3.3rc1/udev-md-raid-assembly.rules 2013-06-28 14:59:58.092070982 +0200
|
||||
@@ -4,16 +4,18 @@
|
||||
|
||||
SUBSYSTEM!="block", GOTO="md_end"
|
||||
SUBSYSTEM!="block", GOTO="md_inc_end"
|
||||
|
||||
+# In Fedora we handle the raid components in 65-md-incremental.rules so that
|
||||
+# we can do things like honor anaconda command line options and such
|
||||
# handle potential components of arrays (the ones supported by md)
|
||||
-ENV{ID_FS_TYPE}=="ddf_raid_member|isw_raid_member|linux_raid_member", GOTO="md_inc"
|
||||
-GOTO="md_inc_skip"
|
||||
-
|
||||
-LABEL="md_inc"
|
||||
-GOTO="md_inc_end"
|
||||
+#ENV{ID_FS_TYPE}=="ddf_raid_member|isw_raid_member|linux_raid_member", GOTO="md_inc"
|
||||
+#GOTO="md_inc_skip"
|
||||
+#
|
||||
+#GOTO="md_inc_end"
|
||||
|
||||
-LABEL="md_inc"
|
||||
+#LABEL="md_inc"
|
||||
|
||||
# remember you can limit what gets auto/incrementally assembled by
|
||||
# mdadm.conf(5)'s 'AUTO' and selectively whitelist using 'ARRAY'
|
||||
-ACTION=="add", RUN+="/sbin/mdadm --incremental $tempnode --offroot"
|
||||
-ACTION=="add", RUN+="/sbin/mdadm --incremental $devnode --offroot"
|
||||
-ACTION=="remove", ENV{ID_PATH}=="?*", RUN+="/sbin/mdadm -If $name --path $env{ID_PATH}"
|
||||
-ACTION=="remove", ENV{ID_PATH}!="?*", RUN+="/sbin/mdadm -If $name"
|
||||
+#ACTION=="add", RUN+="/sbin/mdadm --incremental $tempnode --offroot"
|
||||
+#ACTION=="add", RUN+="/sbin/mdadm --incremental $devnode --offroot"
|
||||
+#ACTION=="remove", ENV{ID_PATH}=="?*", RUN+="/sbin/mdadm -If $name --path $env{ID_PATH}"
|
||||
+#ACTION=="remove", ENV{ID_PATH}!="?*", RUN+="/sbin/mdadm -If $name"
|
||||
|
||||
-LABEL="md_inc_skip"
|
||||
+#LABEL="md_inc_skip"
|
||||
|
||||
# handle md arrays
|
||||
ACTION!="add|change", GOTO="md_end"
|
||||
LABEL="md_inc_end"
|
30
mdadm.spec
30
mdadm.spec
@ -1,7 +1,7 @@
|
||||
Summary: The mdadm program controls Linux md devices (software RAID arrays)
|
||||
Name: mdadm
|
||||
Version: 3.2.6
|
||||
Release: 21%{?dist}
|
||||
Version: 3.3
|
||||
Release: 1%{?dist}
|
||||
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
|
||||
Source1: mdmonitor.init
|
||||
Source2: raid-check
|
||||
@ -11,21 +11,13 @@ Source5: mdadm-cron
|
||||
Source6: mdmonitor.service
|
||||
Source7: mdadm.conf
|
||||
Source8: mdadm_event.conf
|
||||
Patch1: mdadm-3.2.6-Create.c-check-if-freesize-is-equal-0.patch
|
||||
Patch2: mdadm-3.2.6-imsm-Forbid-spanning-between-multiple-controllers.patch
|
||||
Patch3: mdadm-3.2.6-query-udev-dir-via-pkg-config.patch
|
||||
Patch4: mdadm-3.2.6-Add-updating-component_size-to-manager-thread-of-mdm.patch
|
||||
Patch5: mdadm-3.2.6-imsm-monitor-do-not-finish-migration-if-there-are-no.patch
|
||||
Patch6: mdadm-3.2.6-Manage_runstop-call-flush_mdmon-if-O_EXCL-fails-on-s.patch
|
||||
Patch93: mdadm-3.2.6-Remove-offroot-argument-and-default-to-always-settin.patch
|
||||
Patch94: mdadm-3.2.6-Add-support-for-launching-mdmon-via-systemctl-instea.patch
|
||||
Patch95: mdadm-3.2.6-In-case-launching-mdmon-fails-print-an-error-message.patch
|
||||
Patch96: mdadm-3.2.6-mdmon-add-foreground-option.patch
|
||||
# Fedora customization patches
|
||||
Patch97: mdadm-3.2.6-udev.patch
|
||||
Patch97: mdadm-3.3-udev.patch
|
||||
Patch98: mdadm-2.5.2-static.patch
|
||||
# Fedora 17 - only
|
||||
Patch99: mdadm-3.2.4-map-dir.patch
|
||||
URL: http://www.kernel.org/pub/linux/utils/raid/mdadm/
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -48,18 +40,6 @@ file can be used to help with some common tasks.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .raidsize
|
||||
%patch2 -p1 -b .multictrl
|
||||
%patch3 -p1 -b .udevquery
|
||||
%patch4 -p1 -b .component
|
||||
%patch5 -p1 -b .migration
|
||||
%patch6 -p1 -b .runstop
|
||||
|
||||
# Use systemctl to launch mdmon on F18 and higher
|
||||
%patch93 -p1 -b .nooffroot
|
||||
%patch94 -p1 -b .sysctl
|
||||
%patch95 -p1 -b .mdmonfail
|
||||
%patch96 -p1 -b .foreground
|
||||
|
||||
# Fedora customization patches
|
||||
%patch97 -p1 -b .udev
|
||||
@ -124,6 +104,10 @@ rm -rf %{buildroot}
|
||||
/etc/libreport/events.d/*
|
||||
|
||||
%changelog
|
||||
* Thu Sep 5 2013 Jes Sorensen <Jes.Sorensen@redhat.com> - 3.3-1
|
||||
- Update to mdadm-3.3
|
||||
- Resolves bz977826
|
||||
|
||||
* Tue Aug 13 2013 Jes Sorensen <Jes.Sorensen@redhat.com> - 3.2.6-21
|
||||
- Fix pointless rpmbuild noise over mismatching date info
|
||||
- Remove Fedora 17 support
|
||||
|
Loading…
Reference in New Issue
Block a user