parent
8959573c01
commit
7c319bb937
@ -1 +1 @@
|
||||
SOURCES/mdadm-4.2-rc1.tar.xz
|
||||
SOURCES/mdadm-4.2-rc2.tar.xz
|
||||
|
@ -1 +1 @@
|
||||
cceb5f208a2d77a220a68f23d6cab5a0e8704685 SOURCES/mdadm-4.2-rc1.tar.xz
|
||||
b6e99ec4b0c3953505dc2e6ef6e8f2a71a26207d SOURCES/mdadm-4.2-rc2.tar.xz
|
||||
|
@ -1,48 +0,0 @@
|
||||
From 83b3de7795d2a421eb6ae4ab97656a250bb898ea Mon Sep 17 00:00:00 2001
|
||||
From: Xiao Ni <xni@redhat.com>
|
||||
Date: Fri, 23 Apr 2021 14:01:30 +0800
|
||||
Subject: [PATCH 1/2] Fix some building errors
|
||||
|
||||
There are some building errors if treating warning as errors.
|
||||
Fix them in this patch.
|
||||
|
||||
Signed-off-by: Xiao Ni <xni@redhat.com>
|
||||
Signed-off-by: Jes Sorensen <jsorensen@fb.com>
|
||||
---
|
||||
super-intel.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/super-intel.c b/super-intel.c
|
||||
index be0313d..5469912 100644
|
||||
--- a/super-intel.c
|
||||
+++ b/super-intel.c
|
||||
@@ -3192,7 +3192,7 @@ static int imsm_create_metadata_checkpoint_update(
|
||||
}
|
||||
(*u)->type = update_general_migration_checkpoint;
|
||||
(*u)->curr_migr_unit = current_migr_unit(super->migr_rec);
|
||||
- dprintf("prepared for %llu\n", (*u)->curr_migr_unit);
|
||||
+ dprintf("prepared for %llu\n", (unsigned long long)(*u)->curr_migr_unit);
|
||||
|
||||
return update_memory_size;
|
||||
}
|
||||
@@ -11127,7 +11127,7 @@ int recover_backup_imsm(struct supertype *st, struct mdinfo *info)
|
||||
skipped_disks++;
|
||||
continue;
|
||||
}
|
||||
- if (read(dl_disk->fd, buf, unit_len) != unit_len) {
|
||||
+ if (read(dl_disk->fd, buf, unit_len) != (ssize_t)unit_len) {
|
||||
pr_err("Cannot read copy area block: %s\n",
|
||||
strerror(errno));
|
||||
skipped_disks++;
|
||||
@@ -11139,7 +11139,7 @@ int recover_backup_imsm(struct supertype *st, struct mdinfo *info)
|
||||
skipped_disks++;
|
||||
continue;
|
||||
}
|
||||
- if (write(dl_disk->fd, buf, unit_len) != unit_len) {
|
||||
+ if (write(dl_disk->fd, buf, unit_len) != (ssize_t)unit_len) {
|
||||
pr_err("Cannot restore block: %s\n",
|
||||
strerror(errno));
|
||||
skipped_disks++;
|
||||
--
|
||||
2.7.5
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 0530e2e0d8c9ecb5171e70bc48e1a6566f317378 Mon Sep 17 00:00:00 2001
|
||||
From: Norbert Szulc <norbert.szulc@intel.com>
|
||||
Date: Wed, 5 May 2021 13:01:02 +0200
|
||||
Subject: [PATCH 2/2] Prevent user from using --stop with ambiguous args
|
||||
|
||||
When both --scan and device name is passed to --stop action,
|
||||
then is executed only for given device. Scan is ignored.
|
||||
|
||||
Block the operation when both --scan and device name are passed.
|
||||
|
||||
Signed-off-by: Norbert Szulc <norbert.szulc@intel.com>
|
||||
Signed-off-by: Mariusz Tkaczyk <mariusz.tkaczyk@linux.intel.com>
|
||||
Signed-off-by: Jes Sorensen <jsorensen@fb.com>
|
||||
---
|
||||
mdadm.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/mdadm.c b/mdadm.c
|
||||
index 9a4317d..dcc26ba 100644
|
||||
--- a/mdadm.c
|
||||
+++ b/mdadm.c
|
||||
@@ -2041,6 +2041,11 @@ static int misc_list(struct mddev_dev *devlist,
|
||||
rv |= Manage_run(dv->devname, mdfd, c);
|
||||
break;
|
||||
case 'S':
|
||||
+ if (c->scan) {
|
||||
+ pr_err("--stop not meaningful with both a --scan assembly and a device name.\n");
|
||||
+ rv |= 1;
|
||||
+ break;
|
||||
+ }
|
||||
rv |= Manage_stop(dv->devname, mdfd, c->verbose, 0);
|
||||
break;
|
||||
case 'o':
|
||||
--
|
||||
2.7.5
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- mdadm/Makefile.orig 2021-07-28 21:39:23.887433859 +0800
|
||||
+++ mdadm/Makefile 2021-07-28 21:39:37.989432841 +0800
|
||||
@@ -50,7 +50,7 @@
|
||||
CC := $(CROSS_COMPILE)gcc
|
||||
endif
|
||||
CXFLAGS ?= -ggdb
|
||||
-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
|
||||
+CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
|
||||
ifdef WARN_UNUSED
|
||||
CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O3
|
||||
endif
|
Loading…
Reference in New Issue