Merge remote branch 'origin/f13/master'
Conflicts: .gitignore mdadm-2.5.2-static.patch mdadm.rules mdadm.spec sources
This commit is contained in:
commit
73d2cf2972
@ -1,5 +1,5 @@
|
||||
--- mdadm-3.1.3-git20100804/Makefile.static 2010-07-28 23:50:15.000000000 -0400
|
||||
+++ mdadm-3.1.3-git20100804/Makefile 2010-08-04 10:42:10.974092317 -0400
|
||||
+++ mdadm-3.1.3-git20100804/Makefile 2010-08-04 11:28:08.603342301 -0400
|
||||
@@ -68,9 +68,9 @@ CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)
|
||||
# pivotroot from early boot to late boot.
|
||||
# /dev is an odd place to put this, but it is the only directory that
|
||||
@ -13,7 +13,18 @@
|
||||
DIRFLAGS = -DMAP_DIR=\"$(MAP_DIR)\" -DMAP_FILE=\"$(MAP_FILE)\"
|
||||
DIRFLAGS += -DMDMON_DIR=\"$(MDMON_DIR)\"
|
||||
CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS) $(DIRFLAGS)
|
||||
@@ -224,16 +224,16 @@ install : mdadm mdmon install-man instal
|
||||
@@ -165,9 +165,8 @@ mdadm.O2 : $(SRCS) mdadm.h mdmon.O2
|
||||
mdmon.O2 : $(MON_SRCS) mdadm.h mdmon.h
|
||||
$(CC) -o mdmon.O2 $(CFLAGS) $(LDFLAGS) -DHAVE_STDINT_H -O2 -D_FORTIFY_SOURCE=2 $(MON_SRCS)
|
||||
|
||||
-# use '-z now' to guarantee no dynamic linker interactions with the monitor thread
|
||||
mdmon : $(MON_OBJS)
|
||||
- $(CC) $(LDFLAGS) -z now -o mdmon $(MON_OBJS) $(LDLIBS)
|
||||
+ $(CC) $(LDFLAGS) -o mdmon $(MON_OBJS) $(LDLIBS)
|
||||
msg.o: msg.c msg.h
|
||||
|
||||
test_stripe : restripe.c mdadm.h
|
||||
@@ -224,16 +223,16 @@ install : mdadm mdmon install-man instal
|
||||
$(INSTALL) -D $(STRIP) -m 755 mdmon $(DESTDIR)$(BINDIR)/mdmon
|
||||
|
||||
install-static : mdadm.static install-man
|
||||
@ -34,8 +45,8 @@
|
||||
|
||||
install-man: mdadm.8 md.4 mdadm.conf.5 mdmon.8
|
||||
$(INSTALL) -D -m 644 mdadm.8 $(DESTDIR)$(MAN8DIR)/mdadm.8
|
||||
--- mdadm-3.1.3-git20100804/mapfile.c.static 2010-08-04 10:42:21.262967297 -0400
|
||||
+++ mdadm-3.1.3-git20100804/mapfile.c 2010-08-04 10:44:23.364005761 -0400
|
||||
--- mdadm-3.1.3-git20100804/mapfile.c.static 2010-07-28 23:50:15.000000000 -0400
|
||||
+++ mdadm-3.1.3-git20100804/mapfile.c 2010-08-04 11:27:35.391342438 -0400
|
||||
@@ -60,9 +60,15 @@
|
||||
dir "/" base ".lock", \
|
||||
dir }
|
||||
|
@ -37,6 +37,7 @@ make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" SYSCONFDIR="%
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
|
||||
rm -f %{buildroot}/lib/udev/rules.d/64*
|
||||
install -Dp -m 755 %{SOURCE1} %{buildroot}%{_initrddir}/mdmonitor
|
||||
install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/cron.weekly/99-raid-check
|
||||
install -Dp -m 644 %{SOURCE3} %{buildroot}/lib/udev/rules.d/65-md-incremental.rules
|
||||
@ -82,10 +83,9 @@ fi
|
||||
files on the md device map file)
|
||||
|
||||
* Thu Jul 22 2010 Doug Ledford <dledford@redhat.com> - 3.1.3-0.git20100722.2
|
||||
- Comment out the incremental assembly rules from the main udev rule file
|
||||
so we can control it in our own incremental assembly specific rule file
|
||||
- Don't build the static package, we don't install it, also remove the
|
||||
glibc-static buildreq
|
||||
- Remove the glibc-static buildreq and don't build the static mdadm since
|
||||
we don't install it anyway
|
||||
- Remove the udev file since adding it was supposed to be a rawhide only change
|
||||
|
||||
* Thu Jul 22 2010 Doug Ledford <dledford@redhat.com> - 3.1.3-0.git20100722.1
|
||||
- Change git date format to the correct format (YYYYMMDD)
|
||||
|
Loading…
Reference in New Issue
Block a user