Reorder patches to allow for udev query patch to apply on Fedora 17
Signed-off-by: Jes Sorensen <Jes.Sorensen@redhat.com>
This commit is contained in:
parent
ae351a031e
commit
2f8071afbc
@ -32,7 +32,7 @@ index b9787d6..b6edb23 100644
|
|||||||
DIRFLAGS += -DFAILED_SLOTS_DIR=\"$(FAILED_SLOTS_DIR)\"
|
DIRFLAGS += -DFAILED_SLOTS_DIR=\"$(FAILED_SLOTS_DIR)\"
|
||||||
@@ -264,6 +265,9 @@ install-man: mdadm.8 md.4 mdadm.conf.5 mdmon.8
|
@@ -264,6 +265,9 @@ install-man: mdadm.8 md.4 mdadm.conf.5 mdmon.8
|
||||||
install-udev: udev-md-raid.rules
|
install-udev: udev-md-raid.rules
|
||||||
$(INSTALL) -D -m 644 udev-md-raid.rules $(DESTDIR)/lib/udev/rules.d/64-md-raid.rules
|
$(INSTALL) -D -m 644 udev-md-raid.rules $(DESTDIR)$(UDEVDIR)/rules.d/64-md-raid.rules
|
||||||
|
|
||||||
+install-systemd: systemd/mdmon@.service
|
+install-systemd: systemd/mdmon@.service
|
||||||
+ $(INSTALL) -D -m 644 systemd/mdmon@.service $(DESTDIR)$(SYSTEMD_DIR)/mdmon@.service
|
+ $(INSTALL) -D -m 644 systemd/mdmon@.service $(DESTDIR)$(SYSTEMD_DIR)/mdmon@.service
|
||||||
|
@ -46,8 +46,8 @@ index 72f609e..a3e4027 100644
|
|||||||
- $(INSTALL) -D -m 644 udev-md-raid.rules $(DESTDIR)/lib/udev/rules.d/64-md-raid.rules
|
- $(INSTALL) -D -m 644 udev-md-raid.rules $(DESTDIR)/lib/udev/rules.d/64-md-raid.rules
|
||||||
+ $(INSTALL) -D -m 644 udev-md-raid.rules $(DESTDIR)$(UDEVDIR)/rules.d/64-md-raid.rules
|
+ $(INSTALL) -D -m 644 udev-md-raid.rules $(DESTDIR)$(UDEVDIR)/rules.d/64-md-raid.rules
|
||||||
|
|
||||||
install-systemd: systemd/mdmon@.service
|
uninstall:
|
||||||
$(INSTALL) -D -m 644 systemd/mdmon@.service $(DESTDIR)$(SYSTEMD_DIR)/mdmon@.service
|
rm -f $(DESTDIR)$(MAN8DIR)/mdadm.8 $(DESTDIR)$(MAN8DIR)/mdmon.8 $(DESTDIR)$(MAN4DIR)/md.4 $(DESTDIR)$(MAN5DIR)/mdadm.conf.5 $(DESTDIR)$(BINDIR)/mdadm
|
||||||
|
|
||||||
--
|
--
|
||||||
1.8.1.4
|
1.8.1.4
|
||||||
|
16
mdadm.spec
16
mdadm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The mdadm program controls Linux md devices (software RAID arrays)
|
Summary: The mdadm program controls Linux md devices (software RAID arrays)
|
||||||
Name: mdadm
|
Name: mdadm
|
||||||
Version: 3.2.6
|
Version: 3.2.6
|
||||||
Release: 16%{?dist}
|
Release: 17%{?dist}
|
||||||
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
|
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
|
||||||
Source1: mdmonitor.init
|
Source1: mdmonitor.init
|
||||||
Source2: raid-check
|
Source2: raid-check
|
||||||
@ -32,6 +32,8 @@ Obsoletes: mdctl,raidtools
|
|||||||
%define fedora17 0
|
%define fedora17 0
|
||||||
%else
|
%else
|
||||||
%define fedora17 1
|
%define fedora17 1
|
||||||
|
%define _udevrulesdir /usr/lib/udev/rules.d
|
||||||
|
%define _tmpfilesdir %{_prefix}/usr/lib/tmpfiles.d
|
||||||
%endif
|
%endif
|
||||||
%if %{fedora17}
|
%if %{fedora17}
|
||||||
Requires(post): systemd-units systemd-sysv chkconfig coreutils
|
Requires(post): systemd-units systemd-sysv chkconfig coreutils
|
||||||
@ -70,6 +72,10 @@ is not used as the system init process.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .raidsize
|
||||||
|
%patch2 -p1 -b .multictrl
|
||||||
|
%patch3 -p1 -b .udevquery
|
||||||
|
|
||||||
# Use systemctl to launch mdmon on F18 and higher
|
# Use systemctl to launch mdmon on F18 and higher
|
||||||
%if !%{fedora17}
|
%if !%{fedora17}
|
||||||
%patch93 -p1 -b .nooffroot
|
%patch93 -p1 -b .nooffroot
|
||||||
@ -78,10 +84,6 @@ is not used as the system init process.
|
|||||||
%patch96 -p1 -b .foreground
|
%patch96 -p1 -b .foreground
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch1 -p1 -b .raidsize
|
|
||||||
%patch2 -p1 -b .multictrl
|
|
||||||
%patch3 -p1 -b .udevquery
|
|
||||||
|
|
||||||
# Fedora customization patches
|
# Fedora customization patches
|
||||||
%patch97 -p1 -b .udev
|
%patch97 -p1 -b .udev
|
||||||
%patch98 -p1 -b .static
|
%patch98 -p1 -b .static
|
||||||
@ -164,6 +166,10 @@ rm -rf %{buildroot}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 23 2013 Jes Sorensen <Jes.Sorensen@redhat.com> - 3.2.6-17
|
||||||
|
- Reorder patches to allow for udev query patch to be applied on
|
||||||
|
Fedora 17 as well.
|
||||||
|
|
||||||
* Tue Apr 22 2013 Jes Sorensen <Jes.Sorensen@redhat.com> - 3.2.6-16
|
* Tue Apr 22 2013 Jes Sorensen <Jes.Sorensen@redhat.com> - 3.2.6-16
|
||||||
- Rely on rpm macros to place files in correct directories, and match /usr
|
- Rely on rpm macros to place files in correct directories, and match /usr
|
||||||
move
|
move
|
||||||
|
Loading…
Reference in New Issue
Block a user