- Various cleanups as part of merge review process
- Related: bz226134
This commit is contained in:
parent
f1d4a31eb1
commit
0317f8f78a
51
mdadm-2.6.1-build.patch
Normal file
51
mdadm-2.6.1-build.patch
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
--- mdadm-2.6.1/Makefile.build 2007-04-11 11:12:46.000000000 -0400
|
||||||
|
+++ mdadm-2.6.1/Makefile 2007-04-11 11:18:54.000000000 -0400
|
||||||
|
@@ -100,9 +100,11 @@ mdadm.static : $(OBJS) $(STATICOBJS)
|
||||||
|
$(CC) $(CFLAGS) $(LDFLAGS) -static -o mdadm.static $(OBJS) $(STATICOBJS)
|
||||||
|
|
||||||
|
mdadm.tcc : $(SRCS) mdadm.h
|
||||||
|
+ rm -f $(OBJS)
|
||||||
|
$(TCC) -o mdadm.tcc $(SRCS)
|
||||||
|
|
||||||
|
mdadm.uclibc : $(SRCS) mdadm.h
|
||||||
|
+ rm -f $(OBJS) $(STATICOBJS)
|
||||||
|
$(UCLIBC_GCC) -DUCLIBC -DHAVE_STDINT_H -o mdadm.uclibc $(SRCS) $(STATICSRC)
|
||||||
|
|
||||||
|
mdadm.klibc : $(SRCS) mdadm.h
|
||||||
|
@@ -113,15 +115,15 @@ test_stripe : restripe.c mdadm.h
|
||||||
|
$(CC) $(CXFLAGS) $(LDFLAGS) -o test_stripe -DMAIN restripe.c
|
||||||
|
|
||||||
|
mdassemble : $(ASSEMBLE_SRCS) mdadm.h
|
||||||
|
- rm -f $(OBJS)
|
||||||
|
- $(DIET_GCC) $(ASSEMBLE_FLAGS) -o mdassemble $(ASSEMBLE_SRCS) $(STATICSRC)
|
||||||
|
+ rm -f $(OBJS) $(STATICOBJS)
|
||||||
|
+ $(CC) $(ASSEMBLE_FLAGS) $(LDFLAGS) -DHAVE_STDINT_H -o mdassemble.static $(ASSEMBLE_SRCS) $(STATICSRC)
|
||||||
|
|
||||||
|
-mdassemble.static : $(ASSEMBLE_SRCS) mdadm.h
|
||||||
|
- rm -f $(OBJS)
|
||||||
|
+mdassemble.static : $(ASSEMBLE_SRCS) $(STATICSRC) mdadm.h
|
||||||
|
+ rm -f $(OBJS) $(STATICOBJS)
|
||||||
|
$(CC) $(ASSEMBLE_FLAGS) $(LDFLAGS) -static -DHAVE_STDINT_H -o mdassemble.static $(ASSEMBLE_SRCS) $(STATICSRC)
|
||||||
|
|
||||||
|
-mdassemble.uclibc : $(ASSEMBLE_SRCS) mdadm.h
|
||||||
|
- rm -f $(OJS)
|
||||||
|
+mdassemble.uclibc : $(ASSEMBLE_SRCS) $(STATICSRC) mdadm.h
|
||||||
|
+ rm -f $(OBJS) $(STATICOBJS)
|
||||||
|
$(UCLIBC_GCC) $(ASSEMBLE_FLAGS) -DUCLIBC -DHAVE_STDINT_H -static -o mdassemble.uclibc $(ASSEMBLE_SRCS) $(STATICSRC)
|
||||||
|
|
||||||
|
# This doesn't work
|
||||||
|
@@ -164,10 +166,10 @@ install-klibc : mdadm.klibc install-man
|
||||||
|
$(INSTALL) -D -m 755 mdadm.klibc $(DESTDIR)$(BINDIR)/mdadm
|
||||||
|
|
||||||
|
install-man: mdadm.8 mdassemble.8 md.4 mdadm.conf.5
|
||||||
|
- $(INSTALL) -D -m 644 mdadm.8 $(DESTDIR)$(MAN8DIR)/mdadm.8
|
||||||
|
- $(INSTALL) -D -m 644 mdassemble.8 $(DESTDIR)$(MAN8DIR)/mdassemble.8
|
||||||
|
- $(INSTALL) -D -m 644 md.4 $(DESTDIR)$(MAN4DIR)/md.4
|
||||||
|
- $(INSTALL) -D -m 644 mdadm.conf.5 $(DESTDIR)$(MAN5DIR)/mdadm.conf.5
|
||||||
|
+ $(INSTALL) -Dp -m 644 mdadm.8 $(DESTDIR)$(MAN8DIR)/mdadm.8
|
||||||
|
+ $(INSTALL) -Dp -m 644 mdassemble.8 $(DESTDIR)$(MAN8DIR)/mdassemble.8
|
||||||
|
+ $(INSTALL) -Dp -m 644 md.4 $(DESTDIR)$(MAN4DIR)/md.4
|
||||||
|
+ $(INSTALL) -Dp -m 644 mdadm.conf.5 $(DESTDIR)$(MAN5DIR)/mdadm.conf.5
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
rm -f $(DESTDIR)$(MAN8DIR)/mdadm.8 md.4 $(DESTDIR)$(MAN4DIR)/md.4 $(DESTDIR)$(MAN5DIR)/mdadm.conf.5 $(DESTDIR)$(BINDIR)/mdadm
|
22
mdadm.spec
22
mdadm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: mdadm controls Linux md devices (software RAID arrays)
|
Summary: mdadm controls Linux md devices (software RAID arrays)
|
||||||
Name: mdadm
|
Name: mdadm
|
||||||
Version: 2.6.1
|
Version: 2.6.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Source: http://www.cse.unsw.edu.au/~neilb/source/mdadm/mdadm-%{version}.tgz
|
Source: http://www.cse.unsw.edu.au/~neilb/source/mdadm/mdadm-%{version}.tgz
|
||||||
Source1: mdmonitor.init
|
Source1: mdmonitor.init
|
||||||
Patch1: mdadm-1.5.0-email.patch
|
Patch1: mdadm-1.5.0-email.patch
|
||||||
@ -9,12 +9,16 @@ Patch2: mdadm-2.5.2-s390-build.patch
|
|||||||
Patch3: mdadm-2.5.2-static.patch
|
Patch3: mdadm-2.5.2-static.patch
|
||||||
Patch4: mdadm-2.2-nodiet.patch
|
Patch4: mdadm-2.2-nodiet.patch
|
||||||
Patch5: mdadm-2.5.2-cflags.patch
|
Patch5: mdadm-2.5.2-cflags.patch
|
||||||
|
Patch6: mdadm-2.6.1-build.patch
|
||||||
URL: http://www.cse.unsw.edu.au/~neilb/source/mdadm/
|
URL: http://www.cse.unsw.edu.au/~neilb/source/mdadm/
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: mdctl,raidtools
|
Obsoletes: mdctl,raidtools
|
||||||
Requires: smtpdaemon
|
Requires: smtpdaemon
|
||||||
|
Requires(post): /sbin/service, /sbin/chkconfig
|
||||||
|
Requires(preun): /sbin/service, /sbin/chkconfig
|
||||||
|
Requires(postun): /sbin/service
|
||||||
|
|
||||||
%description
|
%description
|
||||||
mdadm is used to create, manage, and monitor Linux MD (software RAID)
|
mdadm is used to create, manage, and monitor Linux MD (software RAID)
|
||||||
@ -30,13 +34,15 @@ file can be used to help with some common tasks.
|
|||||||
%patch3 -p1 -b .static
|
%patch3 -p1 -b .static
|
||||||
%patch4 -p1 -b .nodiet
|
%patch4 -p1 -b .nodiet
|
||||||
%patch5 -p1 -b .cflags
|
%patch5 -p1 -b .cflags
|
||||||
|
%patch6 -p1 -b .build
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" MDASSEMBLE_AUTO=1 mdadm mdadm.static mdassemble.static
|
make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" MDASSEMBLE_AUTO=1 mdassemble.static mdassemble mdadm.static mdadm
|
||||||
|
|
||||||
%install
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin install
|
make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=/sbin install
|
||||||
install -D -m755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/mdmonitor
|
install -Dp -m755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/mdmonitor
|
||||||
|
|
||||||
mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdadm
|
mkdir -p -m 700 $RPM_BUILD_ROOT/var/run/mdadm
|
||||||
|
|
||||||
@ -69,13 +75,17 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc ANNOUNCE-* TODO ChangeLog mdadm.conf-example COPYING misc/*
|
%doc TODO ChangeLog mdadm.conf-example COPYING misc/*
|
||||||
/sbin/*
|
/sbin/*
|
||||||
%{_initrddir}/*
|
%{_initrddir}/*
|
||||||
%{_mandir}/man*/md*
|
%{_mandir}/man*/md*
|
||||||
%attr(0700,root,root) %dir /var/run/mdadm
|
%attr(0700,root,root) %dir /var/run/mdadm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 11 2007 Doug Ledford <dledford@redhat.com> - 2.6.1-3
|
||||||
|
- Various cleanups as part of merge review process
|
||||||
|
- Related: bz226134
|
||||||
|
|
||||||
* Sat Mar 31 2007 Doug Ledford <dledford@redhat.com> - 2.6.1-2
|
* Sat Mar 31 2007 Doug Ledford <dledford@redhat.com> - 2.6.1-2
|
||||||
- Oops, missing a dependency in the Makefile
|
- Oops, missing a dependency in the Makefile
|
||||||
|
|
||||||
@ -190,7 +200,7 @@ fi
|
|||||||
- add patch with reallyforce mode on creation to be used by anaconda
|
- add patch with reallyforce mode on creation to be used by anaconda
|
||||||
|
|
||||||
* Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
|
* Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
|
||||||
- Fix a bug in the %postun scriptlet related to downgrading to a version
|
- Fix a bug in the postun scriptlet related to downgrading to a version
|
||||||
of mdadm that doesn't include the mdmpd daemon.
|
of mdadm that doesn't include the mdmpd daemon.
|
||||||
|
|
||||||
* Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
|
* Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
|
||||||
|
Loading…
Reference in New Issue
Block a user