Update to latest upstream release

Signed-off-by: Doug Ledford <dledford@redhat.com>
This commit is contained in:
Doug Ledford 2011-03-28 10:27:34 -04:00
parent 5c2839000f
commit 0278b6d64f
5 changed files with 33 additions and 18 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@ mdadm-3.1.5.tar.bz2
clog
*.src.rpm
*/
/mdadm-3.2.1.tar.bz2

View File

@ -1,19 +1,22 @@
--- mdadm-3.1.3-git20100804/Makefile.static 2010-07-28 23:50:15.000000000 -0400
+++ mdadm-3.1.3-git20100804/Makefile 2010-08-04 11:28:08.603342301 -0400
@@ -68,9 +68,9 @@ CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)
--- mdadm-3.2.1/Makefile.static 2011-03-27 22:31:20.000000000 -0400
+++ mdadm-3.2.1/Makefile 2011-03-28 10:16:55.277900184 -0400
@@ -68,11 +68,11 @@ CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)
# pivotroot from early boot to late boot.
# /dev is an odd place to put this, but it is the only directory that
# meets the requirements.
-MAP_DIR=/dev/.mdadm
-MAP_FILE = map
-MDMON_DIR = /dev/.mdadm
+MAP_DIR = /dev/md
+MAP_DIR=/dev/md
+MAP_FILE = md-device-map
+MDMON_DIR = /dev/md
# place for autoreplace cookies
-FAILED_SLOTS_DIR = /dev/.mdadm/failed-slots
+FAILED_SLOTS_DIR = /dev/md/failed-slots
DIRFLAGS = -DMAP_DIR=\"$(MAP_DIR)\" -DMAP_FILE=\"$(MAP_FILE)\"
DIRFLAGS += -DMDMON_DIR=\"$(MDMON_DIR)\"
CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS) $(DIRFLAGS)
@@ -224,16 +223,16 @@ install : mdadm mdmon install-man instal
DIRFLAGS += -DFAILED_SLOTS_DIR=\"$(FAILED_SLOTS_DIR)\"
@@ -238,16 +238,16 @@ install : mdadm mdmon install-man instal
$(INSTALL) -D $(STRIP) -m 755 mdmon $(DESTDIR)$(BINDIR)/mdmon
install-static : mdadm.static install-man

View File

@ -1,15 +1,20 @@
--- mdadm-3.1.3-git20100722/udev-md-raid.rules.no-incremental 2010-07-22 12:11:39.188967623 -0400
+++ mdadm-3.1.3-git20100722/udev-md-raid.rules 2010-07-22 12:12:24.298092552 -0400
@@ -3,8 +3,10 @@
--- mdadm-3.2.1/udev-md-raid.rules.udev 2011-03-27 22:31:20.000000000 -0400
+++ mdadm-3.2.1/udev-md-raid.rules 2011-03-28 10:14:26.047232843 -0400
@@ -2,11 +2,13 @@
SUBSYSTEM!="block", GOTO="md_end"
+# In Fedora we handle the raid components in 65-md-incremental.rules so that
+# we can do things like honor anaconda command line options and such
# handle potential components of arrays
-ENV{ID_FS_TYPE}=="linux_raid_member", ACTION=="remove", RUN+="/sbin/mdadm -If $name"
-ENV{ID_FS_TYPE}=="linux_raid_member", ACTION=="remove", RUN+="/sbin/mdadm -If $name --path $env{ID_PATH}"
-ENV{ID_FS_TYPE}=="linux_raid_member", ACTION=="add", RUN+="/sbin/mdadm --incremental $env{DEVNAME}"
+# Note: in Fedora we handle incremental assembly in 65-incremental.rules so
+# we can do things like honor anaconda install options
+#ENV{ID_FS_TYPE}=="linux_raid_member", ACTION=="remove", RUN+="/sbin/mdadm -If $name"
-ENV{ID_FS_TYPE}=="isw_raid_member", ACTION=="remove", RUN+="/sbin/mdadm -If $name --path $env{ID_PATH}"
-ENV{ID_FS_TYPE}=="isw_raid_member", ACTION=="add", RUN+="/sbin/mdadm --incremental $env{DEVNAME}"
+#ENV{ID_FS_TYPE}=="linux_raid_member", ACTION=="remove", RUN+="/sbin/mdadm -If $name --path $env{ID_PATH}"
+#ENV{ID_FS_TYPE}=="linux_raid_member", ACTION=="add", RUN+="/sbin/mdadm --incremental $env{DEVNAME}"
+#ENV{ID_FS_TYPE}=="isw_raid_member", ACTION=="remove", RUN+="/sbin/mdadm -If $name --path $env{ID_PATH}"
+#ENV{ID_FS_TYPE}=="isw_raid_member", ACTION=="add", RUN+="/sbin/mdadm --incremental $env{DEVNAME}"
# handle md arrays
ACTION!="add|change", GOTO="md_end"

View File

@ -1,7 +1,7 @@
Summary: The mdadm program controls Linux md devices (software RAID arrays)
Name: mdadm
Version: 3.1.5
Release: 1%{?dist}
Version: 3.2.1
Release: 0%{?dist}.1
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.bz2
Source1: mdmonitor.init
Source2: raid-check
@ -30,12 +30,13 @@ file can be used to help with some common tasks.
%prep
%setup -q
%patch0 -p1 -b .param
#%patch0 -p1 -b .param
%patch19 -p1 -b .udev
%patch20 -p1 -b .static
%build
make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
#make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
make -j30 CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
%install
rm -rf %{buildroot}
@ -80,6 +81,11 @@ fi
%ghost %attr(0700,root,root) %dir /var/run/mdadm
%changelog
* Mon Mar 28 2011 Doug Ledford <dledford@redhat.com> - 3.2.1-0.fc16.1
- Test build of latest upstream version. Will build for real once I know
if I need to fix up the param patch
- Related: 691353
* Fri Mar 25 2011 Doug Ledford <dledford@redhat.com> - 3.1.5-1
- Update to latest upstream stable release
- Update mdadm.rules file to honor noiswmd and nodmraid command line options

View File

@ -1 +1 @@
a7575707a5f2d1ed6d408446eabcb19b mdadm-3.1.5.tar.bz2
d1e2549202bd79d9e99f1498d1109530 mdadm-3.2.1.tar.bz2