mc/mc-extensions.patch
Jindrich Novy 4567fd4608 - fix hotkey conflict in Layout options (#183282)
- move syntax configuration file from /usr/share/mc to /etc/mc
- save layout settings pernamently for showing free space, not only for
    current session (#182127)
- fix audio bindings, make firefox default html binding
2006-02-28 11:14:11 +00:00

166 lines
4.2 KiB
Diff

--- mc-4.6.1a/configure.ac.extensions 2005-11-11 03:03:55.000000000 +0100
+++ mc-4.6.1a/configure.ac 2006-02-28 11:54:30.000000000 +0100
@@ -83,7 +83,7 @@ AC_PROG_LN_S
AC_CHECK_TOOL(AR, ar, ar)
dnl Only list browsers here that can be run in background (i.e. with `&')
-AC_CHECK_PROGS(X11_WWW, [gnome-moz-remote mozilla konqueror opera netscape])
+AC_CHECK_PROGS(X11_WWW, [firefox gnome-moz-remote mozilla konqueror opera netscape])
dnl
dnl Ovverriding mmap support. This has to be before AC_FUNC_MMAP is used.
--- mc-4.6.1a/configure.extensions 2006-02-15 21:12:35.000000000 +0100
+++ mc-4.6.1a/configure 2006-02-28 12:03:54.000000000 +0100
@@ -5791,7 +5791,7 @@ else
fi
-for ac_prog in gnome-moz-remote mozilla konqueror opera netscape
+for ac_prog in firefox gnome-moz-remote mozilla konqueror opera netscape
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2
--- mc-4.6.1a/lib/mc.ext.in.extensions 2005-09-06 11:20:01.000000000 +0200
+++ mc-4.6.1a/lib/mc.ext.in 2005-12-06 09:22:37.000000000 +0100
@@ -216,14 +221,25 @@ shell/.7z
# C
shell/.c
- Open=%var{EDITOR:vi} %f
+ Include=editor
# Fortran
shell/.f
- Open=%var{EDITOR:vi} %f
+ Include=editor
# Header
regex/\.(h|hpp)$
+ Include=editor
+
+# Asm
+regex/\.([Ss]|[Aa]sm|ASM)$
+ Include=editor
+
+# C++
+regex/\.(C|cc|[Cc]pp|CPP)$
+ Inlude=editor
+
+include/editor
Open=%var{EDITOR:vi} %f
# Object
@@ -248,9 +264,11 @@ regex/\.(te?xi|texinfo)$
# GNU Info page
type/^Info\ text
Open=info -f %f
+ #Open=pinfo %f
shell/.info
Open=info -f %f
+ #Open=pinfo %f
# Manual page
# Exception - .so libraries are not manual pages
@@ -319,6 +337,12 @@ type/^PPM
type/^Netpbm
Include=image
+type/^JNG
+ Include=image
+
+type/^MNG
+ Include=image
+
shell/.xcf
Open=gimp %f
@@ -330,7 +354,7 @@ shell/.xpm
View=sxpm %f
include/image
- Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (gqview %f &); fi
+ Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (display %f &); fi
View=%view{ascii} identify %f
#View=%view{ascii} asciiview %f
@@ -348,8 +372,12 @@ regex/\.([wW][aA][wW]22)$
Open=vplay -s 22 %f
regex/\.([mM][pP]3)$
- Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f &); fi
- View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+ Include=audio
+ #Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f &); fi
+ #View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+
+regex/\.([mM][kK][aA])$
+ Include=audio
regex/\.([oO][gG][gG])$
Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f &); fi
@@ -362,6 +390,9 @@ regex/\.([wW][mM][aA])$
Open=mplayer -vo null %f
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
+include/audio
+ Open=mplayer %f
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
### Play lists ###
@@ -386,20 +417,27 @@ regex/\.([mM][oO][vV]|[qQ][tT])$
regex/\.([mM][pP]4|[mM][pP][eE]?[gG])$
Include=video
+regex/\.([mM][kK][vV])$
+ Include=video
+
regex/\.([vV][oO][bB])$
Include=video
regex/\.([wW][mM][vV])$
Include=video
+regex/\.([fF][lL][iIcC])$
+ Include=video
+
regex/\.([oO][gG][mM])$
Include=video
regex/\.([rR][aA]?[mM])$
- Open=(realplay %f >/dev/null 2>&1 &)
+ Include=video
include/video
Open=(mplayer %f >/dev/null 2>&1 &)
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
#Open=(gtv %f >/dev/null 2>&1 &)
#Open=(xanim %f >/dev/null 2>&1 &)
@@ -408,12 +446,13 @@ include/video
# Postscript
type/^PostScript
- Open=(gv %f &)
+ Open=(evince %f >/dev/null 2>&1 &)
View=%view{ascii} ps2ascii %f
# PDF
type/^PDF
- Open=(xpdf %f &)
+ Open=(evince %f >/dev/null 2>&1 &)
+ #Open=(xpdf %f >/dev/null 2>&1 &)
#Open=(acroread %f &)
#Open=(ghostview %f &)
View=%view{ascii} pdftotext %f -
@@ -424,7 +463,7 @@ type/^PDF
# html
regex/\.([hH][tT][mM][lL]?)$
Open=(if test -n "@X11_WWW@" && test -n "$DISPLAY"; then (@X11_WWW@ file://%d/%p &) 1>&2; else links %f || lynx -force_html %f || ${PAGER:-more} %f; fi) 2>/dev/null
- View=%view{ascii} lynx -dump -force_html %f
+ View=%view{ascii} links -dump %f
# StarOffice 5.2
shell/.sdw