- fix hotkey conflict in Layout options (#183282)
- move syntax configuration file from /usr/share/mc to /etc/mc - save layout settings pernamently for showing free space, not only for current session (#182127) - fix audio bindings, make firefox default html binding
This commit is contained in:
parent
7f70c24d4b
commit
4567fd4608
@ -1,3 +1,25 @@
|
||||
--- mc-4.6.1a/configure.ac.extensions 2005-11-11 03:03:55.000000000 +0100
|
||||
+++ mc-4.6.1a/configure.ac 2006-02-28 11:54:30.000000000 +0100
|
||||
@@ -83,7 +83,7 @@ AC_PROG_LN_S
|
||||
AC_CHECK_TOOL(AR, ar, ar)
|
||||
|
||||
dnl Only list browsers here that can be run in background (i.e. with `&')
|
||||
-AC_CHECK_PROGS(X11_WWW, [gnome-moz-remote mozilla konqueror opera netscape])
|
||||
+AC_CHECK_PROGS(X11_WWW, [firefox gnome-moz-remote mozilla konqueror opera netscape])
|
||||
|
||||
dnl
|
||||
dnl Ovverriding mmap support. This has to be before AC_FUNC_MMAP is used.
|
||||
--- mc-4.6.1a/configure.extensions 2006-02-15 21:12:35.000000000 +0100
|
||||
+++ mc-4.6.1a/configure 2006-02-28 12:03:54.000000000 +0100
|
||||
@@ -5791,7 +5791,7 @@ else
|
||||
fi
|
||||
|
||||
|
||||
-for ac_prog in gnome-moz-remote mozilla konqueror opera netscape
|
||||
+for ac_prog in firefox gnome-moz-remote mozilla konqueror opera netscape
|
||||
do
|
||||
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
||||
set dummy $ac_prog; ac_word=$2
|
||||
--- mc-4.6.1a/lib/mc.ext.in.extensions 2005-09-06 11:20:01.000000000 +0200
|
||||
+++ mc-4.6.1a/lib/mc.ext.in 2005-12-06 09:22:37.000000000 +0100
|
||||
@@ -216,14 +221,25 @@ shell/.7z
|
||||
@ -81,7 +103,7 @@
|
||||
Open=mplayer -vo null %f
|
||||
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
|
||||
|
||||
+Include/audio
|
||||
+include/audio
|
||||
+ Open=mplayer %f
|
||||
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
|
||||
|
||||
|
@ -1,5 +1,15 @@
|
||||
--- mc-4.6.1a/src/screen.c.showfree 2006-02-01 15:47:58.000000000 +0100
|
||||
+++ mc-4.6.1a/src/screen.c 2006-02-01 15:47:58.000000000 +0100
|
||||
--- mc-4.6.1a/src/setup.c.showfree 2006-01-29 21:26:05.000000000 +0100
|
||||
+++ mc-4.6.1a/src/setup.c 2006-02-28 11:43:49.000000000 +0100
|
||||
@@ -133,6 +133,7 @@ static const struct {
|
||||
{ "show_mini_info", &show_mini_info },
|
||||
{ "permission_mode", &permission_mode },
|
||||
{ "filetype_mode", &filetype_mode },
|
||||
+ { "free_space", &free_space },
|
||||
{ 0, 0 }
|
||||
};
|
||||
|
||||
--- mc-4.6.1a/src/screen.c.showfree 2006-02-28 11:42:47.000000000 +0100
|
||||
+++ mc-4.6.1a/src/screen.c 2006-02-28 11:42:48.000000000 +0100
|
||||
@@ -49,6 +49,7 @@
|
||||
#define WANT_WIDGETS
|
||||
#include "main.h" /* the_menubar */
|
||||
@ -80,8 +90,8 @@
|
||||
if (panel->active)
|
||||
standend ();
|
||||
}
|
||||
--- mc-4.6.1a/src/layout.c.showfree 2006-02-01 15:47:58.000000000 +0100
|
||||
+++ mc-4.6.1a/src/layout.c 2006-02-01 15:48:27.000000000 +0100
|
||||
--- mc-4.6.1a/src/layout.c.showfree 2006-02-28 11:42:47.000000000 +0100
|
||||
+++ mc-4.6.1a/src/layout.c 2006-02-28 11:42:48.000000000 +0100
|
||||
@@ -99,6 +99,9 @@ int message_visible = 1;
|
||||
/* Set to show current working dir in xterm window title */
|
||||
int xterm_title = 1;
|
||||
@ -104,7 +114,7 @@
|
||||
int *variable;
|
||||
WCheck *widget;
|
||||
} check_options [] = {
|
||||
+ { N_("show free &Space"), &free_space, 0 },
|
||||
+ { N_("show free sp&Ace"), &free_space, 0 },
|
||||
{ N_("&Xterm window title"), &xterm_title, 0 },
|
||||
{ N_("h&Intbar visible"), &message_visible, 0 },
|
||||
{ N_("&Keybar visible"), &keybar_visible, 0 },
|
||||
@ -218,7 +228,7 @@
|
||||
add_widget (layout_dlg, radio_widget);
|
||||
radio_widget->sel = horizontal_split;
|
||||
--- mc-4.6.1a/src/layout.h.showfree 2004-12-03 20:17:47.000000000 +0100
|
||||
+++ mc-4.6.1a/src/layout.h 2006-02-01 15:47:58.000000000 +0100
|
||||
+++ mc-4.6.1a/src/layout.h 2006-02-28 11:42:48.000000000 +0100
|
||||
@@ -39,6 +39,7 @@ extern int keybar_visible;
|
||||
extern int output_start_y;
|
||||
extern int message_visible;
|
||||
|
12
mc.spec
12
mc.spec
@ -1,7 +1,7 @@
|
||||
Summary: User-friendly text console file manager and visual shell.
|
||||
Name: mc
|
||||
Version: 4.6.1a
|
||||
Release: 8
|
||||
Release: 9
|
||||
Epoch: 1
|
||||
License: GPL
|
||||
Group: System Environment/Shells
|
||||
@ -109,6 +109,7 @@ done
|
||||
popd
|
||||
|
||||
%build
|
||||
export CC="ccache gcc"
|
||||
export CFLAGS="-DUTF8=1 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS"
|
||||
%configure --with-screen=slang \
|
||||
--host=%{_host} --build=%{_build} \
|
||||
@ -138,6 +139,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/mc
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/mc/extfs
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/mc/syntax
|
||||
|
||||
%{makeinstall} sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
|
||||
|
||||
@ -147,6 +149,7 @@ install lib/{mc.sh,mc.csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
|
||||
mv -f $RPM_BUILD_ROOT%{_datadir}/mc/{cedit.menu,edit.indent.rc,edit.spell.rc,\
|
||||
mc.ext,mc.lib,mc.menu,mc.charsets} $RPM_BUILD_ROOT%{_sysconfdir}/mc
|
||||
mv -f $RPM_BUILD_ROOT%{_datadir}/mc/extfs/*.ini $RPM_BUILD_ROOT%{_sysconfdir}/mc/extfs
|
||||
mv -f $RPM_BUILD_ROOT%{_datadir}/mc/syntax/Syntax $RPM_BUILD_ROOT%{_sysconfdir}/mc/syntax
|
||||
|
||||
# install man pages in various languages
|
||||
for l in es hu it pl ru sr; do
|
||||
@ -190,6 +193,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_sysconfdir}/mc
|
||||
|
||||
%changelog
|
||||
* Tue Feb 28 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-9
|
||||
- fix hotkey conflict in Layout options (#183282)
|
||||
- move syntax configuration file from /usr/share/mc to /etc/mc
|
||||
- save layout settings pernamently for showing free space, not
|
||||
only for current session (#182127)
|
||||
- fix audio bindings, make firefox default html binding
|
||||
|
||||
* Sat Feb 25 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-8
|
||||
- make mc FHS compliant: store config files in /etc/mc and
|
||||
extfs/*.ini files in /etc/mc/extfs instead of /usr/share/mc
|
||||
|
Loading…
Reference in New Issue
Block a user