91e4f40a90
Resolves: #1960618
195 lines
10 KiB
Diff
195 lines
10 KiB
Diff
From 7629e3185849f2fb76fe8378f03cf25f6ffe3de6 Mon Sep 17 00:00:00 2001
|
|
From: Marian Csontos <mcsontos@redhat.com>
|
|
Date: Mon, 26 Apr 2021 14:27:05 +0200
|
|
Subject: [PATCH 10/10] configure: update
|
|
|
|
---
|
|
configure | 108 ++++++++++++++++++++++++++++++++++++++++++++++++-
|
|
include/configure.h.in | 3 ++
|
|
2 files changed, 110 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure b/configure
|
|
index 7c6bd48..54bc1ef 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -774,6 +774,8 @@ SYSTEMD_LIBS
|
|
SYSTEMD_CFLAGS
|
|
BLKID_LIBS
|
|
BLKID_CFLAGS
|
|
+APP_MACHINEID_LIBS
|
|
+APP_MACHINEID_CFLAGS
|
|
NOTIFY_DBUS_LIBS
|
|
NOTIFY_DBUS_CFLAGS
|
|
LOCKD_DLM_CONTROL_LIBS
|
|
@@ -952,6 +954,7 @@ enable_use_lvmpolld
|
|
with_lvmpolld_pidfile
|
|
enable_dmfilemapd
|
|
enable_notify_dbus
|
|
+enable_app_machineid
|
|
enable_blkid_wiping
|
|
enable_udev_systemd_background_jobs
|
|
enable_udev_sync
|
|
@@ -1021,6 +1024,8 @@ LOCKD_DLM_CONTROL_CFLAGS
|
|
LOCKD_DLM_CONTROL_LIBS
|
|
NOTIFY_DBUS_CFLAGS
|
|
NOTIFY_DBUS_LIBS
|
|
+APP_MACHINEID_CFLAGS
|
|
+APP_MACHINEID_LIBS
|
|
BLKID_CFLAGS
|
|
BLKID_LIBS
|
|
SYSTEMD_CFLAGS
|
|
@@ -1682,6 +1687,7 @@ Optional Features:
|
|
--disable-use-lvmpolld disable usage of LVM Poll Daemon
|
|
--enable-dmfilemapd enable the dmstats filemap daemon
|
|
--enable-notify-dbus enable LVM notification using dbus
|
|
+ --enable-app-machineid enable LVM system ID using app-specific machine-id
|
|
--disable-blkid_wiping disable libblkid detection of signatures when wiping
|
|
and use native code instead
|
|
--disable-udev-systemd-background-jobs
|
|
@@ -1836,6 +1842,10 @@ Some influential environment variables:
|
|
C compiler flags for NOTIFY_DBUS, overriding pkg-config
|
|
NOTIFY_DBUS_LIBS
|
|
linker flags for NOTIFY_DBUS, overriding pkg-config
|
|
+ APP_MACHINEID_CFLAGS
|
|
+ C compiler flags for APP_MACHINEID, overriding pkg-config
|
|
+ APP_MACHINEID_LIBS
|
|
+ linker flags for APP_MACHINEID, overriding pkg-config
|
|
BLKID_CFLAGS
|
|
C compiler flags for BLKID, overriding pkg-config
|
|
BLKID_LIBS linker flags for BLKID, overriding pkg-config
|
|
@@ -11410,6 +11420,101 @@ fi
|
|
fi
|
|
|
|
################################################################################
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to build appmachineid" >&5
|
|
+$as_echo_n "checking whether to build appmachineid... " >&6; }
|
|
+# Check whether --enable-app-machineid was given.
|
|
+if test "${enable_app_machineid+set}" = set; then :
|
|
+ enableval=$enable_app_machineid; APP_MACHINEID_SUPPORT=$enableval
|
|
+else
|
|
+ APP_MACHINEID_SUPPORT=no
|
|
+fi
|
|
+
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $APP_MACHINEID_SUPPORT" >&5
|
|
+$as_echo "$APP_MACHINEID_SUPPORT" >&6; }
|
|
+
|
|
+if test "$APP_MACHINEID_SUPPORT" = yes; then
|
|
+
|
|
+$as_echo "#define APP_MACHINEID_SUPPORT 1" >>confdefs.h
|
|
+
|
|
+ SYSTEMD_LIBS="-lsystemd"
|
|
+fi
|
|
+
|
|
+################################################################################
|
|
+if test "$APP_MACHINEID_SUPPORT" = yes; then
|
|
+
|
|
+pkg_failed=no
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for APP_MACHINEID" >&5
|
|
+$as_echo_n "checking for APP_MACHINEID... " >&6; }
|
|
+
|
|
+if test -n "$APP_MACHINEID_CFLAGS"; then
|
|
+ pkg_cv_APP_MACHINEID_CFLAGS="$APP_MACHINEID_CFLAGS"
|
|
+ elif test -n "$PKG_CONFIG"; then
|
|
+ if test -n "$PKG_CONFIG" && \
|
|
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"systemd >= 234\""; } >&5
|
|
+ ($PKG_CONFIG --exists --print-errors "systemd >= 234") 2>&5
|
|
+ ac_status=$?
|
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
+ test $ac_status = 0; }; then
|
|
+ pkg_cv_APP_MACHINEID_CFLAGS=`$PKG_CONFIG --cflags "systemd >= 234" 2>/dev/null`
|
|
+ test "x$?" != "x0" && pkg_failed=yes
|
|
+else
|
|
+ pkg_failed=yes
|
|
+fi
|
|
+ else
|
|
+ pkg_failed=untried
|
|
+fi
|
|
+if test -n "$APP_MACHINEID_LIBS"; then
|
|
+ pkg_cv_APP_MACHINEID_LIBS="$APP_MACHINEID_LIBS"
|
|
+ elif test -n "$PKG_CONFIG"; then
|
|
+ if test -n "$PKG_CONFIG" && \
|
|
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"systemd >= 234\""; } >&5
|
|
+ ($PKG_CONFIG --exists --print-errors "systemd >= 234") 2>&5
|
|
+ ac_status=$?
|
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
+ test $ac_status = 0; }; then
|
|
+ pkg_cv_APP_MACHINEID_LIBS=`$PKG_CONFIG --libs "systemd >= 234" 2>/dev/null`
|
|
+ test "x$?" != "x0" && pkg_failed=yes
|
|
+else
|
|
+ pkg_failed=yes
|
|
+fi
|
|
+ else
|
|
+ pkg_failed=untried
|
|
+fi
|
|
+
|
|
+
|
|
+
|
|
+if test $pkg_failed = yes; then
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+
|
|
+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
|
+ _pkg_short_errors_supported=yes
|
|
+else
|
|
+ _pkg_short_errors_supported=no
|
|
+fi
|
|
+ if test $_pkg_short_errors_supported = yes; then
|
|
+ APP_MACHINEID_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "systemd >= 234" 2>&1`
|
|
+ else
|
|
+ APP_MACHINEID_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "systemd >= 234" 2>&1`
|
|
+ fi
|
|
+ # Put the nasty error message in config.log where it belongs
|
|
+ echo "$APP_MACHINEID_PKG_ERRORS" >&5
|
|
+
|
|
+ $bailout
|
|
+elif test $pkg_failed = untried; then
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+ $bailout
|
|
+else
|
|
+ APP_MACHINEID_CFLAGS=$pkg_cv_APP_MACHINEID_CFLAGS
|
|
+ APP_MACHINEID_LIBS=$pkg_cv_APP_MACHINEID_LIBS
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
+$as_echo "yes" >&6; }
|
|
+ HAVE_APP_MACHINEID=yes
|
|
+fi
|
|
+fi
|
|
+
|
|
+################################################################################
|
|
|
|
# Check whether --enable-blkid_wiping was given.
|
|
if test "${enable_blkid_wiping+set}" = set; then :
|
|
@@ -14181,7 +14286,7 @@ _ACEOF
|
|
|
|
|
|
################################################################################
|
|
-ac_config_files="$ac_config_files Makefile make.tmpl libdm/make.tmpl daemons/Makefile daemons/cmirrord/Makefile daemons/dmeventd/Makefile daemons/dmeventd/libdevmapper-event.pc daemons/dmeventd/plugins/Makefile daemons/dmeventd/plugins/lvm2/Makefile daemons/dmeventd/plugins/raid/Makefile daemons/dmeventd/plugins/mirror/Makefile daemons/dmeventd/plugins/snapshot/Makefile daemons/dmeventd/plugins/thin/Makefile daemons/dmeventd/plugins/vdo/Makefile daemons/lvmdbusd/Makefile daemons/lvmdbusd/lvmdbusd daemons/lvmdbusd/lvmdb.py daemons/lvmdbusd/lvm_shell_proxy.py daemons/lvmdbusd/path.py daemons/lvmpolld/Makefile daemons/lvmlockd/Makefile conf/Makefile conf/example.conf conf/lvmlocal.conf conf/command_profile_template.profile conf/metadata_profile_template.profile include/Makefile lib/Makefile include/lvm-version.h libdaemon/Makefile libdaemon/client/Makefile libdaemon/server/Makefile libdm/Makefile libdm/dm-tools/Makefile libdm/libdevmapper.pc man/Makefile po/Makefile scripts/lvm2-pvscan.service scripts/blkdeactivate.sh scripts/blk_availability_init_red_hat scripts/blk_availability_systemd_red_hat.service scripts/cmirrord_init_red_hat scripts/com.redhat.lvmdbus1.service scripts/dm_event_systemd_red_hat.service scripts/dm_event_systemd_red_hat.socket scripts/lvm2_cmirrord_systemd_red_hat.service scripts/lvm2_lvmdbusd_systemd_red_hat.service scripts/lvm2_lvmpolld_init_red_hat scripts/lvm2_lvmpolld_systemd_red_hat.service scripts/lvm2_lvmpolld_systemd_red_hat.socket scripts/lvmlockd.service scripts/lvmlocks.service scripts/lvm2_monitoring_init_red_hat scripts/lvm2_monitoring_systemd_red_hat.service scripts/lvm2_tmpfiles_red_hat.conf scripts/lvmdump.sh scripts/Makefile test/Makefile tools/Makefile udev/Makefile"
|
|
+ac_config_files="$ac_config_files Makefile make.tmpl libdm/make.tmpl daemons/Makefile daemons/cmirrord/Makefile daemons/dmeventd/Makefile daemons/dmeventd/libdevmapper-event.pc daemons/dmeventd/plugins/Makefile daemons/dmeventd/plugins/lvm2/Makefile daemons/dmeventd/plugins/raid/Makefile daemons/dmeventd/plugins/mirror/Makefile daemons/dmeventd/plugins/snapshot/Makefile daemons/dmeventd/plugins/thin/Makefile daemons/dmeventd/plugins/vdo/Makefile daemons/lvmdbusd/Makefile daemons/lvmdbusd/lvmdbusd daemons/lvmdbusd/lvmdb.py daemons/lvmdbusd/lvm_shell_proxy.py daemons/lvmdbusd/path.py daemons/lvmpolld/Makefile daemons/lvmlockd/Makefile conf/Makefile conf/example.conf conf/lvmlocal.conf conf/command_profile_template.profile conf/metadata_profile_template.profile include/Makefile lib/Makefile include/lvm-version.h libdaemon/Makefile libdaemon/client/Makefile libdaemon/server/Makefile libdm/Makefile libdm/dm-tools/Makefile libdm/libdevmapper.pc man/Makefile po/Makefile scripts/lvm2-pvscan.service scripts/lvm-vgchange.service scripts/blkdeactivate.sh scripts/blk_availability_init_red_hat scripts/blk_availability_systemd_red_hat.service scripts/cmirrord_init_red_hat scripts/com.redhat.lvmdbus1.service scripts/dm_event_systemd_red_hat.service scripts/dm_event_systemd_red_hat.socket scripts/lvm2_cmirrord_systemd_red_hat.service scripts/lvm2_lvmdbusd_systemd_red_hat.service scripts/lvm2_lvmpolld_init_red_hat scripts/lvm2_lvmpolld_systemd_red_hat.service scripts/lvm2_lvmpolld_systemd_red_hat.socket scripts/lvmlockd.service scripts/lvmlocks.service scripts/lvm2_monitoring_init_red_hat scripts/lvm2_monitoring_systemd_red_hat.service scripts/lvm2_tmpfiles_red_hat.conf scripts/lvmdump.sh scripts/Makefile test/Makefile tools/Makefile udev/Makefile"
|
|
|
|
cat >confcache <<\_ACEOF
|
|
# This file is a shell script that caches the results of configure
|
|
@@ -14914,6 +15019,7 @@ do
|
|
"man/Makefile") CONFIG_FILES="$CONFIG_FILES man/Makefile" ;;
|
|
"po/Makefile") CONFIG_FILES="$CONFIG_FILES po/Makefile" ;;
|
|
"scripts/lvm2-pvscan.service") CONFIG_FILES="$CONFIG_FILES scripts/lvm2-pvscan.service" ;;
|
|
+ "scripts/lvm-vgchange.service") CONFIG_FILES="$CONFIG_FILES scripts/lvm-vgchange.service" ;;
|
|
"scripts/blkdeactivate.sh") CONFIG_FILES="$CONFIG_FILES scripts/blkdeactivate.sh" ;;
|
|
"scripts/blk_availability_init_red_hat") CONFIG_FILES="$CONFIG_FILES scripts/blk_availability_init_red_hat" ;;
|
|
"scripts/blk_availability_systemd_red_hat.service") CONFIG_FILES="$CONFIG_FILES scripts/blk_availability_systemd_red_hat.service" ;;
|
|
diff --git a/include/configure.h.in b/include/configure.h.in
|
|
index 671d201..c680525 100644
|
|
--- a/include/configure.h.in
|
|
+++ b/include/configure.h.in
|
|
@@ -1,5 +1,8 @@
|
|
/* include/configure.h.in. Generated from configure.ac by autoheader. */
|
|
|
|
+/* Define to 1 to include code that uses libsystemd machine-id apis. */
|
|
+#undef APP_MACHINEID_SUPPORT
|
|
+
|
|
/* Define to 1 to use libblkid detection of signatures when wiping. */
|
|
#undef BLKID_WIPING_SUPPORT
|
|
|
|
--
|
|
1.8.3.1
|
|
|