64 lines
3.1 KiB
Diff
64 lines
3.1 KiB
Diff
diff --git a/lvm2.spec b/lvm2.spec
|
|
index 2776625..ac160f3 100644
|
|
--- a/lvm2.spec
|
|
+++ b/lvm2.spec
|
|
@@ -37,7 +37,7 @@
|
|
Summary: Userland logical volume management tools
|
|
Name: lvm2
|
|
Version: 2.02.98
|
|
-Release: 1%{?dist}
|
|
+Release: 2%{?dist}
|
|
License: GPLv2
|
|
Group: System Environment/Base
|
|
URL: http://sources.redhat.com/lvm2
|
|
@@ -55,6 +55,8 @@ BuildRequires: module-init-tools
|
|
BuildRequires: pkgconfig
|
|
BuildRequires: systemd-devel
|
|
BuildRequires: systemd-units
|
|
+BuildRequires: python2-devel
|
|
+BuildRequires: python-setuptools
|
|
Requires: %{name}-libs = %{version}-%{release}
|
|
Requires: bash >= %{bash_version}
|
|
Requires(post): systemd-units >= %{systemd_version}, systemd-sysv
|
|
@@ -97,7 +99,7 @@ or more physical volumes and creating one or more logical volumes
|
|
%define configure_lvmetad --enable-lvmetad
|
|
%endif
|
|
|
|
-%configure --with-default-dm-run-dir=%{_default_dm_run_dir} --with-default-run-dir=%{_default_run_dir} --with-default-pid-dir=%{_default_pid_dir} --with-default-locking-dir=%{_default_locking_dir} --with-usrlibdir=%{_libdir} --enable-lvm1_fallback --enable-fsadm --with-pool=internal --with-user= --with-group= --with-device-uid=0 --with-device-gid=6 --with-device-mode=0660 --enable-pkgconfig --enable-applib --enable-cmdlib --enable-dmeventd %{configure_cluster} %{configure_cmirror} %{?configure_udev} %{?configure_thin} %{?configure_lvmetad}
|
|
+%configure --with-default-dm-run-dir=%{_default_dm_run_dir} --with-default-run-dir=%{_default_run_dir} --with-default-pid-dir=%{_default_pid_dir} --with-default-locking-dir=%{_default_locking_dir} --with-usrlibdir=%{_libdir} --enable-lvm1_fallback --enable-fsadm --with-pool=internal --with-user= --with-group= --with-device-uid=0 --with-device-gid=6 --with-device-mode=0660 --enable-pkgconfig --enable-applib --enable-cmdlib --enable-python-bindings --enable-dmeventd %{configure_cluster} %{configure_cmirror} %{?configure_udev} %{?configure_thin} %{?configure_lvmetad}
|
|
|
|
make %{?_smp_mflags}
|
|
|
|
@@ -317,6 +319,21 @@ This package contains shared lvm2 libraries for applications.
|
|
%{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
|
|
%endif
|
|
|
|
+%package python-libs
|
|
+Summary: Python module to access LVM
|
|
+License: LGPLv2
|
|
+Group: Development/Libraries
|
|
+Provides: python-lvm = %{version}-%{release}
|
|
+Obsoletes: python-lvm < 2.02.98-2
|
|
+Requires: %{name}-libs = %{version}-%{release}
|
|
+
|
|
+%description python-libs
|
|
+Python module to allow the creation and use of LVM
|
|
+logical volumes, physical volumes, and volume groups.
|
|
+
|
|
+%files python-libs
|
|
+%{python_sitearch}/*
|
|
+
|
|
##############################################################################
|
|
# Cluster subpackage
|
|
##############################################################################
|
|
@@ -555,6 +572,9 @@ the device-mapper event library.
|
|
%{_libdir}/pkgconfig/devmapper-event.pc
|
|
|
|
%changelog
|
|
+* Thu Oct 18 2012 Peter Rajnoha <prajnoha@redhat.com> - 2.02.98-2
|
|
+- Incorporate former python-lvm package in lvm2 as lvm2-python-libs subpackage.
|
|
+
|
|
* Tue Oct 16 2012 Peter Rajnoha <prajnoha@redhat.com> - 2.02.98-1
|
|
- Don't try to issue discards to a missing PV to avoid segfault.
|
|
- Fix vgchange -aay not to activate non-matching LVs that follow a matching LV.
|