New upstream release with merged lvm2 & dm source trees.
This commit is contained in:
parent
aa48f2d132
commit
d193f610ea
@ -1,2 +1 @@
|
||||
LVM2.2.02.39.tgz
|
||||
device-mapper.1.02.27.tgz
|
||||
LVM2.2.02.43.tgz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD4DBQBIZWNIIoGRwVZ+LBcRAj8oAKCez7XMlp2yq9tXrfNTH8/zenDfrQCYvHwj
|
||||
1uswV0ePQdZ+dpYlB6nZNQ==
|
||||
=LiNS
|
||||
-----END PGP SIGNATURE-----
|
7
LVM2.2.02.43.tgz.asc
Normal file
7
LVM2.2.02.43.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBJGECOIoGRwVZ+LBcRAnkeAKCLV30KGPeneh7sAxXlHe0cOcGHUQCg2g97
|
||||
DpiFMTKgexLJ07U7AFX3sR0=
|
||||
=GbfG
|
||||
-----END PGP SIGNATURE-----
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBIYlmEIoGRwVZ+LBcRAp8tAKCksVw9S2hln9U3fEgcUykMtunM5ACg0SN+
|
||||
bvwl9A+KYqfLanslffEBwSY=
|
||||
=uNKV
|
||||
-----END PGP SIGNATURE-----
|
@ -1,244 +0,0 @@
|
||||
--- LVM2.2.02.39-5/configure 2008-06-27 20:57:27.000000000 +0100
|
||||
+++ LVM2.2.02.39/configure 2008-10-07 16:38:03.000000000 +0100
|
||||
@@ -731,6 +731,8 @@
|
||||
STATICDIR
|
||||
STATIC_LINK
|
||||
LIB_PTHREAD
|
||||
+usrlibdir
|
||||
+usrsbindir
|
||||
LTLIBOBJS'
|
||||
ac_subst_files=''
|
||||
ac_precious_vars='build_alias
|
||||
@@ -1353,6 +1355,8 @@
|
||||
--with-confdir=DIR Configuration files in DIR /etc
|
||||
--with-staticdir=DIR Static binary in DIR EXEC_PREFIX/sbin
|
||||
--with-dmdir=DIR Build against device-mapper source tree in DIR
|
||||
+ --with-usrlibdir=DIR
|
||||
+ --with-usrsbindir=DIR
|
||||
|
||||
Some influential environment variables:
|
||||
CC C compiler command
|
||||
@@ -9770,6 +9774,24 @@
|
||||
*) DMDIR="`pwd`/$DMDIR" ;;
|
||||
esac
|
||||
|
||||
+
|
||||
+# Check whether --with-usrlibdir was given.
|
||||
+if test "${with_usrlibdir+set}" = set; then
|
||||
+ withval=$with_usrlibdir; usrlibdir="$withval"
|
||||
+else
|
||||
+ usrlibdir='${prefix}/lib'
|
||||
+fi
|
||||
+
|
||||
+
|
||||
+
|
||||
+# Check whether --with-usrsbindir was given.
|
||||
+if test "${with_usrsbindir+set}" = set; then
|
||||
+ withval=$with_usrsbindir; usrsbindir="$withval"
|
||||
+else
|
||||
+ usrsbindir='${prefix}/sbin'
|
||||
+fi
|
||||
+
|
||||
+
|
||||
################################################################################
|
||||
if test x$READLINE = xyes; then
|
||||
|
||||
@@ -11435,6 +11457,8 @@
|
||||
|
||||
|
||||
|
||||
+
|
||||
+
|
||||
################################################################################
|
||||
ac_config_files="$ac_config_files Makefile make.tmpl include/Makefile lib/Makefile man/Makefile po/Makefile dmeventd/Makefile daemons/Makefile daemons/clvmd/Makefile dmeventd/mirror/Makefile dmeventd/snapshot/Makefile doc/Makefile lib/format1/Makefile lib/format_pool/Makefile lib/locking/Makefile lib/mirror/Makefile lib/snapshot/Makefile test/Makefile scripts/Makefile tools/Makefile tools/version.h"
|
||||
|
||||
@@ -12233,10 +12257,12 @@
|
||||
STATICDIR!$STATICDIR$ac_delim
|
||||
STATIC_LINK!$STATIC_LINK$ac_delim
|
||||
LIB_PTHREAD!$LIB_PTHREAD$ac_delim
|
||||
+usrlibdir!$usrlibdir$ac_delim
|
||||
+usrsbindir!$usrsbindir$ac_delim
|
||||
LTLIBOBJS!$LTLIBOBJS$ac_delim
|
||||
_ACEOF
|
||||
|
||||
- if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 21; then
|
||||
+ if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 23; then
|
||||
break
|
||||
elif $ac_last_try; then
|
||||
{ { echo "$as_me:$LINENO: error: could not make $CONFIG_STATUS" >&5
|
||||
--- LVM2.2.02.39-5/configure.in 2008-06-27 20:57:27.000000000 +0100
|
||||
+++ LVM2.2.02.39/configure.in 2008-10-07 16:37:57.000000000 +0100
|
||||
@@ -568,6 +568,16 @@
|
||||
*) DMDIR="`pwd`/$DMDIR" ;;
|
||||
esac
|
||||
|
||||
+AC_ARG_WITH(usrlibdir,
|
||||
+ [ --with-usrlibdir=DIR],
|
||||
+ [ usrlibdir="$withval"],
|
||||
+ [ usrlibdir='${prefix}/lib' ])
|
||||
+
|
||||
+AC_ARG_WITH(usrsbindir,
|
||||
+ [ --with-usrsbindir=DIR],
|
||||
+ [ usrsbindir="$withval"],
|
||||
+ [ usrsbindir='${prefix}/sbin' ])
|
||||
+
|
||||
################################################################################
|
||||
dnl -- Ensure additional headers required
|
||||
if test x$READLINE = xyes; then
|
||||
@@ -660,6 +670,8 @@
|
||||
AC_SUBST(STATICDIR)
|
||||
AC_SUBST(STATIC_LINK)
|
||||
AC_SUBST([LIB_PTHREAD])
|
||||
+AC_SUBST(usrlibdir)
|
||||
+AC_SUBST(usrsbindir)
|
||||
|
||||
################################################################################
|
||||
dnl -- First and last lines should not contain files to generate in order to
|
||||
--- LVM2.2.02.39-5/daemons/clvmd/Makefile.in 2008-05-19 21:06:33.000000000 +0100
|
||||
+++ LVM2.2.02.39/daemons/clvmd/Makefile.in 2008-10-07 16:37:57.000000000 +0100
|
||||
@@ -90,7 +90,7 @@
|
||||
|
||||
install_clvmd: $(TARGETS)
|
||||
$(INSTALL) -D $(OWNER) $(GROUP) -m 555 $(STRIP) clvmd \
|
||||
- $(sbindir)/clvmd
|
||||
+ $(usrsbindir)/clvmd
|
||||
|
||||
install: $(INSTALL_TARGETS)
|
||||
|
||||
--- LVM2.2.02.39-5/device-mapper.1.02.27/configure 2008-06-06 21:44:35.000000000 +0100
|
||||
+++ LVM2.2.02.39/device-mapper.1.02.27/configure 2008-10-07 16:38:08.000000000 +0100
|
||||
@@ -732,6 +732,7 @@
|
||||
kernelvsn
|
||||
tmpdir
|
||||
usrlibdir
|
||||
+usrsbindir
|
||||
LTLIBOBJS'
|
||||
ac_subst_files=''
|
||||
ac_precious_vars='build_alias
|
||||
@@ -1336,6 +1337,8 @@
|
||||
--with-device-mode=MODE Set the mode used for new device nodes [MODE=0600]
|
||||
--with-optimisation=OPT C optimisation flag [OPT=-O2]
|
||||
--with-localedir=DIR Translation files in DIR [PREFIX/share/locale]
|
||||
+ --with-usrlibdir=DIR
|
||||
+ --with-usrsbindir=DIR
|
||||
--with-kernel-dir=DIR linux kernel source in DIR
|
||||
--with-kernel-version=VERSION linux kernel version
|
||||
--with-tmp-dir=DIR temp dir to make kernel patches [/tmp/kerndiff]
|
||||
@@ -1974,9 +1977,6 @@
|
||||
esac
|
||||
|
||||
################################################################################
|
||||
-usrlibdir='${prefix}/lib'
|
||||
-
|
||||
-################################################################################
|
||||
for ac_prog in gawk mawk nawk awk
|
||||
do
|
||||
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
||||
@@ -8766,6 +8766,25 @@
|
||||
fi
|
||||
|
||||
################################################################################
|
||||
+
|
||||
+# Check whether --with-usrlibdir was given.
|
||||
+if test "${with_usrlibdir+set}" = set; then
|
||||
+ withval=$with_usrlibdir; usrlibdir="$withval"
|
||||
+else
|
||||
+ usrlibdir='${prefix}/lib'
|
||||
+fi
|
||||
+
|
||||
+
|
||||
+
|
||||
+# Check whether --with-usrsbindir was given.
|
||||
+if test "${with_usrsbindir+set}" = set; then
|
||||
+ withval=$with_usrsbindir; usrsbindir="$withval"
|
||||
+else
|
||||
+ usrsbindir='${prefix}/sbin'
|
||||
+fi
|
||||
+
|
||||
+
|
||||
+################################################################################
|
||||
{ echo "$as_me:$LINENO: checking for kernel directory" >&5
|
||||
echo $ECHO_N "checking for kernel directory... $ECHO_C" >&6; }
|
||||
|
||||
@@ -8975,6 +8994,7 @@
|
||||
|
||||
|
||||
|
||||
+
|
||||
################################################################################
|
||||
ac_config_files="$ac_config_files Makefile make.tmpl include/Makefile dmsetup/Makefile lib/Makefile lib/libdevmapper.pc dmeventd/Makefile dmeventd/libdevmapper-event.pc kernel/Makefile man/Makefile po/Makefile"
|
||||
|
||||
@@ -9763,10 +9783,11 @@
|
||||
kernelvsn!$kernelvsn$ac_delim
|
||||
tmpdir!$tmpdir$ac_delim
|
||||
usrlibdir!$usrlibdir$ac_delim
|
||||
+usrsbindir!$usrsbindir$ac_delim
|
||||
LTLIBOBJS!$LTLIBOBJS$ac_delim
|
||||
_ACEOF
|
||||
|
||||
- if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 22; then
|
||||
+ if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 23; then
|
||||
break
|
||||
elif $ac_last_try; then
|
||||
{ { echo "$as_me:$LINENO: error: could not make $CONFIG_STATUS" >&5
|
||||
--- LVM2.2.02.39-5/device-mapper.1.02.27/configure.in 2008-06-06 21:44:35.000000000 +0100
|
||||
+++ LVM2.2.02.39/device-mapper.1.02.27/configure.in 2008-10-07 16:37:57.000000000 +0100
|
||||
@@ -62,10 +62,6 @@
|
||||
esac
|
||||
|
||||
################################################################################
|
||||
-dnl -- Additional library location
|
||||
-usrlibdir='${prefix}/lib'
|
||||
-
|
||||
-################################################################################
|
||||
dnl -- Check for programs.
|
||||
AC_PROG_AWK
|
||||
AC_PROG_CC
|
||||
@@ -332,6 +328,17 @@
|
||||
fi
|
||||
|
||||
################################################################################
|
||||
+AC_ARG_WITH(usrlibdir,
|
||||
+ [ --with-usrlibdir=DIR],
|
||||
+ [ usrlibdir="$withval"],
|
||||
+ [ usrlibdir='${prefix}/lib' ])
|
||||
+
|
||||
+AC_ARG_WITH(usrsbindir,
|
||||
+ [ --with-usrsbindir=DIR],
|
||||
+ [ usrsbindir="$withval"],
|
||||
+ [ usrsbindir='${prefix}/sbin' ])
|
||||
+
|
||||
+################################################################################
|
||||
dnl -- Where the linux src tree is
|
||||
AC_MSG_CHECKING(for kernel directory)
|
||||
AC_ARG_WITH(kerneldir,
|
||||
@@ -495,6 +502,7 @@
|
||||
AC_SUBST(kernelvsn)
|
||||
AC_SUBST(tmpdir)
|
||||
AC_SUBST(usrlibdir)
|
||||
+AC_SUBST(usrsbindir)
|
||||
|
||||
################################################################################
|
||||
dnl -- First and last lines should not contain files to generate in order to
|
||||
--- LVM2.2.02.39-5/device-mapper.1.02.27/make.tmpl.in 2008-06-06 21:44:35.000000000 +0100
|
||||
+++ LVM2.2.02.39/device-mapper.1.02.27/make.tmpl.in 2008-10-07 16:37:57.000000000 +0100
|
||||
@@ -39,6 +39,7 @@
|
||||
libdir = $(DESTDIR)@libdir@
|
||||
usrlibdir = $(DESTDIR)@usrlibdir@
|
||||
sbindir = $(DESTDIR)@sbindir@
|
||||
+usrsbindir = $(DESTDIR)@usrsbindir@
|
||||
infodir = $(DESTDIR)@infodir@
|
||||
mandir = $(DESTDIR)@mandir@
|
||||
localedir = $(DESTDIR)@LOCALEDIR@
|
||||
--- LVM2.2.02.39-5/make.tmpl.in 2008-06-27 20:24:17.000000000 +0100
|
||||
+++ LVM2.2.02.39/make.tmpl.in 2008-10-07 16:37:57.000000000 +0100
|
||||
@@ -41,7 +41,9 @@
|
||||
confdir = $(DESTDIR)@CONFDIR@/lvm
|
||||
includedir = $(DESTDIR)@includedir@
|
||||
libdir = $(DESTDIR)@libdir@
|
||||
+usrlibdir = $(DESTDIR)@usrlibdir@
|
||||
sbindir = $(DESTDIR)@sbindir@
|
||||
+usrsbindir = $(DESTDIR)@usrsbindir@
|
||||
infodir = $(DESTDIR)@infodir@
|
||||
mandir = $(DESTDIR)@mandir@
|
||||
localedir = $(DESTDIR)@LOCALEDIR@
|
67
lvm2.spec
67
lvm2.spec
@ -1,21 +1,19 @@
|
||||
%define device_mapper_version 1.02.27
|
||||
%define device_mapper_version 1.02.29
|
||||
|
||||
# Do not reset Release to 1 unless both lvm2 and device-mapper
|
||||
# versions are increased together.
|
||||
|
||||
Summary: Userland logical volume management tools
|
||||
Name: lvm2
|
||||
Version: 2.02.39
|
||||
Release: 6%{?dist}
|
||||
Version: 2.02.43
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://sources.redhat.com/lvm2
|
||||
Source0: LVM2.%{version}.tgz
|
||||
Source1: device-mapper.%{device_mapper_version}.tgz
|
||||
|
||||
# Customise lvmconf.sh for built-in clustered locking in Fedora
|
||||
Patch0: cluster-locking-built-in.patch
|
||||
Patch1: lvm2-config.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
||||
@ -38,9 +36,7 @@ or more physical volumes and creating one or more logical volumes
|
||||
|
||||
%prep
|
||||
%setup -q -n LVM2.%{version}
|
||||
%setup -q -T -D -a 1 -n LVM2.%{version}
|
||||
%patch0 -p1 -b .locking
|
||||
%patch1 -p1 -b .config
|
||||
|
||||
%build
|
||||
%define _exec_prefix /
|
||||
@ -48,12 +44,7 @@ or more physical volumes and creating one or more logical volumes
|
||||
%define _sbindir /sbin
|
||||
%define _libdir /%{_lib}
|
||||
|
||||
cd device-mapper.%{device_mapper_version}
|
||||
%configure --with-user= --with-group= --with-device-uid=0 --with-device-gid=6 --with-device-mode=0660 --enable-pkgconfig --with-usrlibdir=/usr/%{_lib} --with-usrsbindir=/usr/sbin
|
||||
make DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
cd ..
|
||||
%configure --enable-lvm1_fallback --enable-fsadm --with-clvmd=cman --with-cluster=internal --with-pool=internal --with-user= --with-group= --with-dmdir=device-mapper.%{device_mapper_version} --with-usrlibdir=/usr/%{_lib} --with-usrsbindir=/usr/sbin
|
||||
%configure --enable-lvm1_fallback --enable-fsadm --with-clvmd=cman --with-cluster=internal --with-pool=internal --with-user= --with-group= --with-dmdir=device-mapper.%{device_mapper_version} --with-usrlibdir=/usr/%{_lib} --with-usrsbindir=/usr/sbin --with-device-uid=0 --with-device-gid=6 --with-device-mode=0660 --enable-pkgconfig
|
||||
make DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
%install
|
||||
@ -68,9 +59,6 @@ mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
|
||||
install scripts/clvmd_init_rhel4 $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
|
||||
install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
|
||||
|
||||
cd device-mapper.%{device_mapper_version}
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -226,12 +214,7 @@ for the kernel device-mapper.
|
||||
|
||||
%files -n device-mapper
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING COPYING.LIB
|
||||
%doc device-mapper.%{device_mapper_version}/INSTALL
|
||||
%doc device-mapper.%{device_mapper_version}/INTRO
|
||||
%doc device-mapper.%{device_mapper_version}/README
|
||||
%doc device-mapper.%{device_mapper_version}/VERSION
|
||||
%doc device-mapper.%{device_mapper_version}/WHATS_NEW
|
||||
%doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL
|
||||
%attr(755,root,root) /sbin/dmsetup
|
||||
%{_mandir}/man8/dmsetup.8.gz
|
||||
|
||||
@ -274,6 +257,46 @@ This package contains the device-mapper shared library, libdevmapper.
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 10 2008 Alasdair Kergon <agk@redhat.com>> - 2.02.43-1
|
||||
- Upstream merge of device-mapper and lvm2 source.
|
||||
- Correct prototype for --permission on lvchange and lvcreate man pages.
|
||||
- Exit with non-zero status from vgdisplay if couldn't show any requested VG.
|
||||
- libdevmapper.pc: Use simplified x.y.z version number.
|
||||
- Accept locking fallback_to_* options in the global section as documented.
|
||||
- Several fixes to lvconvert involving mirrors.
|
||||
- Avoid overwriting in-use on-disk text metadata when metadataarea fills up.
|
||||
- Generate man pages from templates and include version.
|
||||
- Fix misleading error message when there are no allocatable extents in VG.
|
||||
- Fix handling of PVs which reappeared with old metadata version.
|
||||
- Fix validation of --minor and --major in lvcreate to require -My always.
|
||||
- Allow lvremove to remove LVs from VGs with missing PVs.
|
||||
- In VG with PVs missing, by default allow activation of LVs that are complete.
|
||||
- Require --force with --removemissing in vgreduce to remove partial LVs.
|
||||
- No longer write out PARTIAL flag into metadata backups.
|
||||
- Treat new default activation/missing_stripe_filler "error" as an error target.
|
||||
- Add devices/md_chunk_alignment to lvm.conf.
|
||||
- Pass struct physical_volume to pe_align and adjust for md chunk size.
|
||||
- Avoid shuffling remaining mirror images when removing one, retaining primary.
|
||||
- Prevent resizing an LV while lvconvert is using it.
|
||||
- Avoid repeatedly wiping cache while VG_GLOBAL is held in vgscan & pvscan.
|
||||
- Fix pvresize to not allow resize if PV has two metadata areas.
|
||||
- Fix setting of volume limit count if converting to lvm1 format.
|
||||
- Fix vgconvert logical volume id metadata validation.
|
||||
- Fix lvmdump metadata gather option (-m) to work correctly.
|
||||
- Fix allocation bug in text metadata format write error path.
|
||||
- Fix vgcfgbackup to properly check filename if template is used.
|
||||
- vgremove tries to remove lv snapshot first.
|
||||
- Improve file descriptor leak detection to display likely culprit and filename.
|
||||
- Avoid looping forever in _pv_analyze_mda_raw used by pvck.
|
||||
- Change lvchange exit status to indicate if any part of the operation failed.
|
||||
- Fix pvchange and pvremove to handle PVs without mdas.
|
||||
- Fix pvchange -M1 -u to preserve existing extent locations when there's a VG.
|
||||
- Cease recognising snapshot-in-use percentages returned by early devt kernels.
|
||||
- Add backward-compatible flags field to on-disk format_text metadata.
|
||||
- libdevmapper: Only resume devices in dm_tree_preload_children if size changes.
|
||||
- libdevmapper: Extend deptree buffers so the largest possible device numbers fit.
|
||||
- libdevmapper: Underline longer report help text headings.
|
||||
|
||||
* Tue Oct 7 2008 Alasdair Kergon <agk@redhat.com>> - 2.02.39-6
|
||||
- Only set exec_prefix once and configure explicit directories to work with
|
||||
new version of rpm.
|
||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
||||
32ad429461070f0813aff758e0988bc2 LVM2.2.02.39.tgz
|
||||
6074f2c2035c2a526422e691c7457277 device-mapper.1.02.27.tgz
|
||||
576dd4464f609ae378f296d9fa93236a LVM2.2.02.43.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user