Add patch for lvmdbusd
This commit is contained in:
parent
82eacf9683
commit
ba2af41928
15
lvm2-2_02_172-lvmdbusd-mangling-config.patch
Normal file
15
lvm2-2_02_172-lvmdbusd-mangling-config.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff --git a/daemons/lvmdbusd/utils.py b/daemons/lvmdbusd/utils.py
|
||||||
|
index af9e10a..170824d 100644
|
||||||
|
--- a/daemons/lvmdbusd/utils.py
|
||||||
|
+++ b/daemons/lvmdbusd/utils.py
|
||||||
|
@@ -519,7 +519,9 @@ def add_no_notify(cmdline):
|
||||||
|
if '--config' in cmdline:
|
||||||
|
for i, arg in enumerate(cmdline):
|
||||||
|
if arg == '--config':
|
||||||
|
- cmdline[i] += "global/notify_dbus=0"
|
||||||
|
+ if len(cmdline) <= i+1:
|
||||||
|
+ raise dbus.exceptions.DBusException("Missing value for --config option.")
|
||||||
|
+ cmdline[i+1] += " global/notify_dbus=0"
|
||||||
|
break
|
||||||
|
else:
|
||||||
|
cmdline.extend(['--config', 'global/notify_dbus=0'])
|
10
lvm2.spec
10
lvm2.spec
@ -54,7 +54,7 @@ Summary: Userland logical volume management tools
|
|||||||
Name: lvm2
|
Name: lvm2
|
||||||
|
|
||||||
Version: 2.02.171
|
Version: 2.02.171
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://sources.redhat.com/lvm2
|
URL: http://sources.redhat.com/lvm2
|
||||||
@ -62,7 +62,9 @@ Source0: ftp://sources.redhat.com/pub/lvm2/releases/LVM2.%{version}.tgz
|
|||||||
Patch0: lvm2-set-default-preferred_names.patch
|
Patch0: lvm2-set-default-preferred_names.patch
|
||||||
Patch1: lvm2-lvmetad-timeout.patch
|
Patch1: lvm2-lvmetad-timeout.patch
|
||||||
# Commit 405a3689bcc4 related to RHBZ#1445302
|
# Commit 405a3689bcc4 related to RHBZ#1445302
|
||||||
Patch2: lvm2-2_02_171-lvmdbusd-fix-pv-lookup.patch
|
Patch2: lvm2-2_02_172-lvmdbusd-fix-pv-lookup.patch
|
||||||
|
# Commit 16c6d9f11ab5 fixing RHBZ#1451612
|
||||||
|
Patch3: lvm2-2_02_172-lvmdbusd-mangling-config.patch
|
||||||
|
|
||||||
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
||||||
BuildRequires: libblkid-devel >= %{util_linux_version}
|
BuildRequires: libblkid-devel >= %{util_linux_version}
|
||||||
@ -119,6 +121,7 @@ or more physical volumes and creating one or more logical volumes
|
|||||||
%patch0 -p1 -b .preferred_names
|
%patch0 -p1 -b .preferred_names
|
||||||
%patch1 -p1 -b .lvmetad_timeout
|
%patch1 -p1 -b .lvmetad_timeout
|
||||||
%patch2 -p1 -b .lvmdbusd_lookup
|
%patch2 -p1 -b .lvmdbusd_lookup
|
||||||
|
%patch3 -p1 -b .lvmdbusd_config_mangling
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%global _default_pid_dir /run
|
%global _default_pid_dir /run
|
||||||
@ -851,6 +854,9 @@ the device-mapper event library.
|
|||||||
%{_libdir}/pkgconfig/devmapper-event.pc
|
%{_libdir}/pkgconfig/devmapper-event.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 17 2017 Marian Csontos <mcsontos@redhat.com> - 2.02.171-2
|
||||||
|
- Fix lvmdbusd mangling config options.
|
||||||
|
|
||||||
* Tue May 09 2017 Marian Csontos <mcsontos@redhat.com> - 2.02.171-1
|
* Tue May 09 2017 Marian Csontos <mcsontos@redhat.com> - 2.02.171-1
|
||||||
- Add RAID takeover and reshaping.
|
- Add RAID takeover and reshaping.
|
||||||
- Add pvcreate prompt when device size doesn't match setphysicalvolumesize.
|
- Add pvcreate prompt when device size doesn't match setphysicalvolumesize.
|
||||||
|
Loading…
Reference in New Issue
Block a user