New upstream release (lvm2 v2.02.102).
This commit is contained in:
parent
85d48a02f9
commit
af4a23f5c5
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
|||||||
/LVM2.2.02.97.tgz
|
/LVM2.2.02.97.tgz
|
||||||
/LVM2.2.02.98.tgz
|
/LVM2.2.02.98.tgz
|
||||||
/LVM2.2.02.99.tgz
|
/LVM2.2.02.99.tgz
|
||||||
|
/LVM2.2.02.102.tgz
|
||||||
|
7
LVM2.2.02.102.tgz.asc
Normal file
7
LVM2.2.02.102.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||||
|
|
||||||
|
iEYEABECAAYFAlJAVacACgkQIoGRwVZ+LBcDYQCdEsYn2/0Ba40kuNQ2eeW28sZw
|
||||||
|
RSQAoNidkoe1ngHmx3p9hzLGScY1okMF
|
||||||
|
=MKz2
|
||||||
|
-----END PGP SIGNATURE-----
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
|
||||||
|
|
||||||
iEYEABECAAYFAlHwX8oACgkQIoGRwVZ+LBezWwCfb+zArz0U8G3FOgN76MTWjc5A
|
|
||||||
zsMAoJiKRG9xfU8iK0cK3vtJUfJPLe5A
|
|
||||||
=27LF
|
|
||||||
-----END PGP SIGNATURE-----
|
|
@ -1,35 +0,0 @@
|
|||||||
WHATS_NEW | 4 ++++
|
|
||||||
lib/format_text/format-text.c | 4 ++--
|
|
||||||
2 files changed, 6 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/WHATS_NEW b/WHATS_NEW
|
|
||||||
index 039ddec..f2f5ba4 100644
|
|
||||||
--- a/WHATS_NEW
|
|
||||||
+++ b/WHATS_NEW
|
|
||||||
@@ -1,3 +1,7 @@
|
|
||||||
+Version 2.02.100 -
|
|
||||||
+================================
|
|
||||||
+ Fix metadata area offset/size overflow if it's >= 4g and while using lvmetad.
|
|
||||||
+
|
|
||||||
Version 2.02.99 - 24th July 2013
|
|
||||||
================================
|
|
||||||
Do not zero init 4KB of thin snapshot for non-zeroing thin pool (2.02.94).
|
|
||||||
diff --git a/lib/format_text/format-text.c b/lib/format_text/format-text.c
|
|
||||||
index b210603..950e0d5 100644
|
|
||||||
--- a/lib/format_text/format-text.c
|
|
||||||
+++ b/lib/format_text/format-text.c
|
|
||||||
@@ -1688,12 +1688,12 @@ static int _mda_import_text_raw(struct lvmcache_info *info, const struct dm_conf
|
|
||||||
|
|
||||||
cn = cn->child;
|
|
||||||
device = lvmcache_device(info);
|
|
||||||
- size = dm_config_find_int(cn, "size", 0);
|
|
||||||
+ size = dm_config_find_int64(cn, "size", 0);
|
|
||||||
|
|
||||||
if (!device || !size)
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
- offset = dm_config_find_int(cn, "start", 0);
|
|
||||||
+ offset = dm_config_find_int64(cn, "start", 0);
|
|
||||||
ignore = dm_config_find_int(cn, "ignore", 0);
|
|
||||||
|
|
||||||
lvmcache_add_mda(info, device, offset, size, ignore);
|
|
80
lvm2.spec
80
lvm2.spec
@ -36,15 +36,14 @@
|
|||||||
|
|
||||||
Summary: Userland logical volume management tools
|
Summary: Userland logical volume management tools
|
||||||
Name: lvm2
|
Name: lvm2
|
||||||
Version: 2.02.99
|
Version: 2.02.102
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://sources.redhat.com/lvm2
|
URL: http://sources.redhat.com/lvm2
|
||||||
Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
||||||
Patch0: lvm2-set-default-preferred_names.patch
|
Patch0: lvm2-set-default-preferred_names.patch
|
||||||
Patch1: lvm2-enable-lvmetad-by-default.patch
|
Patch1: lvm2-enable-lvmetad-by-default.patch
|
||||||
Patch2: lvm2-2_02_100-fix-mda-offset-size-overflow-4g-with-lvmetad.patch
|
|
||||||
|
|
||||||
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
@ -95,7 +94,7 @@ or more physical volumes and creating one or more logical volumes
|
|||||||
%define configure_udev --with-udevdir=%{_udevdir} --enable-udev_sync
|
%define configure_udev --with-udevdir=%{_udevdir} --enable-udev_sync
|
||||||
|
|
||||||
%if %{enable_thin}
|
%if %{enable_thin}
|
||||||
%define configure_thin --with-thin=internal --with-thin-check=%{_sbindir}/thin_check
|
%define configure_thin --with-thin=internal --with-thin-check=%{_sbindir}/thin_check --with-thin-dump=%{_sbindir}/thin_dump --with-thin-repair=%{_sbindir}/thin_repair
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{enable_lvmetad}
|
%if %{enable_lvmetad}
|
||||||
@ -577,6 +576,79 @@ the device-mapper event library.
|
|||||||
%{_libdir}/pkgconfig/devmapper-event.pc
|
%{_libdir}/pkgconfig/devmapper-event.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 24 2013 Peter Rajnoha <prajnoha@redhat.com> - 2.02.102-1
|
||||||
|
- Fix missing build dependency for scripts subdir in Makefile.
|
||||||
|
- Fix node up/down handling in clvmd corosync module.
|
||||||
|
- Fix 3-thread clvmd deadlock triggered by cleanup on EOF from client.
|
||||||
|
- Remove VG from lvmetad before restoring it with vgcfgrestore.
|
||||||
|
- Add devtypes report command to display built-in recognised block device types.
|
||||||
|
- Fix CC Makefile override which had reverted to using built-in value. (2.02.75)
|
||||||
|
- Recognise bcache block devices in filter (experimental).
|
||||||
|
- Run lvm2-activation-net after lvm2-activation service to prevent parallel run.
|
||||||
|
- Add man page entries for lvmdump's -u and -l options.
|
||||||
|
- Fix lvm2app segfault while using lvm_list_pvs_free fn if there are no PVs.
|
||||||
|
- Improve of clvmd singlenode locking simulation.
|
||||||
|
- lvconvert no longer converts LVs of "mirror" segment type to thinpool.
|
||||||
|
- lvconvert no longer converts thinpool sub-LVs to "mirror" segment type.
|
||||||
|
- Direct udev to use 3min timeout for LVM devices. Recent udev has default 30s.
|
||||||
|
- Do not scan multipath or RAID components and avoid incorrect autoactivation.
|
||||||
|
- Fix MD/loop udev handling to fire autoactivation after setup or coldplug only.
|
||||||
|
- Make RAID capable of single-machine exclusive operations in a cluster.
|
||||||
|
- Drop calculation of read ahead for deactivated volume.
|
||||||
|
- Check for exactly one lv segment in validation of thin pools and volumes.
|
||||||
|
- Fix dmeventd unmonitoring of thin pools.
|
||||||
|
- Fix lvresize for stacked thin pool volumes (i.e. mirrors).
|
||||||
|
- Write Completed debug message before reinstating log defaults after command.
|
||||||
|
- Refresh existing VG before autoactivation (event retrigger/device reappeared).
|
||||||
|
- Use pvscan -b in udev rules to avoid a deadlock on udev process count limit.
|
||||||
|
- Add pvscan -b/--background for the command to be processed in the background.
|
||||||
|
- Don't assume stdin file descriptor is readable.
|
||||||
|
- Avoid unlimited recursion when creating dtree containing inactive pvmove LV.
|
||||||
|
- Require exactly 3 arguments for lvm2-activation-generator. Remove defaults.
|
||||||
|
- Inform lvmetad about any lost PV label to make it in sync with system state.
|
||||||
|
- Support most of lvchange operations on stacked thin pool meta/data LVs.
|
||||||
|
- Enable non-clustered pvmove of snapshots and snapshot origins.
|
||||||
|
- Add ability to pvmove non-clustered RAID, mirror, and thin volumes.
|
||||||
|
- Make lvm2-activation-generator silent unless it's in error state.
|
||||||
|
- Remove "mpath major is not dm major" msg for mpath component scan (2.02.94).
|
||||||
|
- Prevent cluster mirror logs from being corrupted by redundant checkpoints.
|
||||||
|
- Fix ignored lvmetad update on loop device configuration (2.02.99).
|
||||||
|
- Use LVM_PATH instead of hardcoded value in lvm2 activation systemd generator.
|
||||||
|
- Fix vgck to notice on-disk corruption even if lvmetad is used.
|
||||||
|
- Move mpath device filter before partitioned filter (which opens devices).
|
||||||
|
- Require confirmation for vgchange -c when no VGs listed explicitly.
|
||||||
|
- Also skip /var and /var/log by default in blkdeactivate when unmounting.
|
||||||
|
- Add support for bind mounts in blkdeactivate.
|
||||||
|
- Add blkdeactivate -v/--verbose for debug output from external tools used.
|
||||||
|
- Add blkdeactivate -e/--errors for error messages from external tools used.
|
||||||
|
- Suppress messages from external tools called in blkdeactivate by default.
|
||||||
|
- Fix inability to remove a VG's cluster flag if it contains a mirror.
|
||||||
|
- Fix bug making lvchange unable to change recovery rate for RAID.
|
||||||
|
- Prohibit conversion of thin pool to external origin.
|
||||||
|
- Workaround gcc v4.8 -O2 bug causing failures if config/checks=1 (32bit arch).
|
||||||
|
- Verify clvmd message validity before processing and log error if incorrect.
|
||||||
|
- When creating PV on existing LV don't forbid reserved LV names on LVs below.
|
||||||
|
- When converting mirrors, default segtype should be the same unless specified.
|
||||||
|
- Make "raid1" the default mirror segment type.
|
||||||
|
- Fix clogd descriptor leak when daemonizing.
|
||||||
|
- Fix clvmd descriptor leak on restart.
|
||||||
|
- Add pipe_open/close() to use instead of less efficient/secure popen().
|
||||||
|
- Inherit and apply any profile attached to a VG if creating new thin pool.
|
||||||
|
- Add initial support thin pool lvconvert --repair.
|
||||||
|
- Add --with-thin-repair and --with-thin-dump configure options.
|
||||||
|
- Add lvm.conf thin_repair/dump_executable and thin_repair_options.
|
||||||
|
- Require 1.9 thin pool target version for online thin pool metadata resize.
|
||||||
|
- Ignore previous LV seg with alloc contiguous & cling when num stripes varies.
|
||||||
|
- Fix segfault if devices/global_filter is not specified correctly.
|
||||||
|
- Tidy dmeventd fifo initialisation.
|
||||||
|
- Detect invalid sector supplied to 'dmsetup message'.
|
||||||
|
- Free any previously-set string if a dm_task_set_* function is called again.
|
||||||
|
- Do not allow passing empty new name for dmsetup rename.
|
||||||
|
- Display any output returned by 'dmsetup message'.
|
||||||
|
- Add dm_task_get_message_response to libdevmapper.
|
||||||
|
- Create dmeventd timeout threads as "detached" so exit status is freed.
|
||||||
|
- Add DM_ABORT_ON_INTERNAL_ERRORS env var support to abort on internal errors.
|
||||||
|
|
||||||
* Tue Aug 06 2013 Peter Rajnoha <prajnoha@redhat.com> - 2.02.99-2
|
* Tue Aug 06 2013 Peter Rajnoha <prajnoha@redhat.com> - 2.02.99-2
|
||||||
- Fix metadata area offset/size overflow if it's >= 4g and while using lvmetad.
|
- Fix metadata area offset/size overflow if it's >= 4g and while using lvmetad.
|
||||||
- Require the newest device-mapper-persistent-data-0.2.3-1.
|
- Require the newest device-mapper-persistent-data-0.2.3-1.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
8600d999d04d826138d9fbb5d2d8cc34 LVM2.2.02.99.tgz
|
cfce545d87abf42ae4c9e0aae704619e LVM2.2.02.102.tgz
|
||||||
|
Loading…
Reference in New Issue
Block a user