New upstream with a few fixes including encoding device names
to restrict them to the udev characterset.
This commit is contained in:
parent
e928907306
commit
855bf89245
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/LVM2.2.02.90.tgz
|
||||
/LVM2.2.02.91.tgz
|
||||
/LVM2.2.02.92.tgz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBPOEzqIoGRwVZ+LBcRAtZ3AKCiWkjsvCK2oaXliVVwzIvPDMg3LwCgyiKn
|
||||
LslNhSyldyoBoZIcLse+VLA=
|
||||
=y+5q
|
||||
-----END PGP SIGNATURE-----
|
7
LVM2.2.02.92.tgz.asc
Normal file
7
LVM2.2.02.92.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBPQq8yIoGRwVZ+LBcRAnpTAJ9s3S/AL1S0YeDR2PYu63l3VtKhXACfR0/W
|
||||
qLwf5jzbwGxEKPvYOzmGHUQ=
|
||||
=Vc+8
|
||||
-----END PGP SIGNATURE-----
|
@ -1,117 +0,0 @@
|
||||
diff -purN LVM2.2.02.91.orig/configure LVM2.2.02.91.new/configure
|
||||
--- LVM2.2.02.91.orig/configure 2012-01-31 22:21:53.000000000 +0100
|
||||
+++ LVM2.2.02.91.new/configure 2012-02-13 13:49:27.339271246 +0100
|
||||
@@ -596,6 +596,7 @@ ac_default_prefix=/usr
|
||||
ac_subst_vars='LTLIBOBJS
|
||||
usrsbindir
|
||||
usrlibdir
|
||||
+systemdsystemunitdir
|
||||
udevdir
|
||||
udev_prefix
|
||||
tmpdir
|
||||
@@ -840,6 +841,7 @@ with_usrlibdir
|
||||
with_usrsbindir
|
||||
with_udev_prefix
|
||||
with_udevdir
|
||||
+with_systemdsystemunitdir
|
||||
with_dmeventd_pidfile
|
||||
with_dmeventd_path
|
||||
with_default_run_dir
|
||||
@@ -1580,6 +1582,8 @@ Optional Packages:
|
||||
--with-udev-prefix=UPREFIX
|
||||
install udev rule files in UPREFIX [[EPREFIX]]
|
||||
--with-udevdir=DIR udev rules in DIR [[UPREFIX/lib/udev/rules.d]]
|
||||
+ --with-systemdsystemunitdir=DIR
|
||||
+ systemd service files in DIR
|
||||
--with-dmeventd-pidfile=PATH
|
||||
dmeventd pidfile [[/var/run/dmeventd.pid]]
|
||||
--with-dmeventd-path=PATH
|
||||
@@ -9695,6 +9699,23 @@ fi
|
||||
|
||||
|
||||
################################################################################
|
||||
+
|
||||
+# Check whether --with-systemdsystemunitdir was given.
|
||||
+if test "${with_systemdsystemunitdir+set}" = set; then :
|
||||
+ withval=$with_systemdsystemunitdir; systemdsystemunitdir=$withval
|
||||
+else
|
||||
+ pkg_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)
|
||||
+fi
|
||||
+
|
||||
+
|
||||
+if test -n "$pkg_systemdsystemunitdir"; then
|
||||
+ systemdsystemunitdir=$pkg_systemdsystemunitdir;
|
||||
+fi
|
||||
+
|
||||
+if test -z "$systemdsystemunitdir"; then
|
||||
+ systemdsystemunitdir='/lib/systemd/system';
|
||||
+fi
|
||||
+################################################################################
|
||||
if test x$READLINE = xyes; then
|
||||
for ac_header in readline/readline.h readline/history.h
|
||||
do :
|
||||
@@ -10233,6 +10254,7 @@ LVM_LIBAPI=`echo "$VER" | $AWK -F '[()]'
|
||||
|
||||
|
||||
|
||||
+
|
||||
|
||||
|
||||
|
||||
diff -purN LVM2.2.02.91.orig/configure.in LVM2.2.02.91.new/configure.in
|
||||
--- LVM2.2.02.91.orig/configure.in 2012-01-31 22:21:54.000000000 +0100
|
||||
+++ LVM2.2.02.91.new/configure.in 2012-02-13 13:49:27.339271246 +0100
|
||||
@@ -1159,6 +1159,22 @@ AC_ARG_WITH(udevdir,
|
||||
udevdir=$withval, udevdir='${udev_prefix}/lib/udev/rules.d')
|
||||
|
||||
################################################################################
|
||||
+dnl -- Get the systemd system unit dir value from pkg_config automatically if value not given explicitly.
|
||||
+dnl -- This follows the recommendation for systemd integration best practices mentioned in daemon(7) manpage.
|
||||
+AC_ARG_WITH(systemdsystemunitdir,
|
||||
+ AC_HELP_STRING([--with-systemdsystemunitdir=DIR],
|
||||
+ [systemd service files in DIR]),
|
||||
+ systemdsystemunitdir=$withval,
|
||||
+ pkg_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd))
|
||||
+
|
||||
+if test -n "$pkg_systemdsystemunitdir"; then
|
||||
+ systemdsystemunitdir=$pkg_systemdsystemunitdir;
|
||||
+fi
|
||||
+
|
||||
+if test -z "$systemdsystemunitdir"; then
|
||||
+ systemdsystemunitdir='/lib/systemd/system';
|
||||
+fi
|
||||
+################################################################################
|
||||
dnl -- Ensure additional headers required
|
||||
if test x$READLINE = xyes; then
|
||||
AC_CHECK_HEADERS(readline/readline.h readline/history.h,,AC_MSG_ERROR(bailing out))
|
||||
@@ -1426,6 +1442,7 @@ AC_SUBST(kernelvsn)
|
||||
AC_SUBST(tmpdir)
|
||||
AC_SUBST(udev_prefix)
|
||||
AC_SUBST(udevdir)
|
||||
+AC_SUBST(systemdsystemunitdir)
|
||||
AC_SUBST(usrlibdir)
|
||||
AC_SUBST(usrsbindir)
|
||||
|
||||
diff -purN LVM2.2.02.91.orig/make.tmpl.in LVM2.2.02.91.new/make.tmpl.in
|
||||
--- LVM2.2.02.91.orig/make.tmpl.in 2011-11-23 13:19:23.000000000 +0100
|
||||
+++ LVM2.2.02.91.new/make.tmpl.in 2012-02-13 13:49:27.340271242 +0100
|
||||
@@ -66,7 +66,7 @@ staticdir = $(DESTDIR)@STATICDIR@
|
||||
udevdir = $(DESTDIR)@udevdir@
|
||||
pkgconfigdir = $(usrlibdir)/pkgconfig
|
||||
initdir = $(DESTDIR)@sysconfdir@/rc.d/init.d
|
||||
-systemd_dir = $(DESTDIR)/lib/systemd/system
|
||||
+systemd_dir = $(DESTDIR)/@systemdsystemunitdir@
|
||||
ocf_scriptdir = $(DESTDIR)@OCFDIR@
|
||||
|
||||
USRLIB_RELPATH = $(shell echo $(abspath $(usrlibdir) $(libdir)) | \
|
||||
diff -purN LVM2.2.02.91.orig/WHATS_NEW LVM2.2.02.91.new/WHATS_NEW
|
||||
--- LVM2.2.02.91.orig/WHATS_NEW 2012-02-13 00:02:52.000000000 +0100
|
||||
+++ LVM2.2.02.91.new/WHATS_NEW 2012-02-13 13:51:04.104940437 +0100
|
||||
@@ -1,3 +1,7 @@
|
||||
+Version 2.02.92 -
|
||||
+====================================
|
||||
+ Add configure --with-systemdsystemunitdir.
|
||||
+
|
||||
Version 2.02.91 - 12th February 2012
|
||||
====================================
|
||||
Remove PV-based format instances (which are no longer needed).
|
26
lvm2.spec
26
lvm2.spec
@ -1,4 +1,4 @@
|
||||
%define device_mapper_version 1.02.70
|
||||
%define device_mapper_version 1.02.71
|
||||
|
||||
%define enable_thin 0
|
||||
%define enable_cluster 1
|
||||
@ -65,8 +65,8 @@
|
||||
|
||||
Summary: Userland logical volume management tools
|
||||
Name: lvm2
|
||||
Version: 2.02.91
|
||||
Release: 2%{?dist}
|
||||
Version: 2.02.92
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://sources.redhat.com/lvm2
|
||||
@ -75,7 +75,6 @@ Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
||||
Source1: %{name}-tmpfiles.conf
|
||||
%endif
|
||||
Patch0: lvm2-set-default-preferred_names.patch
|
||||
Patch1: lvm2-2_02_92-add-with-systemdsystemunitdir-config.patch
|
||||
|
||||
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
||||
BuildRequires: ncurses-devel
|
||||
@ -119,7 +118,6 @@ or more physical volumes and creating one or more logical volumes
|
||||
%prep
|
||||
%setup -q -n LVM2.%{version}
|
||||
%patch0 -p1 -b preferred_names
|
||||
%patch1 -p1 -b systemd_dir
|
||||
|
||||
%build
|
||||
%define _exec_prefix ""
|
||||
@ -633,6 +631,24 @@ the device-mapper event library.
|
||||
/usr%{_libdir}/pkgconfig/devmapper-event.pc
|
||||
|
||||
%changelog
|
||||
* Mon Feb 20 2012 Alasdair Kergon <agk@redhat.com> - 2.02.92-1
|
||||
- Read dmeventd monitoring config settings for every lvm command.
|
||||
- For thin devices, initialize monitoring only for thin pools not thin volumes.
|
||||
- Make conversion from a synced 'mirror' to 'raid1' not cause a full resync.
|
||||
- Add clvmd init dependency on dlm service when running with new corosync.
|
||||
- Switch to using built-in blkid in 13-dm-disk.rules.
|
||||
- Add "watch" rule to 13-dm-disk.rules.
|
||||
- Detect failing fifo and skip 20s retry communication period.
|
||||
- Replace any '\' char with '\\' in dm table specification on input.
|
||||
- New 'mangle' options in dmsetup/libdevmapper for transparent reversible
|
||||
encoding of characters that udev forbids in device names.
|
||||
- Add --manglename option to dmsetup to select the name mangling mode.
|
||||
- Add mangle command to dmsetup to provide renaming to correct mangled form.
|
||||
- Add 'mangled_name' and 'unmangled_name' fields to dmsetup info -c -o.
|
||||
- Mangle device name on dm_task_set_name/newname call if necessary.
|
||||
- Add dm_task_get_name_mangled/unmangled to libdevmapper.
|
||||
- Add dm_set/get_name_mangling_mode to set/get name mangling in libdevmapper.
|
||||
|
||||
* Mon Feb 13 2012 Peter Rajnoha <prajnoha@redhat.com> - 2.02.91-2
|
||||
- Add configure --with-systemdsystemunitdir.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
03ed8dc20c3a65079aedcedc0ec33192 LVM2.2.02.91.tgz
|
||||
7602eb1cd493b001d4ef46ff50ddd1c6 LVM2.2.02.92.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user