Fix regression in blkdeactivate script.
This commit is contained in:
parent
a9df414abf
commit
73457903f0
@ -0,0 +1,24 @@
|
||||
diff --git a/scripts/blkdeactivate.sh.in b/scripts/blkdeactivate.sh.in
|
||||
index 2a48b3e..b4c3237 100644
|
||||
--- a/scripts/blkdeactivate.sh.in
|
||||
+++ b/scripts/blkdeactivate.sh.in
|
||||
@@ -193,8 +193,7 @@ deactivate_holders () {
|
||||
}
|
||||
|
||||
deactivate_dm () {
|
||||
- local name
|
||||
- name=$(printf "%s" "$name")
|
||||
+ local name=$(printf "%s" "$name")
|
||||
test -b "$DEV_DIR/mapper/$name" || return 0
|
||||
test -z ${SKIP_DEVICE_LIST["$kname"]} || return 1
|
||||
|
||||
@@ -263,8 +262,7 @@ deactivate_lvm () {
|
||||
}
|
||||
|
||||
deactivate_md () {
|
||||
- local name
|
||||
- name=$(printf "%s" "$name")
|
||||
+ local name=$(printf "%s" "$name")
|
||||
test -b "$DEV_DIR/$name" || return 0
|
||||
test -z ${SKIP_DEVICE_LIST["$kname"]} || return 1
|
||||
|
20
lvm2.spec
20
lvm2.spec
@ -53,13 +53,14 @@ Summary: Userland logical volume management tools
|
||||
Name: lvm2
|
||||
|
||||
Version: 2.02.155
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://sources.redhat.com/lvm2
|
||||
Source0: ftp://sources.redhat.com/pub/lvm2/releases/LVM2.%{version}.tgz
|
||||
Patch0: lvm2-set-default-preferred_names.patch
|
||||
Patch1: lvm2-lvmetad-timeout.patch
|
||||
Patch2: lvm2-2_02_156-fix-regression-in-blkdeactivate-causing-devs-to-be-skipped.patch
|
||||
|
||||
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
||||
BuildRequires: libblkid-devel >= %{util_linux_version}
|
||||
@ -115,6 +116,7 @@ or more physical volumes and creating one or more logical volumes
|
||||
%setup -q -n LVM2.%{version}
|
||||
%patch0 -p1 -b .preferred_names
|
||||
%patch1 -p1 -b .lvmetad_timeout
|
||||
%patch2 -p1 -b .blkdeactivate
|
||||
|
||||
%build
|
||||
%global _default_pid_dir /run
|
||||
@ -239,7 +241,18 @@ systemctl start lvm2-lvmpolld.socket
|
||||
%{_sbindir}/lvmconf
|
||||
%{_sbindir}/lvmconfig
|
||||
%{_sbindir}/lvmdump
|
||||
%if %{enable_lvmetad}
|
||||
%if %{enable_lvmetad}diff --git a/WHATS_NEW b/WHATS_NEW
|
||||
index c1b90af..2e7e138 100644
|
||||
--- a/WHATS_NEW
|
||||
+++ b/WHATS_NEW
|
||||
@@ -1,5 +1,6 @@
|
||||
Version 2.02.156 -
|
||||
================================
|
||||
+ Fix regression in blkdeactivate causing dm and md devices to be skipped. (2.02.155)
|
||||
|
||||
Version 2.02.155 - 3rd June 2016
|
||||
================================
|
||||
|
||||
%{_sbindir}/lvmetad
|
||||
%endif
|
||||
%if %{enable_lvmpolld}
|
||||
@ -834,6 +847,9 @@ the device-mapper event library.
|
||||
%{_libdir}/pkgconfig/devmapper-event.pc
|
||||
|
||||
%changelog
|
||||
* Mon Jun 06 2016 Peter Rajnoha <prajnoha@redhat.com> - 2.02.155-2
|
||||
- Fix regression in blkdeactivate causing dm and md devices to be skipped. (2.02.155)
|
||||
|
||||
* Mon Jun 06 2016 Peter Rajnoha <prajnoha@redhat.com> - 2.02.155-1
|
||||
- Reject PV tags on pvmove cmdline because only 1 PV is supported. (2.02.141)
|
||||
- Fix compilation error when building with configure --disable-devmapper.
|
||||
|
Loading…
Reference in New Issue
Block a user