New upstream
This commit is contained in:
parent
17c73a7e0a
commit
71fce882f4
@ -1 +1 @@
|
||||
LVM2.2.02.47.tgz
|
||||
LVM2.2.02.48.tgz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBJrV5+IoGRwVZ+LBcRAjEfAJ0W6QcbtMX5O/H6nHAQ68NzO2ThmgCgsqNY
|
||||
MKXx9CYw4vQ2tpGtCrF7zzo=
|
||||
=U8vL
|
||||
-----END PGP SIGNATURE-----
|
7
LVM2.2.02.48.tgz.asc
Normal file
7
LVM2.2.02.48.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBKSmiOIoGRwVZ+LBcRAuOEAJ91bUIQ8VQtN8sQlaZx1MQIsBCSaQCgsvgQ
|
||||
g5k7R3ofyTUbNAqzzGWLng4=
|
||||
=X6rZ
|
||||
-----END PGP SIGNATURE-----
|
@ -1,82 +0,0 @@
|
||||
Index: daemons/clvmd/clvmd-corosync.c
|
||||
===================================================================
|
||||
RCS file: /cvs/lvm2/LVM2/daemons/clvmd/clvmd-corosync.c,v
|
||||
retrieving revision 1.9
|
||||
retrieving revision 1.10
|
||||
diff -u -r1.9 -r1.10
|
||||
--- a/daemons/clvmd/clvmd-corosync.c 21 Apr 2009 13:11:28 -0000 1.9
|
||||
+++ b/daemons/clvmd/clvmd-corosync.c 3 Jun 2009 13:42:02 -0000 1.10
|
||||
@@ -56,16 +56,16 @@
|
||||
#define LOCKSPACE_NAME "clvmd"
|
||||
|
||||
static void cpg_deliver_callback (cpg_handle_t handle,
|
||||
- struct cpg_name *groupName,
|
||||
+ const struct cpg_name *groupName,
|
||||
uint32_t nodeid,
|
||||
uint32_t pid,
|
||||
void *msg,
|
||||
- int msg_len);
|
||||
+ size_t msg_len);
|
||||
static void cpg_confchg_callback(cpg_handle_t handle,
|
||||
- struct cpg_name *groupName,
|
||||
- struct cpg_address *member_list, int member_list_entries,
|
||||
- struct cpg_address *left_list, int left_list_entries,
|
||||
- struct cpg_address *joined_list, int joined_list_entries);
|
||||
+ const struct cpg_name *groupName,
|
||||
+ const struct cpg_address *member_list, size_t member_list_entries,
|
||||
+ const struct cpg_address *left_list, size_t left_list_entries,
|
||||
+ const struct cpg_address *joined_list, size_t joined_list_entries);
|
||||
static void _cluster_closedown(void);
|
||||
|
||||
/* Hash list of nodes in the cluster */
|
||||
@@ -206,17 +206,17 @@
|
||||
}
|
||||
|
||||
static void cpg_deliver_callback (cpg_handle_t handle,
|
||||
- struct cpg_name *groupName,
|
||||
+ const struct cpg_name *groupName,
|
||||
uint32_t nodeid,
|
||||
uint32_t pid,
|
||||
void *msg,
|
||||
- int msg_len)
|
||||
+ size_t msg_len)
|
||||
{
|
||||
int target_nodeid;
|
||||
|
||||
memcpy(&target_nodeid, msg, COROSYNC_CSID_LEN);
|
||||
|
||||
- DEBUGLOG("%u got message from nodeid %d for %d. len %d\n",
|
||||
+ DEBUGLOG("%u got message from nodeid %d for %d. len %zd\n",
|
||||
our_nodeid, nodeid, target_nodeid, msg_len-4);
|
||||
|
||||
if (nodeid != our_nodeid)
|
||||
@@ -226,15 +226,15 @@
|
||||
}
|
||||
|
||||
static void cpg_confchg_callback(cpg_handle_t handle,
|
||||
- struct cpg_name *groupName,
|
||||
- struct cpg_address *member_list, int member_list_entries,
|
||||
- struct cpg_address *left_list, int left_list_entries,
|
||||
- struct cpg_address *joined_list, int joined_list_entries)
|
||||
+ const struct cpg_name *groupName,
|
||||
+ const struct cpg_address *member_list, size_t member_list_entries,
|
||||
+ const struct cpg_address *left_list, size_t left_list_entries,
|
||||
+ const struct cpg_address *joined_list, size_t joined_list_entries)
|
||||
{
|
||||
int i;
|
||||
struct node_info *ninfo;
|
||||
|
||||
- DEBUGLOG("confchg callback. %d joined, %d left, %d members\n",
|
||||
+ DEBUGLOG("confchg callback. %zd joined, %zd left, %zd members\n",
|
||||
joined_list_entries, left_list_entries, member_list_entries);
|
||||
|
||||
for (i=0; i<joined_list_entries; i++) {
|
||||
@@ -580,7 +580,7 @@
|
||||
{
|
||||
confdb_handle_t handle;
|
||||
int result;
|
||||
- int namelen = buflen;
|
||||
+ size_t namelen = buflen;
|
||||
hdb_handle_t cluster_handle;
|
||||
confdb_callbacks_t callbacks = {
|
||||
.confdb_key_change_notify_fn = NULL,
|
48
lvm2.spec
48
lvm2.spec
@ -1,4 +1,4 @@
|
||||
%define device_mapper_version 1.02.32
|
||||
%define device_mapper_version 1.02.33
|
||||
%define corosync_version 0.97-1
|
||||
%define clusterlib_version 3.0.0-12.alpha6
|
||||
|
||||
@ -7,8 +7,8 @@
|
||||
|
||||
Summary: Userland logical volume management tools
|
||||
Name: lvm2
|
||||
Version: 2.02.47
|
||||
Release: 2%{?dist}
|
||||
Version: 2.02.48
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://sources.redhat.com/lvm2
|
||||
@ -16,7 +16,6 @@ Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
||||
|
||||
# Customise lvmconf.sh for built-in clustered locking in Fedora
|
||||
Patch0: cluster-locking-built-in.patch
|
||||
Patch1: lvm2-2_02_48-cluster-cpg-new-api.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
||||
@ -42,7 +41,6 @@ or more physical volumes and creating one or more logical volumes
|
||||
%prep
|
||||
%setup -q -n LVM2.%{version}
|
||||
%patch0 -p1 -b .locking
|
||||
%patch1 -p1 -b .cpg
|
||||
|
||||
%build
|
||||
%define _exec_prefix /
|
||||
@ -268,6 +266,46 @@ This package contains the device-mapper shared library, libdevmapper.
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 30 2009 Alasdair Kergon <agk@redhat.com> - 2.02.48-1
|
||||
- Abort if automatic metadata correction fails when reading VG to update it.
|
||||
- Don't fallback to default major number in libdm: use dm_task_set_major_minor.
|
||||
- Explicitly request fallback to default major number in device mapper.
|
||||
- Ignore suspended devices during repair.
|
||||
- Suggest using lvchange --resync when adding leg to not-yet-synced mirror.
|
||||
- Destroy toolcontext on clvmd exit to avoid memory pool leaks.
|
||||
- Fix lvconvert not to poll mirror if no conversion in progress.
|
||||
- Fix memory leaks in toolcontext error path.
|
||||
- Reinstate partial activation support in clustered mode.
|
||||
- Allow metadata correction even when PVs are missing.
|
||||
- Use 'lvm lvresize' instead of 'lvresize' in fsadm.
|
||||
- Do not use '-n' realine option in fsadm for rescue disk compatiblity.
|
||||
- Round up requested readahead to at least one page and print warning.
|
||||
- Try to repair vg before actual vgremove when force flag provided.
|
||||
- Unify error messages when processing inconsistent volume group.
|
||||
- Introduce lvconvert --use_policies (repair policy according to lvm.conf).
|
||||
- Fix rename of active snapshot with virtual origin.
|
||||
- Fix convert polling to ignore LV with different UUID.
|
||||
- Cache underlying device readahead only before activation calls.
|
||||
- Fix segfault when calculating readahead on missing device in vgreduce.
|
||||
- Remove verbose 'visited' messages.
|
||||
- Handle multi-extent mirror log allocation when smallest PV has only 1 extent.
|
||||
- Add LSB standard headers and functions (incl. reload) to clvmd initscript.
|
||||
- When creating new LV, double-check that name is not already in use.
|
||||
- Remove /dev/vgname/lvname symlink automatically if LV is no longer visible.
|
||||
- Rename internal vorigin LV to match visible LV.
|
||||
- Suppress 'removed' messages displayed when internal LVs are removed.
|
||||
- Fix lvchange -a and -p for sparse LVs.
|
||||
- Fix lvcreate --virtualsize to activate the new device immediately.
|
||||
- Make --snapshot optional with lvcreate --virtualsize.
|
||||
- Generalise --virtualoriginsize to --virtualsize.
|
||||
- Skip virtual origins in process_each_lv_in_vg() without --all.
|
||||
- Fix counting of virtual origin LVs in vg_validate.
|
||||
- Attempt to load dm-zero module if zero target needed but not present.
|
||||
- Add crypt target handling to libdevmapper tree nodes.
|
||||
- Add splitname command to dmsetup.
|
||||
- Add subsystem, vg_name, lv_name, lv_layer fields to dmsetup reports.
|
||||
- Make mempool optional in dm_split_lvm_name() in libdevmapper.
|
||||
|
||||
* Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 2.02.47-2
|
||||
- BuildRequire newer version of corosynclib (0.97-1) to link against
|
||||
latest libraries version (soname 4.0.0).
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
669d57ff97d171fd4e077c61da1f9a34 LVM2.2.02.47.tgz
|
||||
0d24c2709f439eeca36261e5cea68330 LVM2.2.02.48.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user