New upstream - extend lvconvert raid1 support.
This commit is contained in:
parent
a76d6fdae6
commit
6c83f67bb3
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@ LVM2.2.02.73.tgz
|
|||||||
/LVM2.2.02.84.tgz
|
/LVM2.2.02.84.tgz
|
||||||
/LVM2.2.02.86.tgz
|
/LVM2.2.02.86.tgz
|
||||||
/LVM2.2.02.87.tgz
|
/LVM2.2.02.87.tgz
|
||||||
|
/LVM2.2.02.88.tgz
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
|
||||||
|
|
||||||
iD8DBQBORI13IoGRwVZ+LBcRAshdAKCG/UOS7n0xA83p9jsZb8ka8PoqygCg35hg
|
|
||||||
5GrcluMg1WIlTvYRs71X124=
|
|
||||||
=EBP2
|
|
||||||
-----END PGP SIGNATURE-----
|
|
7
LVM2.2.02.88.tgz.asc
Normal file
7
LVM2.2.02.88.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||||
|
|
||||||
|
iD8DBQBOTuwJIoGRwVZ+LBcRAsD5AJwJsan/rnhUF9ogRAGoBfUIqIbCsQCfa4cq
|
||||||
|
QCnm+ZZ8eg2pGEVsbWHSuqM=
|
||||||
|
=WRAS
|
||||||
|
-----END PGP SIGNATURE-----
|
@ -1,16 +0,0 @@
|
|||||||
make.tmpl.in | 2 +-
|
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/make.tmpl.in b/make.tmpl.in
|
|
||||||
index a9d5235..3a21b24 100644
|
|
||||||
--- a/make.tmpl.in
|
|
||||||
+++ b/make.tmpl.in
|
|
||||||
@@ -364,7 +364,7 @@ cleandir:
|
|
||||||
$(RM) $(OBJECTS) $(TARGETS) $(CLEAN_TARGETS) $(CLEAN_CFLOW) $(LDDEPS) \
|
|
||||||
$(POTFILES) $(SOURCES:%.c=%.d) $(SOURCES:%.c=%.gcno) $(SOURCES:%.c=%.gcda) \
|
|
||||||
$(SOURCES2:%.c=%.o) $(SOURCES2:%.c=%.d) $(SOURCES2:%.c=%.gcno) $(SOURCES2:%.c=%.gcda) \
|
|
||||||
- .exported_symbols_generated Makefile core
|
|
||||||
+ .exported_symbols_generated core
|
|
||||||
|
|
||||||
clean: $(SUBDIRS.clean) cleandir
|
|
||||||
|
|
15
lvm2.spec
15
lvm2.spec
@ -1,4 +1,4 @@
|
|||||||
%define device_mapper_version 1.02.66
|
%define device_mapper_version 1.02.67
|
||||||
%define enable_cluster 1
|
%define enable_cluster 1
|
||||||
|
|
||||||
%if "%{fedora}" == "12"
|
%if "%{fedora}" == "12"
|
||||||
@ -38,7 +38,7 @@
|
|||||||
|
|
||||||
Summary: Userland logical volume management tools
|
Summary: Userland logical volume management tools
|
||||||
Name: lvm2
|
Name: lvm2
|
||||||
Version: 2.02.87
|
Version: 2.02.88
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -48,7 +48,6 @@ Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
|||||||
Source1: %{name}-tmpfiles.conf
|
Source1: %{name}-tmpfiles.conf
|
||||||
%endif
|
%endif
|
||||||
Patch0: lvm2-set-default-preferred_names.patch
|
Patch0: lvm2-set-default-preferred_names.patch
|
||||||
Patch1: lvm2-2_02_88-do-not-remove-makefile-on-clean.patch
|
|
||||||
|
|
||||||
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
@ -88,7 +87,6 @@ or more physical volumes and creating one or more logical volumes
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n LVM2.%{version}
|
%setup -q -n LVM2.%{version}
|
||||||
%patch0 -p1 -b preferred_names
|
%patch0 -p1 -b preferred_names
|
||||||
%patch1 -p1 -b .clean
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%define _exec_prefix ""
|
%define _exec_prefix ""
|
||||||
@ -587,6 +585,15 @@ the device-mapper event library.
|
|||||||
/usr%{_libdir}/pkgconfig/devmapper-event.pc
|
/usr%{_libdir}/pkgconfig/devmapper-event.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 22 2011 Alasdair Kergon <agk@redhat.com> - 2.02.88-1
|
||||||
|
- Remove incorrect 'Breaking' error message from allocation code. (2.02.87)
|
||||||
|
- Add lvconvert --merge support for raid1 devices split with --trackchanges.
|
||||||
|
- Add --trackchanges support to lvconvert --splitmirrors option for raid1.
|
||||||
|
- Add dm_tree_node_add_null_area for temporarily-missing raid devs tracked.
|
||||||
|
- Support lvconvert of -m1 raid1 devices to a higher number.
|
||||||
|
- Support splitting off a single raid1 rimage in lvconvert --splitmirrors.
|
||||||
|
- Add -V as short form of --virtualsize in lvcreate.
|
||||||
|
|
||||||
* Fri Aug 12 2011 Peter Rajnoha <prajnoha@redhat.com> - 2.02.87-1
|
* Fri Aug 12 2011 Peter Rajnoha <prajnoha@redhat.com> - 2.02.87-1
|
||||||
- Cache and share generated VG structs to improve performance.
|
- Cache and share generated VG structs to improve performance.
|
||||||
- Suppress locking error messages in monitoring init scripts.
|
- Suppress locking error messages in monitoring init scripts.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
4c36c7f216edfe65a6193d2adc389ecd LVM2.2.02.87.tgz
|
321429cd1b1526a29cf6d75018b1e4bb LVM2.2.02.88.tgz
|
||||||
|
Loading…
Reference in New Issue
Block a user