Fix editline compilation
This commit is contained in:
parent
24098c7fd8
commit
5e3e5a7dc8
61
lvm2-2_03_12-lvm-Fix-editline-compilation.patch
Normal file
61
lvm2-2_03_12-lvm-Fix-editline-compilation.patch
Normal file
@ -0,0 +1,61 @@
|
||||
From 51d4b6069e5767467b4264b7182943a0c73b4c92 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Csontos <mcsontos@redhat.com>
|
||||
Date: Mon, 22 Mar 2021 10:50:42 +0100
|
||||
Subject: [PATCH] lvm: Fix editline compilation
|
||||
|
||||
---
|
||||
configure | 2 +-
|
||||
configure.ac | 4 ++--
|
||||
tools/lvm.c | 1 -
|
||||
3 files changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 4c38cbe..0be9f13 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -13404,7 +13404,7 @@ $as_echo_n "checking whether to enable readline... " >&6; }
|
||||
$as_echo "$READLINE" >&6; }
|
||||
|
||||
if test "$EDITLINE" = yes; then
|
||||
- for ac_header in editline/readline.h editline/history.h
|
||||
+ for ac_header in editline/readline.h
|
||||
do :
|
||||
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
||||
ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ee21b87..b92be0d 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1420,7 +1420,7 @@ if test "$EDITLINE" == yes; then
|
||||
PKG_CHECK_MODULES([EDITLINE], [libedit], [
|
||||
AC_DEFINE([EDITLINE_SUPPORT], 1,
|
||||
[Define to 1 to include the LVM editline shell.])], AC_MSG_ERROR(
|
||||
-[libedit could not be found which is required for the --enable-readline option.])
|
||||
+[libedit could not be found which is required for the --enable-editline option.])
|
||||
)
|
||||
fi
|
||||
|
||||
@@ -1557,7 +1557,7 @@ AC_MSG_CHECKING(whether to enable readline)
|
||||
AC_MSG_RESULT($READLINE)
|
||||
|
||||
if test "$EDITLINE" = yes; then
|
||||
- AC_CHECK_HEADERS(editline/readline.h editline/history.h,,hard_bailout)
|
||||
+ AC_CHECK_HEADERS(editline/readline.h,,hard_bailout)
|
||||
fi
|
||||
AC_MSG_CHECKING(whether to enable editline)
|
||||
AC_MSG_RESULT($EDITLINE)
|
||||
diff --git a/tools/lvm.c b/tools/lvm.c
|
||||
index 79b1210..cc67e92 100644
|
||||
--- a/tools/lvm.c
|
||||
+++ b/tools/lvm.c
|
||||
@@ -33,7 +33,6 @@ int main(int argc, char **argv)
|
||||
# endif
|
||||
# elif defined(EDITLINE_SUPPORT)
|
||||
# include <editline/readline.h>
|
||||
-# include <editline/history.h>
|
||||
# endif
|
||||
|
||||
static struct cmdline_context *_cmdline;
|
||||
--
|
||||
1.8.3.1
|
||||
|
12
lvm2.spec
12
lvm2.spec
@ -49,7 +49,7 @@ Name: lvm2
|
||||
Epoch: %{rhel}
|
||||
%endif
|
||||
Version: 2.03.11
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: GPLv2
|
||||
URL: https://sourceware.org/lvm2/
|
||||
Source0: https://sourceware.org/pub/lvm2/releases/LVM2.%{version}.tgz
|
||||
@ -84,6 +84,8 @@ Patch21: lvm2-2_03_12-test-check-read_only_volume_list-tagging-works.patch
|
||||
Patch22: lvm2-2_03_12-filter-mpath-work-with-nvme-devices.patch
|
||||
# BZ 1925871:
|
||||
Patch23: lvm2-2_03_12-dev_get_primary_dev-fix-invalid-path-check.patch
|
||||
# Fix editline compilation:
|
||||
Patch24: lvm2-2_03_12-lvm-Fix-editline-compilation.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -93,7 +95,7 @@ BuildRequires: gcc-c++
|
||||
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
||||
BuildRequires: libblkid-devel >= %{util_linux_version}
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: libedit
|
||||
BuildRequires: libedit-devel
|
||||
BuildRequires: libaio-devel
|
||||
%if %{enable_cluster}
|
||||
BuildRequires: corosynclib-devel >= %{corosync_version}
|
||||
@ -162,6 +164,7 @@ or more physical volumes and creating one or more logical volumes
|
||||
%patch21 -p1 -b .backup21
|
||||
%patch22 -p1 -b .backup22
|
||||
%patch23 -p1 -b .backup23
|
||||
%patch24 -p1 -b .backup24
|
||||
|
||||
%build
|
||||
%global _default_pid_dir /run
|
||||
@ -763,7 +766,10 @@ An extensive functional testsuite for LVM2.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Mar 16 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 2.03.11-3
|
||||
* Mon Mar 22 2021 Marian Csontos <mcsontos@redhat.com> - 2.03.11-4
|
||||
- Fix editline compilation.
|
||||
|
||||
* Tue Mar 16 2021 Marian Csontos <mcsontos@redhat.com> - 2.03.11-3
|
||||
- Replace readline library with editline.
|
||||
|
||||
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 2.03.11-2
|
||||
|
Loading…
Reference in New Issue
Block a user