import lvm2-2.03.12-2.el8
This commit is contained in:
commit
4e7c260570
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/LVM2.2.03.12.tgz
|
1
.lvm2.metadata
Normal file
1
.lvm2.metadata
Normal file
@ -0,0 +1 @@
|
||||
6d74d987b474dd0b45f239eb6dcc050622ad6962 SOURCES/LVM2.2.03.12.tgz
|
37
SOURCES/lvm2-2_03_13-vdo-fix-preload-of-kvdo.patch
Normal file
37
SOURCES/lvm2-2_03_13-vdo-fix-preload-of-kvdo.patch
Normal file
@ -0,0 +1,37 @@
|
||||
WHATS_NEW | 4 ++++
|
||||
lib/activate/activate.c | 10 +++-------
|
||||
2 files changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/WHATS_NEW b/WHATS_NEW
|
||||
index 6f339a5..04c6dcd 100644
|
||||
--- a/WHATS_NEW
|
||||
+++ b/WHATS_NEW
|
||||
@@ -1,3 +1,7 @@
|
||||
+Version 2.03.13 -
|
||||
+===============================
|
||||
+ Fix load of kvdo target when it is not present in memory (2.03.12).
|
||||
+
|
||||
Version 2.03.12 - 07th May 2021
|
||||
===============================
|
||||
Allow attaching cache to thin data volume.
|
||||
diff --git a/lib/activate/activate.c b/lib/activate/activate.c
|
||||
index 71db981..6bda738 100644
|
||||
--- a/lib/activate/activate.c
|
||||
+++ b/lib/activate/activate.c
|
||||
@@ -574,13 +574,9 @@ int module_present(struct cmd_context *cmd, const char *target_name)
|
||||
}
|
||||
|
||||
#ifdef MODPROBE_CMD
|
||||
- if (strcmp(target_name, MODULE_NAME_VDO) == 0) {
|
||||
- argv[1] = target_name; /* ATM kvdo is without dm- prefix */
|
||||
- if ((ret = exec_cmd(cmd, argv, NULL, 0)))
|
||||
- return ret;
|
||||
- }
|
||||
-
|
||||
- if (dm_snprintf(module, sizeof(module), "dm-%s", target_name) < 0) {
|
||||
+ if (strcmp(target_name, TARGET_NAME_VDO) == 0)
|
||||
+ argv[1] = MODULE_NAME_VDO; /* ATM kvdo is without dm- prefix */
|
||||
+ else if (dm_snprintf(module, sizeof(module), "dm-%s", target_name) < 0) {
|
||||
log_error("module_present module name too long: %s",
|
||||
target_name);
|
||||
return 0;
|
18
SOURCES/lvm2-rhel8.patch
Normal file
18
SOURCES/lvm2-rhel8.patch
Normal file
@ -0,0 +1,18 @@
|
||||
VERSION | 2 +-
|
||||
VERSION_DM | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/VERSION b/VERSION
|
||||
index d9c3e23..2610861 100644
|
||||
--- a/VERSION
|
||||
+++ b/VERSION
|
||||
@@ -1 +1 @@
|
||||
-2.03.12(2) (2021-05-07)
|
||||
+2.03.12(2)-RHEL8 (2021-05-19)
|
||||
diff --git a/VERSION_DM b/VERSION_DM
|
||||
index 6105a0f..0991c69 100644
|
||||
--- a/VERSION_DM
|
||||
+++ b/VERSION_DM
|
||||
@@ -1 +1 @@
|
||||
-1.02.177 (2021-05-07)
|
||||
+1.02.177-RHEL8 (2021-05-19)
|
33
SOURCES/lvm2-set-default-preferred_names.patch
Normal file
33
SOURCES/lvm2-set-default-preferred_names.patch
Normal file
@ -0,0 +1,33 @@
|
||||
conf/example.conf.in | 5 +++--
|
||||
lib/config/config_settings.h | 2 +-
|
||||
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/conf/example.conf.in b/conf/example.conf.in
|
||||
index b4a55ae..aaf73a4 100644
|
||||
--- a/conf/example.conf.in
|
||||
+++ b/conf/example.conf.in
|
||||
@@ -121,8 +121,9 @@ devices {
|
||||
#
|
||||
# Example
|
||||
# preferred_names = [ "^/dev/mpath/", "^/dev/mapper/mpath", "^/dev/[hs]d" ]
|
||||
- #
|
||||
- # This configuration option does not have a default value defined.
|
||||
+ #
|
||||
+ # This configuration option has an automatic default value.
|
||||
+ # preferred_names = [ "^/dev/mpath/", "^/dev/mapper/mpath", "^/dev/[hs]d" ]
|
||||
|
||||
# Configuration option devices/use_devicesfile.
|
||||
# Enable or disable the use of a devices file.
|
||||
diff --git a/lib/config/config_settings.h b/lib/config/config_settings.h
|
||||
index d3a42a1..f5dac4d 100644
|
||||
--- a/lib/config/config_settings.h
|
||||
+++ b/lib/config/config_settings.h
|
||||
@@ -269,7 +269,7 @@ cfg(devices_hints_CFG, "hints", devices_CFG_SECTION, CFG_DEFAULT_COMMENTED, CFG_
|
||||
" Use no hints.\n"
|
||||
"#\n")
|
||||
|
||||
-cfg_array(devices_preferred_names_CFG, "preferred_names", devices_CFG_SECTION, CFG_ALLOW_EMPTY | CFG_DEFAULT_UNDEFINED , CFG_TYPE_STRING, NULL, vsn(1, 2, 19), NULL, 0, NULL,
|
||||
+cfg_array(devices_preferred_names_CFG, "preferred_names", devices_CFG_SECTION, CFG_ALLOW_EMPTY | CFG_DEFAULT_COMMENTED, CFG_TYPE_STRING, "#S^/dev/mpath/#S^/dev/mapper/mpath#S^/dev/[hs]d", vsn(1, 2, 19), NULL, 0, NULL,
|
||||
"Select which path name to display for a block device.\n"
|
||||
"If multiple path names exist for a block device, and LVM needs to\n"
|
||||
"display a name for the device, the path names are matched against\n"
|
39
SOURCES/lvm2-test-skip-problematic-tests.patch
Normal file
39
SOURCES/lvm2-test-skip-problematic-tests.patch
Normal file
@ -0,0 +1,39 @@
|
||||
test/dbus/lvmdbustest.py | 1 +
|
||||
test/shell/lvcreate-usage.sh | 6 +++---
|
||||
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/test/dbus/lvmdbustest.py b/test/dbus/lvmdbustest.py
|
||||
index 6d69222..64faf84 100755
|
||||
--- a/test/dbus/lvmdbustest.py
|
||||
+++ b/test/dbus/lvmdbustest.py
|
||||
@@ -1856,6 +1856,7 @@ class TestDbusService(unittest.TestCase):
|
||||
# path to it. Additionally, we will take the symlink and do a lookup
|
||||
# (Manager.LookUpByLvmId) using it and the original device path to
|
||||
# ensure that we can find the PV.
|
||||
+ raise unittest.SkipTest('Test need fixing')
|
||||
symlink = None
|
||||
|
||||
pv = self.objs[PV_INT][0]
|
||||
diff --git a/test/shell/lvcreate-usage.sh b/test/shell/lvcreate-usage.sh
|
||||
index 6d46939..9e00f1c 100644
|
||||
--- a/test/shell/lvcreate-usage.sh
|
||||
+++ b/test/shell/lvcreate-usage.sh
|
||||
@@ -181,15 +181,15 @@ check lv_field $vg/$lv4 lv_read_ahead "auto"
|
||||
DEVICE=$(dmsetup deps -o blkdevname "$dev1" | sed -e "s,.*:\ (\(.*\)),/dev/\1,")
|
||||
RASZ=$(( $(blockdev --getra "$DEVICE" ) / 2 ))
|
||||
test "$RASZ" -ge 128 || RASZ="128"
|
||||
-check lv_field $vg/$lv4 lv_kernel_read_ahead "${RASZ}.00k" --units k
|
||||
+should check lv_field $vg/$lv4 lv_kernel_read_ahead "${RASZ}.00k" --units k
|
||||
lvcreate -vvvvv -L 8 -n $lv5 -i2 --stripesize 16k --readahead auto $vg
|
||||
check lv_field $vg/$lv5 lv_read_ahead "auto"
|
||||
# For 16k stripe we set '128k' as the is the minimum size we get when creating DM device
|
||||
-check lv_field $vg/$lv5 lv_kernel_read_ahead "128.00k" --units k
|
||||
+should check lv_field $vg/$lv5 lv_kernel_read_ahead "128.00k" --units k
|
||||
lvcreate -L 8 -n $lv6 -i2 --stripesize 128k --readahead auto $vg
|
||||
check lv_field $vg/$lv6 lv_read_ahead "auto"
|
||||
# For striped device we set double of strip size unrelated to underlaying dev RA size
|
||||
-check lv_field $vg/$lv6 lv_kernel_read_ahead "512.00k" --units k
|
||||
+should check lv_field $vg/$lv6 lv_kernel_read_ahead "512.00k" --units k
|
||||
lvremove -ff $vg
|
||||
|
||||
#
|
5100
SPECS/lvm2.spec
Normal file
5100
SPECS/lvm2.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user