New upstream release v2.02.172.
This commit is contained in:
parent
7db022a761
commit
467f2fc6fe
1
.gitignore
vendored
1
.gitignore
vendored
@ -74,3 +74,4 @@
|
||||
/LVM2.2.02.167.tgz
|
||||
/LVM2.2.02.168.tgz
|
||||
/LVM2.2.02.171.tgz
|
||||
/LVM2.2.02.172.tgz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v2.0.14 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlkJsL8ACgkQIoGRwVZ+LBdDyQCglMu7xeTWOFeLMTlCsKX7CuFv
|
||||
7TgAoO9d8AW3mFx8DAiw4cBkpOLftNdz
|
||||
=2q57
|
||||
-----END PGP SIGNATURE-----
|
7
LVM2.2.02.172.tgz.asc
Normal file
7
LVM2.2.02.172.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v2.0.14 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAllT0e4ACgkQIoGRwVZ+LBfVwgCg+QlL7VAkmsIhPczlc+n/1LsT
|
||||
qccAnitUgn6j6QaE6F8faF5NR94JiDgF
|
||||
=hQbN
|
||||
-----END PGP SIGNATURE-----
|
@ -1,28 +0,0 @@
|
||||
diff --git a/daemons/lvmdbusd/objectmanager.py b/daemons/lvmdbusd/objectmanager.py
|
||||
index a9d13a7..563b9ec 100644
|
||||
--- a/daemons/lvmdbusd/objectmanager.py
|
||||
+++ b/daemons/lvmdbusd/objectmanager.py
|
||||
@@ -223,8 +223,9 @@ class ObjectManager(AutomatedProperties):
|
||||
:param lvm_id: The lvm identifier
|
||||
"""
|
||||
with self.rlock:
|
||||
- if lvm_id in self._id_to_object_path:
|
||||
- return self.get_object_by_path(self._id_to_object_path[lvm_id])
|
||||
+ lookup_rc = self._id_lookup(lvm_id)
|
||||
+ if lookup_rc:
|
||||
+ return self.get_object_by_path(lookup_rc)
|
||||
return None
|
||||
|
||||
def get_object_path_by_lvm_id(self, lvm_id):
|
||||
@@ -234,8 +235,9 @@ class ObjectManager(AutomatedProperties):
|
||||
:return: Object path or '/' if not found
|
||||
"""
|
||||
with self.rlock:
|
||||
- if lvm_id in self._id_to_object_path:
|
||||
- return self._id_to_object_path[lvm_id]
|
||||
+ lookup_rc = self._id_lookup(lvm_id)
|
||||
+ if lookup_rc:
|
||||
+ return lookup_rc
|
||||
return '/'
|
||||
|
||||
def _uuid_verify(self, path, uuid, lvm_id):
|
@ -1,15 +0,0 @@
|
||||
diff --git a/daemons/lvmdbusd/utils.py b/daemons/lvmdbusd/utils.py
|
||||
index af9e10a..170824d 100644
|
||||
--- a/daemons/lvmdbusd/utils.py
|
||||
+++ b/daemons/lvmdbusd/utils.py
|
||||
@@ -519,7 +519,9 @@ def add_no_notify(cmdline):
|
||||
if '--config' in cmdline:
|
||||
for i, arg in enumerate(cmdline):
|
||||
if arg == '--config':
|
||||
- cmdline[i] += "global/notify_dbus=0"
|
||||
+ if len(cmdline) <= i+1:
|
||||
+ raise dbus.exceptions.DBusException("Missing value for --config option.")
|
||||
+ cmdline[i+1] += " global/notify_dbus=0"
|
||||
break
|
||||
else:
|
||||
cmdline.extend(['--config', 'global/notify_dbus=0'])
|
@ -1,21 +0,0 @@
|
||||
daemons/lvmdbusd/cmdhandler.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
|
||||
diff --git a/daemons/lvmdbusd/cmdhandler.py b/daemons/lvmdbusd/cmdhandler.py
|
||||
index 8ed38cb..a883f1e 100644
|
||||
--- a/daemons/lvmdbusd/cmdhandler.py
|
||||
+++ b/daemons/lvmdbusd/cmdhandler.py
|
||||
@@ -618,10 +618,10 @@ def vg_reduce(vg_name, missing, pv_devices, reduce_options):
|
||||
cmd = ['vgreduce']
|
||||
cmd.extend(options_to_cli_args(reduce_options))
|
||||
|
||||
- if len(pv_devices) == 0:
|
||||
- cmd.append('--all')
|
||||
if missing:
|
||||
cmd.append('--removemissing')
|
||||
+ elif len(pv_devices) == 0:
|
||||
+ cmd.append('--all')
|
||||
|
||||
cmd.append(vg_name)
|
||||
cmd.extend(pv_devices)
|
52
lvm2.spec
52
lvm2.spec
@ -1,4 +1,4 @@
|
||||
%global device_mapper_version 1.02.140
|
||||
%global device_mapper_version 1.02.141
|
||||
|
||||
%global enable_cache 1
|
||||
%global enable_cluster 1
|
||||
@ -47,26 +47,20 @@
|
||||
%global enable_python 1
|
||||
%endif
|
||||
|
||||
# Do not reset Release to 1 unless both lvm2 and device-mapper
|
||||
# Do not reset Release to 1 unless both lvm2 and device-mapper
|
||||
# versions are increased together.
|
||||
|
||||
Summary: Userland logical volume management tools
|
||||
Summary: Userland logical volume management tools
|
||||
Name: lvm2
|
||||
|
||||
Version: 2.02.171
|
||||
Release: 3%{?dist}
|
||||
Version: 2.02.172
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://sources.redhat.com/lvm2
|
||||
Source0: ftp://sources.redhat.com/pub/lvm2/releases/LVM2.%{version}.tgz
|
||||
Patch0: lvm2-set-default-preferred_names.patch
|
||||
Patch1: lvm2-lvmetad-timeout.patch
|
||||
# Commit 405a3689bcc4 related to RHBZ#1445302
|
||||
Patch2: lvm2-2_02_172-lvmdbusd-fix-pv-lookup.patch
|
||||
# Commit 16c6d9f11ab5 fixing RHBZ#1451612
|
||||
Patch3: lvm2-2_02_172-lvmdbusd-mangling-config.patch
|
||||
# Commit 192d142e1cd3 fixing RHBZ#1455471
|
||||
Patch4: lvm2-2_02_172-lvmdbusd-removemissing.patch
|
||||
|
||||
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
||||
BuildRequires: libblkid-devel >= %{util_linux_version}
|
||||
@ -122,9 +116,6 @@ or more physical volumes and creating one or more logical volumes
|
||||
%setup -q -n LVM2.%{version}
|
||||
%patch0 -p1 -b .preferred_names
|
||||
%patch1 -p1 -b .lvmetad_timeout
|
||||
%patch2 -p1 -b .lvmdbusd_lookup
|
||||
%patch3 -p1 -b .lvmdbusd_config_mangling
|
||||
%patch4 -p1 -b .lvmdbusd_removemissing
|
||||
|
||||
%build
|
||||
%global _default_pid_dir /run
|
||||
@ -857,6 +848,39 @@ the device-mapper event library.
|
||||
%{_libdir}/pkgconfig/devmapper-event.pc
|
||||
|
||||
%changelog
|
||||
* Thu Jun 29 2017 Marian Csontos <mcsontos@redhat.com> - 2.02.172-1
|
||||
- Do not lvdisplay --maps unset settings of cache pool.
|
||||
- Fix lvdisplay --maps for cache pool without policy settings.
|
||||
- Support aborting of flushing cache LV.
|
||||
- Improve lvcreate --cachepool arg validation.
|
||||
- Cache format2 flag is now using segment name type field.
|
||||
- Disallow cachepool creation with policy cleaner and mode writeback.
|
||||
- Lvconvert --repair handles failing raid legs (present but marked 'D'ead).
|
||||
- Add display_percent helper function for printing percent values.
|
||||
- Add dm_percent_to_round_float for adjusted percentage rounding.
|
||||
- Fix lvcreate extent percentage calculation for mirrors.
|
||||
- Reenable conversion of data and metadata thin-pool volumes to raid.
|
||||
- Linear to RAID1 upconverts now use "recover" sync action, not "resync".
|
||||
- No longer necessary to '--force' a repair for RAID1.
|
||||
- Improve raid status reporting with lvs.
|
||||
- dm_get_status_raid() handle better some incosistent md statuses.
|
||||
- Limit maximal size of thin-pool for specific chunk size.
|
||||
- Print a warning about in-use PVs with no VG using them.
|
||||
- Disable automatic clearing of PVs that look like in-use orphans.
|
||||
- Extend validation of filesystems resized by fsadm.
|
||||
- Properly handle subshell return codes in fsadm.
|
||||
- Stop using '--yes' mode when fsadm runs without terminal.
|
||||
- Support storing status flags via segtype name field.
|
||||
- Enhance lvconvert automatic settings of possible (raid) LV types.
|
||||
- Add missing NULL to argv array when spliting cmdline arguments.
|
||||
- Don't reinstate still-missing devices when correcting inconsistent metadata.
|
||||
- Allow lvchange to change properties on a thin pool data sub LV.
|
||||
- Fix reusing of dm_task structure for status reading (used by dmeventd).
|
||||
- Drop unneeded --config option from raid dmeventd plugin.
|
||||
- Accept truncated files in calls to dm_stats_update_regions_from_fd().
|
||||
- Restore Warning by 5% increment when thin-pool is over 80% (1.02.138).
|
||||
- Reset array with dead rimage devices once raid gets in sync.
|
||||
|
||||
* Fri Jun 09 2017 Marian Csontos <mcsontos@redhat.com> - 2.02.171-3
|
||||
- Fix lvmdbusd not passing --all with vgreduce --removemissing.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (LVM2.2.02.171.tgz) = 801adcc2ae483f81edf6bfba73090b6b8f710370e48764f08a62da71d617157075bea01593c2535ad5ba71dcb5e0cfe83cec9a65180a6e8b9e0d214bdee79883
|
||||
SHA512 (LVM2.2.02.172.tgz) = 402612667f279be5f1c682b9037022788e9b76e3157907a0832e8b7847c3aa96e4b44a3bd880657a7e577ab46db0e4f283ac6edbb52502e365617633c802ae40
|
||||
|
Loading…
Reference in New Issue
Block a user