folded patches into tarball & a few more fixes
This commit is contained in:
parent
75746c1fae
commit
423a9aaabb
@ -1 +1 @@
|
|||||||
LVM2.2.02.52.tgz
|
LVM2.2.02.53.tgz
|
||||||
|
7
LVM2.2.02.53.tgz.asc
Normal file
7
LVM2.2.02.53.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||||
|
|
||||||
|
iD8DBQBKvRepIoGRwVZ+LBcRAjPTAKDbxSa/ohWlc9f1sdVuZ8+/34hyXgCeJXUA
|
||||||
|
MBicW/9WJRiltnFa8FF/kyk=
|
||||||
|
=XBZd
|
||||||
|
-----END PGP SIGNATURE-----
|
@ -1,33 +0,0 @@
|
|||||||
--- LVM2.2.02.52/daemons/dmeventd/plugins/mirror/dmeventd_mirror.c 2009-06-30 19:39:31.000000000 +0100
|
|
||||||
+++ LVM2.2.02.52-new2/daemons/dmeventd/plugins/mirror/dmeventd_mirror.c 2009-09-17 12:51:29.637533000 +0100
|
|
||||||
@@ -126,8 +126,10 @@
|
|
||||||
return ME_IGNORE;
|
|
||||||
}
|
|
||||||
|
|
||||||
-static void _temporary_log_fn(int level, const char *file __attribute((unused)),
|
|
||||||
+static void _temporary_log_fn(int level,
|
|
||||||
+ const char *file __attribute((unused)),
|
|
||||||
int line __attribute((unused)),
|
|
||||||
+ int dm_errno __attribute((unused)),
|
|
||||||
const char *format)
|
|
||||||
{
|
|
||||||
if (!strncmp(format, "WARNING: ", 9) && (level < 5))
|
|
||||||
--- LVM2.2.02.52/daemons/dmeventd/plugins/snapshot/dmeventd_snapshot.c 2008-10-13 13:06:30.000000000 +0100
|
|
||||||
+++ LVM2.2.02.52-new2/daemons/dmeventd/plugins/snapshot/dmeventd_snapshot.c 2009-09-17 12:51:29.641533000 +0100
|
|
||||||
@@ -57,6 +57,7 @@
|
|
||||||
static void _temporary_log_fn(int level,
|
|
||||||
const char *file __attribute((unused)),
|
|
||||||
int line __attribute((unused)),
|
|
||||||
+ int dm_errno __attribute((unused)),
|
|
||||||
const char *format)
|
|
||||||
{
|
|
||||||
if (!strncmp(format, "WARNING: ", 9) && (level < 5))
|
|
||||||
--- LVM2.2.02.52/WHATS_NEW 2009-09-17 12:50:42.799264000 +0100
|
|
||||||
+++ LVM2.2.02.52-new2/WHATS_NEW 2009-09-17 12:51:51.499101000 +0100
|
|
||||||
@@ -1,5 +1,6 @@
|
|
||||||
Version 2.02.53 -
|
|
||||||
=====================================
|
|
||||||
+ Fix dmeventd _temporary_log_fn parameters. (2.02.50)
|
|
||||||
Update lvm2 monitoring script to lvm2_monitoring_init_red_hat.in.
|
|
||||||
|
|
||||||
Version 2.02.52 - 15th September 2009
|
|
@ -1,38 +0,0 @@
|
|||||||
--- LVM2.2.02.52/doc/example.conf 2009-09-15 14:49:11.000000000 +0100
|
|
||||||
+++ LVM2.2.02.52-new3/doc/example.conf 2009-09-17 13:18:59.736033000 +0100
|
|
||||||
@@ -435,7 +435,7 @@
|
|
||||||
|
|
||||||
# Event daemon
|
|
||||||
#
|
|
||||||
-# dmeventd {
|
|
||||||
+dmeventd {
|
|
||||||
# mirror_library is the library used when monitoring a mirror device.
|
|
||||||
#
|
|
||||||
# "libdevmapper-event-lvm2mirror.so" attempts to recover from
|
|
||||||
@@ -443,7 +443,7 @@
|
|
||||||
# reconfigures a mirror as necessary. If no mirror library is
|
|
||||||
# provided, mirrors are not monitored through dmeventd.
|
|
||||||
|
|
||||||
- # mirror_library = "libdevmapper-event-lvm2mirror.so"
|
|
||||||
+ mirror_library = "libdevmapper-event-lvm2mirror.so"
|
|
||||||
|
|
||||||
# snapshot_library is the library used when monitoring a snapshot device.
|
|
||||||
#
|
|
||||||
@@ -452,6 +452,6 @@
|
|
||||||
# snapshot exceedes 80%. The warning is repeated when 85%, 90% and
|
|
||||||
# 95% of the snapshot are filled.
|
|
||||||
|
|
||||||
- # snapshot_library = "libdevmapper-event-lvm2snapshot.so"
|
|
||||||
-#}
|
|
||||||
+ snapshot_library = "libdevmapper-event-lvm2snapshot.so"
|
|
||||||
+}
|
|
||||||
|
|
||||||
--- LVM2.2.02.52/WHATS_NEW 2009-09-17 13:17:07.822006000 +0100
|
|
||||||
+++ LVM2.2.02.52-new3/WHATS_NEW 2009-09-17 13:19:57.674596000 +0100
|
|
||||||
@@ -1,5 +1,6 @@
|
|
||||||
Version 2.02.53 -
|
|
||||||
=====================================
|
|
||||||
+ Enable dmeventd monitoring section of config file by default.
|
|
||||||
Fix dmeventd _temporary_log_fn parameters. (2.02.50)
|
|
||||||
Update lvm2 monitoring script to lvm2_monitoring_init_red_hat.in.
|
|
||||||
|
|
@ -1,174 +0,0 @@
|
|||||||
diff -rNup LVM2.2.02.52/configure LVM2.2.02.52-new/configure
|
|
||||||
--- LVM2.2.02.52/configure 2009-09-14 23:57:46.000000000 +0100
|
|
||||||
+++ LVM2.2.02.52-new/configure 2009-09-17 00:34:32.915966000 +0100
|
|
||||||
@@ -15404,7 +15404,7 @@ LVM_LIBAPI=`echo "$VER" | $AWK -F '[()]'
|
|
||||||
|
|
||||||
|
|
||||||
################################################################################
|
|
||||||
-ac_config_files="$ac_config_files Makefile make.tmpl daemons/Makefile daemons/clvmd/Makefile daemons/cmirrord/Makefile daemons/dmeventd/Makefile daemons/dmeventd/libdevmapper-event.pc daemons/dmeventd/plugins/Makefile daemons/dmeventd/plugins/mirror/Makefile daemons/dmeventd/plugins/snapshot/Makefile doc/Makefile include/Makefile lib/Makefile lib/format1/Makefile lib/format_pool/Makefile lib/locking/Makefile lib/mirror/Makefile lib/misc/lvm-version.h lib/snapshot/Makefile libdm/Makefile libdm/libdevmapper.pc liblvm/Makefile liblvm/liblvm2app.pc man/Makefile po/Makefile scripts/clvmd_init_red_hat scripts/Makefile test/Makefile test/api/Makefile tools/Makefile udev/Makefile"
|
|
||||||
+ac_config_files="$ac_config_files Makefile make.tmpl daemons/Makefile daemons/clvmd/Makefile daemons/cmirrord/Makefile daemons/dmeventd/Makefile daemons/dmeventd/libdevmapper-event.pc daemons/dmeventd/plugins/Makefile daemons/dmeventd/plugins/mirror/Makefile daemons/dmeventd/plugins/snapshot/Makefile doc/Makefile include/Makefile lib/Makefile lib/format1/Makefile lib/format_pool/Makefile lib/locking/Makefile lib/mirror/Makefile lib/misc/lvm-version.h lib/snapshot/Makefile libdm/Makefile libdm/libdevmapper.pc liblvm/Makefile liblvm/liblvm2app.pc man/Makefile po/Makefile scripts/clvmd_init_red_hat scripts/lvm2_monitoring_init_red_hat scripts/Makefile test/Makefile test/api/Makefile tools/Makefile udev/Makefile"
|
|
||||||
|
|
||||||
cat >confcache <<\_ACEOF
|
|
||||||
# This file is a shell script that caches the results of configure
|
|
||||||
@@ -16029,6 +16029,7 @@ do
|
|
||||||
"man/Makefile") CONFIG_FILES="$CONFIG_FILES man/Makefile" ;;
|
|
||||||
"po/Makefile") CONFIG_FILES="$CONFIG_FILES po/Makefile" ;;
|
|
||||||
"scripts/clvmd_init_red_hat") CONFIG_FILES="$CONFIG_FILES scripts/clvmd_init_red_hat" ;;
|
|
||||||
+ "scripts/lvm2_monitoring_init_red_hat") CONFIG_FILES="$CONFIG_FILES scripts/lvm2_monitoring_init_red_hat" ;;
|
|
||||||
"scripts/Makefile") CONFIG_FILES="$CONFIG_FILES scripts/Makefile" ;;
|
|
||||||
"test/Makefile") CONFIG_FILES="$CONFIG_FILES test/Makefile" ;;
|
|
||||||
"test/api/Makefile") CONFIG_FILES="$CONFIG_FILES test/api/Makefile" ;;
|
|
||||||
diff -rNup LVM2.2.02.52/configure.in LVM2.2.02.52-new/configure.in
|
|
||||||
--- LVM2.2.02.52/configure.in 2009-09-14 23:57:46.000000000 +0100
|
|
||||||
+++ LVM2.2.02.52-new/configure.in 2009-09-17 00:34:32.928965000 +0100
|
|
||||||
@@ -1159,6 +1159,7 @@ liblvm/liblvm2app.pc
|
|
||||||
man/Makefile
|
|
||||||
po/Makefile
|
|
||||||
scripts/clvmd_init_red_hat
|
|
||||||
+scripts/lvm2_monitoring_init_red_hat
|
|
||||||
scripts/Makefile
|
|
||||||
test/Makefile
|
|
||||||
test/api/Makefile
|
|
||||||
diff -rNup LVM2.2.02.52/scripts/lvm2_monitoring_init_red_hat.in LVM2.2.02.52-new/scripts/lvm2_monitoring_init_red_hat.in
|
|
||||||
--- LVM2.2.02.52/scripts/lvm2_monitoring_init_red_hat.in 1970-01-01 01:00:00.000000000 +0100
|
|
||||||
+++ LVM2.2.02.52-new/scripts/lvm2_monitoring_init_red_hat.in 2009-09-17 00:34:32.933965000 +0100
|
|
||||||
@@ -0,0 +1,119 @@
|
|
||||||
+#!/bin/bash
|
|
||||||
+#
|
|
||||||
+# Copyright (C) 2007-2009 Red Hat, Inc. All rights reserved.
|
|
||||||
+#
|
|
||||||
+# This copyrighted material is made available to anyone wishing to use,
|
|
||||||
+# modify, copy, or redistribute it subject to the terms and conditions
|
|
||||||
+# of the GNU General Public License v.2.
|
|
||||||
+#
|
|
||||||
+# You should have received a copy of the GNU General Public License
|
|
||||||
+# along with this program; if not, write to the Free Software Foundation,
|
|
||||||
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
|
||||||
+#
|
|
||||||
+# This file is part of LVM2.
|
|
||||||
+# It is required for the proper handling of failures of LVM2 mirror
|
|
||||||
+# devices that were created using the -m option of lvcreate.
|
|
||||||
+#
|
|
||||||
+#
|
|
||||||
+# chkconfig: 12345 02 99
|
|
||||||
+# description: Starts and stops dmeventd monitoring for lvm2
|
|
||||||
+#
|
|
||||||
+# For Red-Hat-based distributions such as Fedora, RHEL, CentOS.
|
|
||||||
+#
|
|
||||||
+### BEGIN INIT INFO
|
|
||||||
+# Provides: lvm2-monitor
|
|
||||||
+# Required-Start: $local_fs
|
|
||||||
+# Required-Stop: $local_fs
|
|
||||||
+# Default-Start: 1 2 3 4 5
|
|
||||||
+# Default-Stop: 0 6
|
|
||||||
+# Short-Description: Monitoring of LVM2 mirrors, snapshots etc. using dmeventd
|
|
||||||
+### END INIT INFO
|
|
||||||
+
|
|
||||||
+. /etc/init.d/functions
|
|
||||||
+
|
|
||||||
+DAEMON=lvm2_monitor
|
|
||||||
+
|
|
||||||
+exec_prefix=@exec_prefix@
|
|
||||||
+sbindir=@sbindir@
|
|
||||||
+
|
|
||||||
+VGCHANGE=${sbindir}/vgchange
|
|
||||||
+VGS=${sbindir}/vgs
|
|
||||||
+
|
|
||||||
+LOCK_FILE="/var/lock/subsys/$DAEMON"
|
|
||||||
+
|
|
||||||
+WARN=1
|
|
||||||
+
|
|
||||||
+start()
|
|
||||||
+{
|
|
||||||
+ ret=0
|
|
||||||
+ # TODO do we want to separate out already active groups only?
|
|
||||||
+ VGSLIST=`$VGS --noheadings -o name 2> /dev/null`
|
|
||||||
+ for vg in $VGSLIST
|
|
||||||
+ do
|
|
||||||
+ action "Starting monitoring for VG $vg:" $VGCHANGE --monitor y $vg || ret=$?
|
|
||||||
+ done
|
|
||||||
+
|
|
||||||
+ return $ret
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+stop()
|
|
||||||
+{
|
|
||||||
+ ret=0
|
|
||||||
+ # TODO do we want to separate out already active groups only?
|
|
||||||
+ if test "$WARN" = "1"; then
|
|
||||||
+ echo "Not stopping monitoring, this is a dangerous operation. Please use force-stop to override."
|
|
||||||
+ return 1
|
|
||||||
+ fi
|
|
||||||
+ VGSLIST=`$VGS --noheadings -o name 2> /dev/null`
|
|
||||||
+ for vg in $VGSLIST
|
|
||||||
+ do
|
|
||||||
+ action "Stopping monitoring for VG $vg:" $VGCHANGE --monitor n $vg || ret=$?
|
|
||||||
+ done
|
|
||||||
+ return $ret
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+rtrn=1
|
|
||||||
+
|
|
||||||
+# See how we were called.
|
|
||||||
+case "$1" in
|
|
||||||
+ start)
|
|
||||||
+ start
|
|
||||||
+ rtrn=$?
|
|
||||||
+ [ $rtrn = 0 ] && touch $LOCK_FILE
|
|
||||||
+ ;;
|
|
||||||
+
|
|
||||||
+ force-stop)
|
|
||||||
+ WARN=0
|
|
||||||
+ stop
|
|
||||||
+ rtrn=$?
|
|
||||||
+ [ $rtrn = 0 ] && rm -f $LOCK_FILE
|
|
||||||
+ ;;
|
|
||||||
+
|
|
||||||
+ stop)
|
|
||||||
+ test "$runlevel" = "0" && WARN=0
|
|
||||||
+ test "$runlevel" = "6" && WARN=0
|
|
||||||
+ stop
|
|
||||||
+ rtrn=$?
|
|
||||||
+ [ $rtrn = 0 ] && rm -f $LOCK_FILE
|
|
||||||
+ ;;
|
|
||||||
+
|
|
||||||
+ restart)
|
|
||||||
+ WARN=0
|
|
||||||
+ if stop
|
|
||||||
+ then
|
|
||||||
+ start
|
|
||||||
+ fi
|
|
||||||
+ rtrn=$?
|
|
||||||
+ ;;
|
|
||||||
+
|
|
||||||
+ status)
|
|
||||||
+ # TODO anyone with an idea how to dump monitored volumes?
|
|
||||||
+ ;;
|
|
||||||
+
|
|
||||||
+ *)
|
|
||||||
+ echo $"Usage: $0 {start|stop|restart|status|force-stop}"
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
+exit $rtrn
|
|
||||||
diff -rNup LVM2.2.02.52/scripts/Makefile.in LVM2.2.02.52-new/scripts/Makefile.in
|
|
||||||
--- LVM2.2.02.52/scripts/Makefile.in 2009-05-14 17:46:13.000000000 +0100
|
|
||||||
+++ LVM2.2.02.52-new/scripts/Makefile.in 2009-09-17 00:34:32.937965000 +0100
|
|
||||||
@@ -29,4 +29,4 @@ endif
|
|
||||||
|
|
||||||
install_lvm2: install
|
|
||||||
|
|
||||||
-DISTCLEAN_TARGETS += clvmd_init_red_hat
|
|
||||||
+DISTCLEAN_TARGETS += clvmd_init_red_hat lvm2_monitoring_init_red_hat
|
|
||||||
diff -rNup LVM2.2.02.52/WHATS_NEW LVM2.2.02.52-new/WHATS_NEW
|
|
||||||
--- LVM2.2.02.52/WHATS_NEW 2009-09-15 14:49:10.000000000 +0100
|
|
||||||
+++ LVM2.2.02.52-new/WHATS_NEW 2009-09-17 00:39:02.216229000 +0100
|
|
||||||
@@ -1,3 +1,7 @@
|
|
||||||
+Version 2.02.53 -
|
|
||||||
+=====================================
|
|
||||||
+ Update lvm2 monitoring script to lvm2_monitoring_init_red_hat.in.
|
|
||||||
+
|
|
||||||
Version 2.02.52 - 15th September 2009
|
|
||||||
=====================================
|
|
||||||
Update _process_one_vg to cleanup properly after vg_read_error.
|
|
17
lvm2.spec
17
lvm2.spec
@ -1,4 +1,4 @@
|
|||||||
%define device_mapper_version 1.02.37
|
%define device_mapper_version 1.02.38
|
||||||
%define corosync_version 1.0.0-1
|
%define corosync_version 1.0.0-1
|
||||||
%define clusterlib_version 3.0.0-20
|
%define clusterlib_version 3.0.0-20
|
||||||
|
|
||||||
@ -7,8 +7,8 @@
|
|||||||
|
|
||||||
Summary: Userland logical volume management tools
|
Summary: Userland logical volume management tools
|
||||||
Name: lvm2
|
Name: lvm2
|
||||||
Version: 2.02.52
|
Version: 2.02.53
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://sources.redhat.com/lvm2
|
URL: http://sources.redhat.com/lvm2
|
||||||
@ -16,9 +16,6 @@ Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
|||||||
|
|
||||||
# Customise lvmconf.sh for built-in clustered locking in Fedora
|
# Customise lvmconf.sh for built-in clustered locking in Fedora
|
||||||
Patch0: cluster-locking-built-in.patch
|
Patch0: cluster-locking-built-in.patch
|
||||||
Patch1: lvm2-2_02_53-lvm2_monitoring_init.patch
|
|
||||||
Patch2: lvm2-2_02_53-dmeventd_log_fn.patch
|
|
||||||
Patch3: lvm2-2_02_53-enable_dmeventd_in_lvm_conf.patch
|
|
||||||
|
|
||||||
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
@ -47,9 +44,6 @@ or more physical volumes and creating one or more logical volumes
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n LVM2.%{version}
|
%setup -q -n LVM2.%{version}
|
||||||
%patch0 -p1 -b .locking
|
%patch0 -p1 -b .locking
|
||||||
%patch1 -p1 -b .lvm2_monitoring
|
|
||||||
%patch2 -p1 -b .dmeventd_log_fn
|
|
||||||
%patch3 -p1 -b .enable_dmeventd_in_conf
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%define _exec_prefix /
|
%define _exec_prefix /
|
||||||
@ -385,6 +379,11 @@ the device-mapper event library.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 25 2009 Alasdair Kergon <agk@redhat.com> - 2.02.53-1
|
||||||
|
- Create any directories in /dev with umask 022. (#507397)
|
||||||
|
- Handle paths supplied to dm_task_set_name by getting name from /dev/mapper.
|
||||||
|
- Add splitname and --yes to dmsetup man page.
|
||||||
|
|
||||||
* Thu Sep 24 2009 Peter Rajnoha <prajnoha@redhat.com> - 2.02.52-4
|
* Thu Sep 24 2009 Peter Rajnoha <prajnoha@redhat.com> - 2.02.52-4
|
||||||
- Disable udev synchronisation code (revert previous build).
|
- Disable udev synchronisation code (revert previous build).
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
f3b3aed6f6aacd8f351d9a5da097293f LVM2.2.02.52.tgz
|
24d863fdaec51faba79513ad3b537f4e LVM2.2.02.53.tgz
|
||||||
|
Loading…
Reference in New Issue
Block a user