parent
2114c4103f
commit
2b4a99e330
@ -1,26 +0,0 @@
|
|||||||
From d1ed4ce6ce9f201435af61982a36f97e9d9d2f94 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Williamson <awilliam@redhat.com>
|
|
||||||
Date: Tue, 21 Mar 2023 11:46:54 -0700
|
|
||||||
Subject: [PATCH] Fix import of utils from lvmdbusd.cfg
|
|
||||||
|
|
||||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
|
||||||
---
|
|
||||||
daemons/lvmdbusd/cfg.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/daemons/lvmdbusd/cfg.py b/daemons/lvmdbusd/cfg.py
|
|
||||||
index 9da4b1267..9f4360100 100644
|
|
||||||
--- a/daemons/lvmdbusd/cfg.py
|
|
||||||
+++ b/daemons/lvmdbusd/cfg.py
|
|
||||||
@@ -11,7 +11,7 @@ import os
|
|
||||||
import multiprocessing
|
|
||||||
import queue
|
|
||||||
import itertools
|
|
||||||
-from utils import LvmDebugData
|
|
||||||
+from lvmdbusd.utils import LvmDebugData
|
|
||||||
|
|
||||||
from lvmdbusd import path
|
|
||||||
|
|
||||||
--
|
|
||||||
2.40.0
|
|
||||||
|
|
@ -1,42 +0,0 @@
|
|||||||
From da1255cdb68ab33a90136ebbec2fa0fda034f6a2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tony Asleson <tasleson@redhat.com>
|
|
||||||
Date: Thu, 30 Mar 2023 10:07:13 -0500
|
|
||||||
Subject: [PATCH 2/3] lvmdbusd: Correct locking for _common_log
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Reduce the lock time and include the flush in the lock.
|
|
||||||
|
|
||||||
Reported by: Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
|
|
||||||
---
|
|
||||||
daemons/lvmdbusd/utils.py | 5 +++--
|
|
||||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/daemons/lvmdbusd/utils.py b/daemons/lvmdbusd/utils.py
|
|
||||||
index 6013b656f..fdd7578c1 100644
|
|
||||||
--- a/daemons/lvmdbusd/utils.py
|
|
||||||
+++ b/daemons/lvmdbusd/utils.py
|
|
||||||
@@ -323,16 +323,17 @@ def _format_log_entry(msg):
|
|
||||||
|
|
||||||
|
|
||||||
def _common_log(msg, *attributes):
|
|
||||||
- cfg.stdout_lock.acquire()
|
|
||||||
msg = _format_log_entry(msg)
|
|
||||||
|
|
||||||
+ cfg.stdout_lock.acquire()
|
|
||||||
+
|
|
||||||
if STDOUT_TTY and attributes:
|
|
||||||
print(color(msg, *attributes))
|
|
||||||
else:
|
|
||||||
print(msg)
|
|
||||||
|
|
||||||
- cfg.stdout_lock.release()
|
|
||||||
sys.stdout.flush()
|
|
||||||
+ cfg.stdout_lock.release()
|
|
||||||
|
|
||||||
|
|
||||||
# Serializes access to stdout to prevent interleaved output
|
|
||||||
--
|
|
||||||
2.39.2
|
|
||||||
|
|
@ -1,47 +0,0 @@
|
|||||||
From feb7c701aa86fda1f13f6c262770a8e90e8ddb09 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tony Asleson <tasleson@redhat.com>
|
|
||||||
Date: Thu, 30 Mar 2023 10:10:23 -0500
|
|
||||||
Subject: [PATCH 3/3] lvmdbusd: Correct seg. fault on s390x ELN
|
|
||||||
|
|
||||||
syscall 186 is specific to x86 64bit. As this is different from arch
|
|
||||||
to arch and between same arch different arch size we will only grab
|
|
||||||
thread ID using built-in python support if it is supported.
|
|
||||||
|
|
||||||
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=2166931
|
|
||||||
---
|
|
||||||
daemons/lvmdbusd/utils.py | 11 +++++++++--
|
|
||||||
1 file changed, 9 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/daemons/lvmdbusd/utils.py b/daemons/lvmdbusd/utils.py
|
|
||||||
index fdd7578c1..27b869c13 100644
|
|
||||||
--- a/daemons/lvmdbusd/utils.py
|
|
||||||
+++ b/daemons/lvmdbusd/utils.py
|
|
||||||
@@ -11,7 +11,6 @@ import xml.etree.ElementTree as Et
|
|
||||||
import sys
|
|
||||||
import inspect
|
|
||||||
import collections
|
|
||||||
-import ctypes
|
|
||||||
import errno
|
|
||||||
import fcntl
|
|
||||||
import os
|
|
||||||
@@ -305,8 +304,16 @@ class DebugMessages(object):
|
|
||||||
self.queue.clear()
|
|
||||||
|
|
||||||
|
|
||||||
+def _get_tid():
|
|
||||||
+ try:
|
|
||||||
+ # Only 3.8 and later have this
|
|
||||||
+ return threading.get_native_id()
|
|
||||||
+ except:
|
|
||||||
+ return -1
|
|
||||||
+
|
|
||||||
+
|
|
||||||
def _format_log_entry(msg):
|
|
||||||
- tid = ctypes.CDLL('libc.so.6').syscall(186)
|
|
||||||
+ tid = _get_tid()
|
|
||||||
|
|
||||||
if not cfg.systemd and STDOUT_TTY:
|
|
||||||
msg = "%s: %d:%d - %s" % \
|
|
||||||
--
|
|
||||||
2.39.2
|
|
||||||
|
|
@ -1,16 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
|
|
||||||
iQIzBAABCAAdFiEE1QGkeEQK4v0TChvouREkMeUJA58FAmQZpUwACgkQuREkMeUJ
|
|
||||||
A59piw//TRzaglBpTiwuTDzmmLtIKOvMEx3xEu9aYtxV6QQVYnI7IaA52TMI+9LJ
|
|
||||||
nNA5sfsF3XJtJ6/8ycRqS9+8KC3tRBSlWfFUpGP68RGA8Y45mBFyQKDvDk7fBK0R
|
|
||||||
lruZOcLyfh1q6sjKm2B12UFcfYRNjsoupkJSf447sGJO4CsZQPUUyJsXolpFQ1Gz
|
|
||||||
KhCTDlhyJ4vQA4U7BgrNRuqqrfqFq8ydlmdS3BfEkJgU9n8bNjB8UsWrVlJNac99
|
|
||||||
ugUNY4Becs4khwcI5NTIDveVD6BO0WLz6gneMbh2IABSe+Qulk2mJHboNtl3t6p5
|
|
||||||
TFRS9awfWeQyKi3yHm0jvpSreUhUD7Ix/jRzYr3+auIIrj1BAk7ZivmFhzmmsHxm
|
|
||||||
P2wbTtMI1tI8a29UIRxlsMrxUUNhj2D/cdFPLT8cady0iqaJyYTEHtE87uHjjMTv
|
|
||||||
WWUnFMK87xmBVMoY6NUVDt80FJW2VCO2oWHDPisizO+dZBr4mFghwv2v0nmNn1F7
|
|
||||||
oEnrfHEDtUxnzv8owRGC70wRE5Pr+W0KqDHMa4gfwZLuWN0XxT4a/y94m4j2tv12
|
|
||||||
VGyoxCnT7O2Yb3CkgAAj/PavUpQknGLCzAJhVmqA2jv/yk2m+wqMUP0ue+sIrw0E
|
|
||||||
X4ajZadguDKBZHLjrj5zNe/9iFdwMGluaR7MWUVTJ++M3ltK6Ys=
|
|
||||||
=6cDj
|
|
||||||
-----END PGP SIGNATURE-----
|
|
16
LVM2.2.03.21.tgz.asc
Normal file
16
LVM2.2.03.21.tgz.asc
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
|
||||||
|
iQIzBAABCAAdFiEE1QGkeEQK4v0TChvouREkMeUJA58FAmRCTIYACgkQuREkMeUJ
|
||||||
|
A5/EaRAArFXpfIrbdjMyKWS6X8c+rRyVrYZZbpDos7oXk7KgICFsEAoVoweEgb9Z
|
||||||
|
oZ48ijR15NyERiajI6v97eVsd+fjGNe6u8g0sW2azOY8teqB4vyMNWQ1BpU2J536
|
||||||
|
eXxvvd0PhkG4fqf9mTdktkE/wvjM1BeRmWltDbTSyNCMYrHiMKTd2GmpT/x4QchW
|
||||||
|
K/UCcvqR6Fj+Shb7Z1wyD2RH3JZs4eOaT2VFWx1BOe6sMd+kQBVDqPR9OTyWv+Ss
|
||||||
|
/3uWUYlrlGQ93gbLVOyGnt2B7fiJzcs5wQGlg97QAaXECAv58C0/2B50jzberk/r
|
||||||
|
4mPe8KTIWkPsG2iGec5s1cVJvXTuJzs6zp65QGgWSb0T5TC8s7/FNzJgkWYn3gmk
|
||||||
|
VKvIqjjI+mfdI34124MP1ptfVp1PbQjENTZuwkIpu6tb4fJQfl6QKmaZ42iCLN3z
|
||||||
|
qT+bB+QkvTIObvML/LRUAFOktj+UKHtFgUBNENLtUdqp0ExfYnunfAlTydUDBSlS
|
||||||
|
FEOnPB33kYW74GmBc337iG9V9bo+XPA7paZut6xySTDcy6y5sIbgafrHJSin1kAD
|
||||||
|
AkkAw24WD32Csj9clS3hsb10P3EWnZoi0CnIruoqKQuXc7nf0mDbWXoUSbyYAP4X
|
||||||
|
T70kY59QIybAYVdUNtgR844WxFY8odXd+g2FaIMzghEW9dga59k=
|
||||||
|
=QDd4
|
||||||
|
-----END PGP SIGNATURE-----
|
19
lvm2.spec
19
lvm2.spec
@ -1,4 +1,4 @@
|
|||||||
%global device_mapper_version 1.02.193
|
%global device_mapper_version 1.02.195
|
||||||
|
|
||||||
%global enable_cache 1
|
%global enable_cache 1
|
||||||
%global enable_lvmdbusd 1
|
%global enable_lvmdbusd 1
|
||||||
@ -50,12 +50,11 @@ Name: lvm2
|
|||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
Epoch: %{rhel}
|
Epoch: %{rhel}
|
||||||
%endif
|
%endif
|
||||||
Version: 2.03.20
|
Version: 2.03.21
|
||||||
%if 0%{?from_snapshot}
|
%if 0%{?from_snapshot}
|
||||||
#Release: 0.1.20211115git%{shortcommit}%{?dist}%{?rel_suffix}
|
Release: 0.1.20211115git%{shortcommit}%{?dist}%{?rel_suffix}
|
||||||
Release: 4%{?dist}%{?rel_suffix}
|
|
||||||
%else
|
%else
|
||||||
Release: 2%{?dist}%{?rel_suffix}
|
Release: 1%{?dist}%{?rel_suffix}
|
||||||
%endif
|
%endif
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://sourceware.org/lvm2
|
URL: http://sourceware.org/lvm2
|
||||||
@ -64,10 +63,8 @@ Source0: lvm2-%{shortcommit}.tgz
|
|||||||
%else
|
%else
|
||||||
Source0: ftp://sourceware.org/pub/lvm2/releases/LVM2.%{version}.tgz
|
Source0: ftp://sourceware.org/pub/lvm2/releases/LVM2.%{version}.tgz
|
||||||
%endif
|
%endif
|
||||||
# BZ2184390:
|
# BZ:
|
||||||
Patch1: 0001-Fix-import-of-utils-from-lvmdbusd.cfg.patch
|
#Patch1: 0001-
|
||||||
Patch2: 0002-lvmdbusd-Correct-locking-for-_common_log.patch
|
|
||||||
Patch3: 0003-lvmdbusd-Correct-seg.-fault-on-s390x-ELN.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -695,6 +692,10 @@ An extensive functional testsuite for LVM2.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 21 2023 Marian Csontos <mcsontos@redhat.com> - 2.03.21-1
|
||||||
|
- Update to upstream version 2.03.21.
|
||||||
|
- Allow (write)cache over raid+integrity LV.
|
||||||
|
|
||||||
* Wed Apr 05 2023 Marian Csontos <mcsontos@redhat.com> - 2.03.20-2
|
* Wed Apr 05 2023 Marian Csontos <mcsontos@redhat.com> - 2.03.20-2
|
||||||
- Fix ModuleNotFoundError: No module named 'utils' in lvmdbusd.
|
- Fix ModuleNotFoundError: No module named 'utils' in lvmdbusd.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (LVM2.2.03.20.tgz) = 202ff19f6ab1e1ecdf448beec6c7db1a80885efda1a6eeabf44cd2cea40577405c388eabd86f59f34c6e9e400188050bc6d1a5d5daf02f2beda87eee73cd1a2d
|
SHA512 (LVM2.2.03.21.tgz) = 6024811c3fa92afd2fc13a10d1c3542352aa9a016f40c3ef588bd2f5f3e41245fed4b36c8a87d9f7f8dddc6e13b7253396f5c811f99665df27751676dc7b5bde
|
||||||
|
Loading…
Reference in New Issue
Block a user