New upstream - lots of fixes & some minor new features.
This commit is contained in:
parent
15432968db
commit
0a5158fa3d
@ -1 +1 @@
|
|||||||
LVM2.2.02.56.tgz
|
LVM2.2.02.57.tgz
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
|
||||||
|
|
||||||
iD8DBQBLDC02IoGRwVZ+LBcRAqi0AJ0euCD5qCKYxgJxvorFQU4MBI5fJQCdG5JN
|
|
||||||
NylWB9BXAJjCELCPHYExhCs=
|
|
||||||
=++t8
|
|
||||||
-----END PGP SIGNATURE-----
|
|
7
LVM2.2.02.57.tgz.asc
Normal file
7
LVM2.2.02.57.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||||
|
|
||||||
|
iD8DBQBLTIsBIoGRwVZ+LBcRAgA2AKCwLbEFU/CQJt1yxmwiM8ZAnnEqrwCbBdc5
|
||||||
|
ktzf9UdruVWiPaQmLug8ueA=
|
||||||
|
=t+d5
|
||||||
|
-----END PGP SIGNATURE-----
|
@ -1,100 +0,0 @@
|
|||||||
--- LVM2.2.02.12-old/scripts/lvmconf.sh 2006-09-20 18:36:47.000000000 +0100
|
|
||||||
+++ LVM2.2.02.12/scripts/lvmconf.sh 2006-10-20 19:20:26.000000000 +0100
|
|
||||||
@@ -36,7 +36,7 @@ function parse_args
|
|
||||||
while [ -n "$1" ]; do
|
|
||||||
case $1 in
|
|
||||||
--enable-cluster)
|
|
||||||
- LOCKING_TYPE=2
|
|
||||||
+ LOCKING_TYPE=3
|
|
||||||
shift
|
|
||||||
;;
|
|
||||||
--disable-cluster)
|
|
||||||
@@ -94,15 +94,13 @@ function validate_args
|
|
||||||
|
|
||||||
if [ -n "$LOCKINGLIBDIR" ]; then
|
|
||||||
|
|
||||||
- [ -z "$LOCKINGLIB" ] && LOCKINGLIB="liblvm2clusterlock.so"
|
|
||||||
-
|
|
||||||
if [ "${LOCKINGLIBDIR:0:1}" != "/" ]
|
|
||||||
then
|
|
||||||
echo "Prefix must be an absolute path name (starting with a /)"
|
|
||||||
exit 12
|
|
||||||
fi
|
|
||||||
|
|
||||||
- if [ ! -f "$LOCKINGLIBDIR/$LOCKINGLIB" ]
|
|
||||||
+ if [ -n "$LOCKINGLIB" ] && [ ! -f "$LOCKINGLIBDIR/$LOCKINGLIB" ]
|
|
||||||
then
|
|
||||||
echo "$LOCKINGLIBDIR/$LOCKINGLIB does not exist, did you do a \"make install\" ?"
|
|
||||||
exit 11
|
|
||||||
@@ -170,13 +168,29 @@ then
|
|
||||||
if [ -z "$LOCKING_TYPE" ]; then
|
|
||||||
LOCKING_TYPE=1
|
|
||||||
fi
|
|
||||||
- if [ "$LOCKING_TYPE" = "2" ]; then
|
|
||||||
+ if [ "$LOCKING_TYPE" = "3" ] || [ "$LOCKING_TYPE" = "2" ]; then
|
|
||||||
cat $CONFIGFILE - <<EOF > $TMPFILE
|
|
||||||
global {
|
|
||||||
# Enable locking for cluster LVM
|
|
||||||
locking_type = $LOCKING_TYPE
|
|
||||||
library_dir = "$LOCKINGLIBDIR"
|
|
||||||
+EOF
|
|
||||||
+ if [ $? != 0 ]
|
|
||||||
+ then
|
|
||||||
+ echo "failed to create temporary config file, $CONFIGFILE not updated"
|
|
||||||
+ exit 14
|
|
||||||
+ fi
|
|
||||||
+ if [ -n "$LOCKINGLIB" ]; then
|
|
||||||
+ cat - <<EOF >> $TMPFILE
|
|
||||||
locking_library = "$LOCKINGLIB"
|
|
||||||
+EOF
|
|
||||||
+ if [ $? != 0 ]
|
|
||||||
+ then
|
|
||||||
+ echo "failed to create temporary config file, $CONFIGFILE not updated"
|
|
||||||
+ exit 16
|
|
||||||
+ fi
|
|
||||||
+ fi
|
|
||||||
+ cat - <<EOF >> $TMPFILE
|
|
||||||
}
|
|
||||||
EOF
|
|
||||||
fi # if we aren't setting cluster locking, we don't need to create a global section
|
|
||||||
@@ -184,7 +198,7 @@ EOF
|
|
||||||
if [ $? != 0 ]
|
|
||||||
then
|
|
||||||
echo "failed to create temporary config file, $CONFIGFILE not updated"
|
|
||||||
- exit 14
|
|
||||||
+ exit 17
|
|
||||||
fi
|
|
||||||
else
|
|
||||||
#
|
|
||||||
@@ -208,8 +222,10 @@ else
|
|
||||||
else
|
|
||||||
SEDCMD="${SEDCMD}\n/global[[:blank:]]*{/a\ \ \ \ library_dir = \"$LOCKINGLIBDIR\""
|
|
||||||
fi
|
|
||||||
+ fi
|
|
||||||
|
|
||||||
- if [ "$have_library" = "0" ]
|
|
||||||
+ if [ -n "$LOCKINGLIB" ]; then
|
|
||||||
+ if [ "$have_library" = "0" ]
|
|
||||||
then
|
|
||||||
SEDCMD="${SEDCMD}\ns/^[[:blank:]]*locking_library[[:blank:]]*=.*/\ \ \ \ locking_library = \"$LOCKINGLIB\"/g"
|
|
||||||
else
|
|
||||||
@@ -217,19 +233,6 @@ else
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
- if [ "$LOCKING_TYPE" = "1" ]; then
|
|
||||||
- # if we're not using cluster locking, remove the library dir and locking library name
|
|
||||||
- if [ "$have_dir" = "0" ]
|
|
||||||
- then
|
|
||||||
- SEDCMD="${SEDCMD}\n/^[[:blank:]]*library_dir[[:blank:]]*=.*/d"
|
|
||||||
- fi
|
|
||||||
-
|
|
||||||
- if [ "$have_library" = "0" ]
|
|
||||||
- then
|
|
||||||
- SEDCMD="${SEDCMD}\n/^[[:blank:]]*locking_library[[:blank:]]*=.*/d"
|
|
||||||
- fi
|
|
||||||
- fi
|
|
||||||
-
|
|
||||||
echo -e $SEDCMD > $SCRIPTFILE
|
|
||||||
sed <$CONFIGFILE >$TMPFILE -f $SCRIPTFILE
|
|
||||||
if [ $? != 0 ]
|
|
62
lvm2.spec
62
lvm2.spec
@ -1,4 +1,4 @@
|
|||||||
%define device_mapper_version 1.02.40
|
%define device_mapper_version 1.02.41
|
||||||
%define corosync_version 1.0.0-1
|
%define corosync_version 1.0.0-1
|
||||||
%define openais_version 1.1.0-1
|
%define openais_version 1.1.0-1
|
||||||
%define clusterlib_version 3.0.0-20
|
%define clusterlib_version 3.0.0-20
|
||||||
@ -8,16 +8,13 @@
|
|||||||
|
|
||||||
Summary: Userland logical volume management tools
|
Summary: Userland logical volume management tools
|
||||||
Name: lvm2
|
Name: lvm2
|
||||||
Version: 2.02.56
|
Version: 2.02.57
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://sources.redhat.com/lvm2
|
URL: http://sources.redhat.com/lvm2
|
||||||
Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
||||||
|
|
||||||
# Customise lvmconf.sh for built-in clustered locking in Fedora
|
|
||||||
Patch0: cluster-locking-built-in.patch
|
|
||||||
|
|
||||||
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
@ -46,7 +43,6 @@ or more physical volumes and creating one or more logical volumes
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n LVM2.%{version}
|
%setup -q -n LVM2.%{version}
|
||||||
%patch0 -p1 -b .locking
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%define _exec_prefix /
|
%define _exec_prefix /
|
||||||
@ -396,6 +392,58 @@ the device-mapper event library.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 12 2010 Alasdair Kergon <agk@redhat.com> - 2.02.57-1
|
||||||
|
Add --splitmirrors to lvconvert to split off part of a mirror.
|
||||||
|
Allow vgremove to remove a VG with PVs missing after a prompt.
|
||||||
|
Add activation/udev_rules config option in lvm.conf.
|
||||||
|
Add --poll flag to vgchange and lvchange to control background daemon launch.
|
||||||
|
Impose limit of 8 mirror images to match the in-kernel kcopyd restriction.
|
||||||
|
Log failure type and recognise type 'F' (flush) in dmeventd mirror plugin.
|
||||||
|
Add --noudevrules option for dmsetup to disable /dev node management by udev.
|
||||||
|
Fix 'dmsetup info -c -o all' to show all fields.
|
||||||
|
Fix coredump and memory leak for 'dmsetup help -c'.
|
||||||
|
Rename mirror_device_fault_policy to mirror_image_fault policy.
|
||||||
|
Use extended status of new kernel snapshot target 1.8.0 to detect when empty.
|
||||||
|
Allow use of precommitted metadata when a PV is missing.
|
||||||
|
Add global/abort_on_internal_errors to lvm.conf to assist testing.
|
||||||
|
If aborting due to internal error, always send that message to stderr.
|
||||||
|
Keep log type consistent when changing mirror image count.
|
||||||
|
Exit with success in lvconvert --repair --use-policies on failed allocation.
|
||||||
|
Ensure any background daemon exits without duplicating parent's functionality.
|
||||||
|
Change background daemon process names to "(lvm2)".
|
||||||
|
Fix internal lock state after forking.
|
||||||
|
Remove empty PV devices if lvconvert --repair is using defined policies.
|
||||||
|
Use fixed buffer to prevent stack overflow in persistent filter dump.
|
||||||
|
Propagate metadata commit and revert notifications to other cluster nodes.
|
||||||
|
Fix metadata caching and lock state propagation to remote nodes in clvmd.
|
||||||
|
Properly decode all flags in clvmd messages including VG locks.
|
||||||
|
Drop cached metadata after device was auto-repaired and removed from VG.
|
||||||
|
Clear MISSING_PV flag if PV reappeared and is empty.
|
||||||
|
Fix removal of multiple devices from a mirror.
|
||||||
|
Also clean up PVs flagged as missing in vgreduce --removemissing --force.
|
||||||
|
Fix some pvresize and toollib error paths with missing VG releases/unlocks.
|
||||||
|
Explicitly call suspend for temporary mirror layer.
|
||||||
|
Add memlock information to do_lock_lv debug output.
|
||||||
|
Always bypass calls to remote cluster nodes for non-clustered VGs.
|
||||||
|
Permit implicit cluster lock conversion in pre/post callbacks on local node.
|
||||||
|
Permit implicit cluster lock conversion to the lock mode already held.
|
||||||
|
Fix lock flag masking in clvmd so intended code paths get invoked.
|
||||||
|
Remove newly-created mirror log from metadata if initial deactivation fails.
|
||||||
|
Improve pvmove error message when all source LVs are skipped.
|
||||||
|
Fix memlock imbalance in lv_suspend if already suspended.
|
||||||
|
Fix pvmove test mode not to poll (and fail).
|
||||||
|
Fix vgcreate error message if VG already exists.
|
||||||
|
Fix tools to use log_error when aborted due to user response to prompt.
|
||||||
|
Fix ignored readahead setting in lvcreate --readahead.
|
||||||
|
Fix clvmd memory leak in lv_info_by_lvid by calling release_vg.
|
||||||
|
If LVM_UDEV_DISABLE_CHECKING is set in environment, disable udev warnings.
|
||||||
|
If DM_UDEV_DISABLE_CHECKING is set in environment, disable udev warnings.
|
||||||
|
Always set environment variables for an LVM2 device in 11-dm-lvm.rules.
|
||||||
|
Disable udev rules for change events with DISK_RO set.
|
||||||
|
Add dm_tree_add_dev_with_udev_flags to provide wider support for udev flags.
|
||||||
|
Correct activated or deactivated text in vgchange summary message.
|
||||||
|
Fix fsadm man page typo (fsdam).
|
||||||
|
|
||||||
* Tue Nov 24 2009 Alasdair Kergon <agk@redhat.com> - 2.02.56-2
|
* Tue Nov 24 2009 Alasdair Kergon <agk@redhat.com> - 2.02.56-2
|
||||||
- Revert vg_read_internal change as clvmd was not ready for vg_read. (2.02.55)
|
- Revert vg_read_internal change as clvmd was not ready for vg_read. (2.02.55)
|
||||||
- Fix unbalanced memory locking when deactivating LVs.
|
- Fix unbalanced memory locking when deactivating LVs.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
0326c0c7fd53c2043dcedec169c59a4c LVM2.2.02.56.tgz
|
27292a8a550b85f4f620d67948bbf507 LVM2.2.02.57.tgz
|
||||||
|
Loading…
Reference in New Issue
Block a user