New upstream release v2.02.177
This commit is contained in:
parent
e18384b357
commit
0948a0736a
1
.gitignore
vendored
1
.gitignore
vendored
@ -79,3 +79,4 @@
|
|||||||
/LVM2.2.02.174.tgz
|
/LVM2.2.02.174.tgz
|
||||||
/LVM2.2.02.175.tgz
|
/LVM2.2.02.175.tgz
|
||||||
/LVM2.2.02.176.tgz
|
/LVM2.2.02.176.tgz
|
||||||
|
/LVM2.2.02.177.tgz
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v2.0.14 (GNU/Linux)
|
|
||||||
|
|
||||||
iEYEABECAAYFAln78m4ACgkQIoGRwVZ+LBd7JgCgrSwgbcu9Q3DcMlgQ6cKWuw7A
|
|
||||||
OJUAn2ZLtu42YBXsqlxSbfS4/KTWBroE
|
|
||||||
=iUwm
|
|
||||||
-----END PGP SIGNATURE-----
|
|
7
LVM2.2.02.177.tgz.asc
Normal file
7
LVM2.2.02.177.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v2.0.14 (GNU/Linux)
|
||||||
|
|
||||||
|
iEYEABECAAYFAlo4KccACgkQIoGRwVZ+LBcdSgCg3Dgs6+ItNryJV9GvCCDguOoj
|
||||||
|
gGQAoIfvtmvZc5eif/P941hGELtZQFZ6
|
||||||
|
=0j1r
|
||||||
|
-----END PGP SIGNATURE-----
|
13
lvm2-2_02_178-lvmlockd-fix-uninitialized.patch
Normal file
13
lvm2-2_02_178-lvmlockd-fix-uninitialized.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/lib/locking/lvmlockd.c b/lib/locking/lvmlockd.c
|
||||||
|
index 0365797..a4684b4 100644
|
||||||
|
--- a/lib/locking/lvmlockd.c
|
||||||
|
+++ b/lib/locking/lvmlockd.c
|
||||||
|
@@ -2148,7 +2148,7 @@ int lockd_lv_name(struct cmd_context *cmd, struct volume_group *vg,
|
||||||
|
static int _lockd_lv_thin(struct cmd_context *cmd, struct logical_volume *lv,
|
||||||
|
const char *def_mode, uint32_t flags)
|
||||||
|
{
|
||||||
|
- struct logical_volume *pool_lv;
|
||||||
|
+ struct logical_volume *pool_lv = NULL;
|
||||||
|
|
||||||
|
if (lv_is_thin_volume(lv)) {
|
||||||
|
struct lv_segment *pool_seg = first_seg(lv);
|
64
lvm2.spec
64
lvm2.spec
@ -1,4 +1,4 @@
|
|||||||
%global device_mapper_version 1.02.145
|
%global device_mapper_version 1.02.146
|
||||||
|
|
||||||
%global enable_cache 1
|
%global enable_cache 1
|
||||||
%global enable_cluster 1
|
%global enable_cluster 1
|
||||||
@ -60,14 +60,16 @@ Name: lvm2
|
|||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
Epoch: %{rhel}
|
Epoch: %{rhel}
|
||||||
%endif
|
%endif
|
||||||
Version: 2.02.176
|
Version: 2.02.177
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://sources.redhat.com/lvm2
|
URL: http://sourceware.org/lvm2
|
||||||
Source0: ftp://sources.redhat.com/pub/lvm2/releases/LVM2.%{version}.tgz
|
Source0: ftp://sourceware.org/pub/lvm2/releases/LVM2.%{version}.tgz
|
||||||
Patch0: lvm2-set-default-preferred_names.patch
|
Patch0: lvm2-set-default-preferred_names.patch
|
||||||
Patch1: lvm2-lvmetad-timeout.patch
|
Patch1: lvm2-lvmetad-timeout.patch
|
||||||
|
# Upstream: 3f9ae846b89a
|
||||||
|
Patch2: lvm2-2_02_178-lvmlockd-fix-uninitialized.patch
|
||||||
|
|
||||||
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
||||||
BuildRequires: libblkid-devel >= %{util_linux_version}
|
BuildRequires: libblkid-devel >= %{util_linux_version}
|
||||||
@ -123,6 +125,7 @@ or more physical volumes and creating one or more logical volumes
|
|||||||
%setup -q -n LVM2.%{version}
|
%setup -q -n LVM2.%{version}
|
||||||
%patch0 -p1 -b .preferred_names
|
%patch0 -p1 -b .preferred_names
|
||||||
%patch1 -p1 -b .lvmetad_timeout
|
%patch1 -p1 -b .lvmetad_timeout
|
||||||
|
%patch2 -p1 -b .lvmlockd_uninitialized
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%global _default_pid_dir /run
|
%global _default_pid_dir /run
|
||||||
@ -890,6 +893,57 @@ An extensive functional testsuite for LVM2.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 19 2017 Marian Csontos <mcsontos@redhat.com> - 2.02.177-1
|
||||||
|
- When writing text metadata content, use complete 4096 byte blocks.
|
||||||
|
- Change text format metadata alignment from 512 to 4096 bytes.
|
||||||
|
- When writing metadata, consistently skip mdas marked as failed.
|
||||||
|
- Refactor and adjust text format metadata alignment calculation.
|
||||||
|
- Fix python3 path in lvmdbusd to use value detected by configure.
|
||||||
|
- Reduce checks for active LVs in vgchange before background polling.
|
||||||
|
- Ensure _node_send_message always uses clean status of thin pool.
|
||||||
|
- Fix lvmlockd to use pool lock when accessing _tmeta volume.
|
||||||
|
- Report expected sanlock_convert errors only when retries fail.
|
||||||
|
- Avoid blocking in sanlock_convert on SH to EX lock conversion.
|
||||||
|
- Deactivate missing raid LV legs (_rimage_X-missing_Y_Z) on decativation.
|
||||||
|
- Skip read-modify-write when entire block is replaced.
|
||||||
|
- Categorise I/O with reason annotations in debug messages.
|
||||||
|
- Allow extending of raid LVs created with --nosync after a failed repair.
|
||||||
|
- Command will lock memory only when suspending volumes.
|
||||||
|
- Merge segments when pvmove is finished.
|
||||||
|
- Remove label_verify that has never been used.
|
||||||
|
- Ensure very large numbers used as arguments are not casted to lower values.
|
||||||
|
- Enhance reading and validation of options stripes and stripes_size.
|
||||||
|
- Fix printing of default stripe size when user is not using stripes.
|
||||||
|
- Activation code for pvmove automatically discovers holding LVs for resume.
|
||||||
|
- Make a pvmove LV locking holder.
|
||||||
|
- Do not change critical section counter on resume path without real resume.
|
||||||
|
- Enhance activation code to automatically suspend pvmove participants.
|
||||||
|
- Prevent conversion of thin volumes to snapshot origin when lvmlockd is used.
|
||||||
|
- Correct the steps to change lock type in lvmlockd man page.
|
||||||
|
- Retry lock acquisition on recognized sanlock errors.
|
||||||
|
- Fix lock manager error codes in lvmlockd.
|
||||||
|
- Remove unnecessary single read from lvmdiskscan.
|
||||||
|
- Check raid reshape flags in vg_validate().
|
||||||
|
- Add support for pvmove of cache and snapshot origins.
|
||||||
|
- Avoid using precommitted metadata for suspending pvmove tree.
|
||||||
|
- Ehnance pvmove locking.
|
||||||
|
- Deactivate activated LVs on error path when pvmove activation fails.
|
||||||
|
- Add "io" to log/debug_classes for logging low-level I/O.
|
||||||
|
- Avoid importing persistent filter in vgscan/pvscan/vgrename.
|
||||||
|
- Fix memleak of string buffer when vgcfgbackup runs in secure mode.
|
||||||
|
- Do not print error when clvmd cannot find running clvmd.
|
||||||
|
- Prevent start of new merge of snapshot if origin is already being merged.
|
||||||
|
- Fix offered type for raid6_n_6 to raid5 conversion (raid5_n).
|
||||||
|
- Deactivate sub LVs when removing unused cache-pool.
|
||||||
|
- Do not take backup with suspended devices.
|
||||||
|
- Avoid RAID4 activation on incompatible kernels under all circumstances.
|
||||||
|
- Reject conversion request to striped/raid0 on 2-legged raid4/5.
|
||||||
|
- Activation tree of thin pool skips duplicated check of pool status.
|
||||||
|
- Remove code supporting replicator target.
|
||||||
|
- Do not ignore failure of _info_by_dev().
|
||||||
|
- Propagate delayed resume for pvmove subvolumes.
|
||||||
|
- Suppress integrity encryption keys in 'table' output unless --showkeys supplied.
|
||||||
|
|
||||||
* Thu Dec 14 2017 Marian Csontos <mcsontos@redhat.com> - 2.02.176-2
|
* Thu Dec 14 2017 Marian Csontos <mcsontos@redhat.com> - 2.02.176-2
|
||||||
- Add testsuite subpackage.
|
- Add testsuite subpackage.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (LVM2.2.02.176.tgz) = eee0b1cc356f0c5ff5dba8efe81af5f0ad446649dc237458bb63419483899becc4fe6912592555f84cf9cb8f9cbdec341d2047db5943ca9a3da5f0af60b70759
|
SHA512 (LVM2.2.02.177.tgz) = e287aeae3ce5ce0efcdebce90f24c2f659cd8691839e3f3cb902848535259ae510ec48f5355481b99f7285d9cff01883e6ef2b101072bdf9c99fba8e9cb54ded
|
||||||
|
Loading…
Reference in New Issue
Block a user