New upstream with fixes and new udev code (not yet switched on).
This commit is contained in:
parent
7047a17d4f
commit
074e0349bd
@ -1 +1 @@
|
||||
LVM2.2.02.51.tgz
|
||||
LVM2.2.02.52.tgz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBKeyTEIoGRwVZ+LBcRAp3SAKDV9fwpAL4SNOs0VmtZ4v9FBJUHhQCeKY1n
|
||||
5PeRAqJFAyLmL9asVl61/Uk=
|
||||
=jnKk
|
||||
-----END PGP SIGNATURE-----
|
7
LVM2.2.02.52.tgz.asc
Normal file
7
LVM2.2.02.52.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBKr5wNIoGRwVZ+LBcRAiGiAKD5qxF5j/XVemM+mLiKed3J48BOrwCfUzEh
|
||||
RZTZYuW+YYd6o+HzY/3GqH0=
|
||||
=cddF
|
||||
-----END PGP SIGNATURE-----
|
@ -1,76 +0,0 @@
|
||||
--- LVM2.2.02.51.old/lib/device/dev-md.c 2009-08-01 19:14:52.000000000 +0200
|
||||
+++ LVM2.2.02.51/lib/device/dev-md.c 2009-08-24 14:13:39.000000000 +0200
|
||||
@@ -137,13 +137,15 @@ static int _md_sysfs_attribute_snprintf(
|
||||
if (!sysfs_dir || !*sysfs_dir)
|
||||
return ret;
|
||||
|
||||
-check_md_major:
|
||||
- if (MAJOR(dev) != md_major()) {
|
||||
- if (get_primary_dev(sysfs_dir, blkdev, &dev))
|
||||
- goto check_md_major;
|
||||
- return ret;
|
||||
+ if (MAJOR(dev) == blkext_major()) {
|
||||
+ /* lookup parent MD device from blkext partition */
|
||||
+ if (!get_primary_dev(sysfs_dir, blkdev, &dev))
|
||||
+ return ret;
|
||||
}
|
||||
|
||||
+ if (MAJOR(dev) != md_major())
|
||||
+ return ret;
|
||||
+
|
||||
ret = dm_snprintf(path, size, "%s/dev/block/%d:%d/md/%s", sysfs_dir,
|
||||
(int)MAJOR(dev), (int)MINOR(dev), attribute);
|
||||
if (ret < 0) {
|
||||
--- LVM2.2.02.51.old/lib/filters/filter.c 2009-07-10 00:34:02.000000000 +0200
|
||||
+++ LVM2.2.02.51/lib/filters/filter.c 2009-08-24 14:13:39.000000000 +0200
|
||||
@@ -38,6 +38,7 @@ typedef struct {
|
||||
} device_info_t;
|
||||
|
||||
static int _md_major = -1;
|
||||
+static int _blkext_major = -1;
|
||||
static int _device_mapper_major = -1;
|
||||
|
||||
int md_major(void)
|
||||
@@ -45,6 +46,11 @@ int md_major(void)
|
||||
return _md_major;
|
||||
}
|
||||
|
||||
+int blkext_major(void)
|
||||
+{
|
||||
+ return _blkext_major;
|
||||
+}
|
||||
+
|
||||
/*
|
||||
* Devices are only checked for partition tables if their minor number
|
||||
* is a multiple of the number corresponding to their type below
|
||||
@@ -197,6 +203,10 @@ static int _scan_proc_dev(const char *pr
|
||||
if (!strncmp("md", line + i, 2) && isspace(*(line + i + 2)))
|
||||
_md_major = line_maj;
|
||||
|
||||
+ /* Look for blkext device */
|
||||
+ if (!strncmp("blkext", line + i, 6) && isspace(*(line + i + 6)))
|
||||
+ _blkext_major = line_maj;
|
||||
+
|
||||
/* Look for device-mapper device */
|
||||
/* FIXME Cope with multiple majors */
|
||||
if (!strncmp("device-mapper", line + i, 13) && isspace(*(line + i + 13)))
|
||||
--- LVM2.2.02.51.old/lib/filters/filter.h 2007-08-20 22:55:25.000000000 +0200
|
||||
+++ LVM2.2.02.51/lib/filters/filter.h 2009-08-24 14:13:39.000000000 +0200
|
||||
@@ -36,6 +36,7 @@ struct dev_filter *lvm_type_filter_creat
|
||||
void lvm_type_filter_destroy(struct dev_filter *f);
|
||||
|
||||
int md_major(void);
|
||||
+int blkext_major(void);
|
||||
int max_partitions(int major);
|
||||
|
||||
#endif
|
||||
--- LVM2.2.02.51.old/WHATS_NEW 2009-08-06 19:08:01.000000000 +0200
|
||||
+++ LVM2.2.02.51/WHATS_NEW 2009-08-24 14:14:06.000000000 +0200
|
||||
@@ -1,3 +1,7 @@
|
||||
+Version 2.02.52 -
|
||||
+=================================
|
||||
+ Fix pvcreate on a partition (2.02.51).
|
||||
+
|
||||
Version 2.02.51 - 6th August 2009
|
||||
=================================
|
||||
Fix locking in clvmd (2.02.50).
|
@ -1,20 +0,0 @@
|
||||
--- LVM2.2.02.51.old/tools/toollib.c 2009-07-21 13:10:49.000000000 +0200
|
||||
+++ LVM2.2.02.51/tools/toollib.c 2009-08-24 14:15:08.000000000 +0200
|
||||
@@ -643,7 +643,7 @@ int process_each_pv(struct cmd_context *
|
||||
|
||||
dm_list_init(&tags);
|
||||
|
||||
- if (lock_global && !lock_vol(cmd, VG_GLOBAL, LCK_READ)) {
|
||||
+ if (lock_global && !lock_vol(cmd, VG_GLOBAL, LCK_VG_READ)) {
|
||||
log_error("Unable to obtain global lock.");
|
||||
return ECMD_FAILED;
|
||||
}
|
||||
--- LVM2.2.02.51.old/WHATS_NEW 2009-08-24 14:14:58.000000000 +0200
|
||||
+++ LVM2.2.02.51/WHATS_NEW 2009-08-24 14:15:25.000000000 +0200
|
||||
@@ -1,5 +1,6 @@
|
||||
Version 2.02.52 -
|
||||
=================================
|
||||
+ Fix global locking in PV reporting commands (2.02.49).
|
||||
Fix pvcreate on a partition (2.02.51).
|
||||
|
||||
Version 2.02.51 - 6th August 2009
|
27
lvm2.spec
27
lvm2.spec
@ -1,4 +1,4 @@
|
||||
%define device_mapper_version 1.02.36
|
||||
%define device_mapper_version 1.02.37
|
||||
%define corosync_version 1.0.0-1
|
||||
%define clusterlib_version 3.0.0-20
|
||||
|
||||
@ -7,8 +7,8 @@
|
||||
|
||||
Summary: Userland logical volume management tools
|
||||
Name: lvm2
|
||||
Version: 2.02.51
|
||||
Release: 3%{?dist}
|
||||
Version: 2.02.52
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://sources.redhat.com/lvm2
|
||||
@ -16,8 +16,6 @@ Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
||||
|
||||
# Customise lvmconf.sh for built-in clustered locking in Fedora
|
||||
Patch0: cluster-locking-built-in.patch
|
||||
Patch1: lvm2-2_02_52-fix-pvcreate-partition.patch
|
||||
Patch2: lvm2-2_02_52-fix-pvs-global-lock.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
||||
@ -43,8 +41,6 @@ or more physical volumes and creating one or more logical volumes
|
||||
%prep
|
||||
%setup -q -n LVM2.%{version}
|
||||
%patch0 -p1 -b .locking
|
||||
%patch1 -p1 -b .partition
|
||||
%patch2 -p1 -b .globallock
|
||||
|
||||
%build
|
||||
%define _exec_prefix /
|
||||
@ -310,6 +306,23 @@ This package contains the device-mapper shared library, libdevmapper.
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Sep 15 2009 Alasdair Kergon <agk@redhat.com> - 2.02.52-1
|
||||
- Prioritise write locks over read locks by default for file locking.
|
||||
- Add local lock files with suffix ':aux' to serialise locking requests.
|
||||
- Fix readonly locking to permit writeable global locks (for vgscan). (2.02.49)
|
||||
- Make readonly locking available as locking type 4.
|
||||
- Fix global locking in PV reporting commands (2.02.49).
|
||||
- Make lvchange --refresh only take a read lock on volume group.
|
||||
- Fix race where non-blocking file locks could be granted in error.
|
||||
- Fix pvcreate string termination in duplicate uuid warning message.
|
||||
- Don't loop reading sysfs with pvcreate on a non-blkext partition (2.02.51).
|
||||
- Fix vgcfgrestore error paths when locking fails (2.02.49).
|
||||
- Make clvmd check corosync to see what cluster interface it should use.
|
||||
- Fix vgextend error path - if ORPHAN lock fails, unlock / release vg (2.02.49).
|
||||
- Clarify use of PE ranges in lv{convert|create|extend|resize} man pages.
|
||||
- Restore umask when device node creation fails.
|
||||
- Check kernel vsn to use 'block_on_error' or 'handle_errors' in mirror table.
|
||||
|
||||
* Mon Aug 24 2009 Milan Broz <mbroz@redhat.com> - 2.02.51-3
|
||||
- Fix global locking in PV reporting commands (2.02.49).
|
||||
- Fix pvcreate on a partition (2.02.51).
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
725d07794007e021bfc592b1636100c7 LVM2.2.02.51.tgz
|
||||
e92f83deb74b5b82439b63faf63128f3 LVM2.2.02.52.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user