New upstream with important snapshot+pvmove fixes.
This commit is contained in:
parent
f59f655d10
commit
0727836ebe
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ LVM2.2.02.73.tgz
|
||||
/LVM2.2.02.82.tgz
|
||||
/LVM2.2.02.83.tgz
|
||||
/LVM2.2.02.84.tgz
|
||||
/LVM2.2.02.86.tgz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBNUoPBIoGRwVZ+LBcRArV5AJsEBiOr2+l+t75sCQFHjeI1qMz8yQCgnNWV
|
||||
KenZpjzUKHsOQRcXNIWDz4o=
|
||||
=OTJ3
|
||||
-----END PGP SIGNATURE-----
|
7
LVM2.2.02.86.tgz.asc
Normal file
7
LVM2.2.02.86.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.2.1 (GNU/Linux)
|
||||
|
||||
iD8DBQBOF2CSIoGRwVZ+LBcRAgPPAJ9j86CkFVmMQCgmqk/uSvPZ3setVACgtTWI
|
||||
5xp0pXLF6lsI+IQquIz1CWk=
|
||||
=rB0U
|
||||
-----END PGP SIGNATURE-----
|
@ -1,77 +0,0 @@
|
||||
--- LVM2.2.02.84.old/libdm/ioctl/libdm-iface.c 2011-02-04 22:26:33.000000000 +0100
|
||||
+++ LVM2.2.02.84/libdm/ioctl/libdm-iface.c 2011-06-21 13:24:14.261923553 +0200
|
||||
@@ -73,9 +73,9 @@ static unsigned _dm_version_minor = 0;
|
||||
static unsigned _dm_version_patchlevel = 0;
|
||||
static int _log_suppress = 0;
|
||||
|
||||
-static int _kernel_major;
|
||||
-static int _kernel_minor;
|
||||
-static int _kernel_release;
|
||||
+static int _kernel_major = 0;
|
||||
+static int _kernel_minor = 0;
|
||||
+static int _kernel_release = 0;
|
||||
|
||||
/*
|
||||
* If the kernel dm driver only supports one major number
|
||||
@@ -152,6 +152,7 @@ static int _uname(void)
|
||||
{
|
||||
static int _uts_set = 0;
|
||||
struct utsname _uts;
|
||||
+ int parts;
|
||||
|
||||
if (_uts_set)
|
||||
return 1;
|
||||
@@ -160,10 +161,14 @@ static int _uname(void)
|
||||
log_error("uname failed: %s", strerror(errno));
|
||||
return 0;
|
||||
}
|
||||
- if (sscanf(_uts.release, "%d.%d.%d",
|
||||
+
|
||||
+ parts = sscanf(_uts.release, "%d.%d.%d",
|
||||
&_kernel_major,
|
||||
&_kernel_minor,
|
||||
- &_kernel_release) != 3) {
|
||||
+ &_kernel_release);
|
||||
+
|
||||
+ /* Kernels with a major number of 2 always had 3 parts. */
|
||||
+ if (parts < 1 || (_kernel_major < 3 && parts < 3)) {
|
||||
log_error("Could not determine kernel version used.");
|
||||
return 0;
|
||||
}
|
||||
--- LVM2.2.02.84.old/libdm/libdm-deptree.c 2010-11-29 13:42:10.000000000 +0100
|
||||
+++ LVM2.2.02.84/libdm/libdm-deptree.c 2011-06-21 13:25:11.062393944 +0200
|
||||
@@ -1541,13 +1541,20 @@ static int _mirror_emit_segment_line(str
|
||||
int dm_log_userspace = 0;
|
||||
struct utsname uts;
|
||||
unsigned log_parm_count;
|
||||
- int pos = 0;
|
||||
+ int pos = 0, parts;
|
||||
char logbuf[DM_FORMAT_DEV_BUFSIZE];
|
||||
const char *logtype;
|
||||
- unsigned kmaj, kmin, krel;
|
||||
+ unsigned kmaj = 0, kmin = 0, krel = 0;
|
||||
|
||||
- if (uname(&uts) == -1 || sscanf(uts.release, "%u.%u.%u", &kmaj, &kmin, &krel) != 3) {
|
||||
- log_error("Cannot read kernel release version");
|
||||
+ if (uname(&uts) == -1) {
|
||||
+ log_error("Cannot read kernel release version.");
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
+ /* Kernels with a major number of 2 always had 3 parts. */
|
||||
+ parts = sscanf(uts.release, "%u.%u.%u", &kmaj, &kmin, &krel);
|
||||
+ if (parts < 1 || (kmaj < 3 && parts < 3)) {
|
||||
+ log_error("Wrong kernel release version %s.", uts.release);
|
||||
return 0;
|
||||
}
|
||||
|
||||
--- LVM2.2.02.84.old/WHATS_NEW_DM 2011-02-09 13:04:39.000000000 +0100
|
||||
+++ LVM2.2.02.84/WHATS_NEW_DM 2011-06-21 13:24:58.862292506 +0200
|
||||
@@ -1,3 +1,7 @@
|
||||
+Version 1.02.65 -
|
||||
+==================================
|
||||
+ Accept new kernel version 3 formats in initialisation.
|
||||
+
|
||||
Version 1.02.63 - 9th February 2011
|
||||
===================================
|
||||
Reinstate DEBUG_MEM as it's part of the API. (1.02.62)
|
43
lvm2.spec
43
lvm2.spec
@ -1,4 +1,4 @@
|
||||
%define device_mapper_version 1.02.63
|
||||
%define device_mapper_version 1.02.65
|
||||
%define enable_cluster 1
|
||||
|
||||
%if "%{fedora}" == "12"
|
||||
@ -38,8 +38,8 @@
|
||||
|
||||
Summary: Userland logical volume management tools
|
||||
Name: lvm2
|
||||
Version: 2.02.84
|
||||
Release: 3%{?dist}
|
||||
Version: 2.02.86
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://sources.redhat.com/lvm2
|
||||
@ -48,7 +48,6 @@ Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
|
||||
Source1: %{name}-tmpfiles.conf
|
||||
%endif
|
||||
Patch0: lvm2-set-default-preferred_names.patch
|
||||
Patch1: lvm2-uname.patch
|
||||
|
||||
BuildRequires: libselinux-devel >= 1.30.19-4, libsepol-devel
|
||||
BuildRequires: ncurses-devel
|
||||
@ -82,7 +81,6 @@ or more physical volumes and creating one or more logical volumes
|
||||
%prep
|
||||
%setup -q -n LVM2.%{version}
|
||||
%patch0 -p1 -b preferred_names
|
||||
%patch1 -p1 -b .uname
|
||||
|
||||
%build
|
||||
%define _exec_prefix ""
|
||||
@ -494,6 +492,41 @@ the device-mapper event library.
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jul 8 2011 Alasdair Kergon <agk@redhat.com> - 2.02.86-1
|
||||
- Fix activation sequences to avoid trapped I/O with multiple LVs.
|
||||
- Fix activation sequences to avoid allocating tables while devs suspended.
|
||||
- Remove unnecessary warning in pvcreate for MD linear devices.
|
||||
- Add activation/checks to lvm.conf to perform additional ioctl validation.
|
||||
- Append 'm' attribute to pv_attr for missing PVs.
|
||||
- Fix to preserve exclusive activation of mirror while up-converting.
|
||||
- Reject allocation if number of extents is not divisible by area count.
|
||||
- Fix cluster mirror creation to work with new mirror allocation algorithm.
|
||||
- Ignore activation/verify_udev_operations if dm kernel driver vsn < 4.18.
|
||||
- Add activation/verify_udev_operations to lvm.conf, disabled by default.
|
||||
- Ignore inconsistent pre-commit metadata on MISSING_PV devs while activating.
|
||||
- Add proper udev library context initialization and finalization to liblvm.
|
||||
- Downgrade critical_section errors to debug level until it is moved to libdm.
|
||||
- Fix ignored background polling default in vgchange -ay.
|
||||
- Fix reduction of mirrors with striped segments to always align to stripe size.
|
||||
- Validate mirror segments size.
|
||||
- Fix extent rounding for striped volumes never to reduce more than requested.
|
||||
- Fix create_temp_name to replace any '/' found in the hostname with '?'.
|
||||
- Always use append to file in lvmdump. selinux policy may ban file truncation.
|
||||
- Propagate test mode to clvmd to skip activation and changes to held locks.
|
||||
- Permit --available with lvcreate so non-snapshot LVs need not be activated.
|
||||
- Clarify error message when unable to convert an LV into a snapshot of an LV.
|
||||
- Do not issue an error message when unable to remove .cache on read-only fs.
|
||||
- Avoid memlock size mismatch by preallocating stdio line buffers.
|
||||
- Report internal error if suspending a device using an already-suspended dev.
|
||||
- Report internal error if any table is loaded while any dev is known suspended.
|
||||
- Report error if a table load requiring target parameters has none supplied.
|
||||
- Add dmsetup --checks and dm_task_enable_checks framework to validate ioctls.
|
||||
- Add age_in_minutes parameter to dmsetup udevcomplete_all.
|
||||
- Disable udev fallback by default and add --verifyudev option to dmsetup.
|
||||
- Add dm_get_suspended_counter() for number of devs in suspended state by lib.
|
||||
- Fix "all" report field prefix matching to include label fields with pv_all.
|
||||
- Delay resuming new preloaded mirror devices with core logs in deptree code.
|
||||
|
||||
* Wed Jun 22 2011 Zdenek Kabelac <zkabelac@redhat.com> - 2.02.84-3
|
||||
- Updated uname string test.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
8b4e0897ee48f02c0dff11940e44e23b LVM2.2.02.84.tgz
|
||||
3b42dec4d15ad106302a35149082a20e LVM2.2.02.86.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user