auto-import changelog data from lockdev-1.0.0-19.src.rpm
Wed Jun 05 2002 Jeff Johnson <jbj@redhat.com> 1.0.0-19 - fix: don't ignore signals, use default behavior instead (#63468). Thu May 23 2002 Tim Powers <timp@redhat.com> - automated rebuild
This commit is contained in:
parent
714ed7c48a
commit
de2898b600
41
lockdev-1.0.0-signal.patch
Normal file
41
lockdev-1.0.0-signal.patch
Normal file
@ -0,0 +1,41 @@
|
||||
--- lockdev-1.0.0/src/baudboy.h Sat Apr 20 15:42:16 2002
|
||||
+++ lockdev-1.0.0-/src/baudboy.h Sat Apr 20 15:41:49 2002
|
||||
@@ -34,11 +34,11 @@
|
||||
|
||||
#define LOCKDEV_PATH "/usr/sbin/lockdev"
|
||||
|
||||
-static inline int doit(const char * argv[])
|
||||
+static inline int _doit(const char * argv[])
|
||||
{
|
||||
pid_t child;
|
||||
int status;
|
||||
- void (*osig) (int) = signal(SIGCHLD, SIG_IGN);
|
||||
+ void (*osig) (int) = signal(SIGCHLD, SIG_DFL);
|
||||
int rc;
|
||||
|
||||
if (!(child = fork())) {
|
||||
@@ -104,21 +104,21 @@
|
||||
{
|
||||
const char * argv[] = { LOCKDEV_PATH, "-l", NULL, NULL};
|
||||
argv[2] = devname;
|
||||
- return doit(argv);
|
||||
+ return _doit(argv);
|
||||
}
|
||||
|
||||
static inline int ttyunlock(const char * devname)
|
||||
{
|
||||
const char * argv[] = { LOCKDEV_PATH, "-u", NULL, NULL};
|
||||
argv[2] = devname;
|
||||
- return doit(argv);
|
||||
+ return _doit(argv);
|
||||
}
|
||||
|
||||
static inline int ttylocked(const char * devname)
|
||||
{
|
||||
const char * argv[] = { LOCKDEV_PATH, NULL, NULL};
|
||||
argv[1] = devname;
|
||||
- return doit(argv);
|
||||
+ return _doit(argv);
|
||||
}
|
||||
|
||||
static inline int ttywait(const char * devname)
|
18
lockdev.spec
18
lockdev.spec
@ -1,12 +1,13 @@
|
||||
Summary: A library for locking devices.
|
||||
Name: lockdev
|
||||
Version: 1.0.0
|
||||
Release: 16
|
||||
Release: 19
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
Source: ftp://ftp.debian.org/debian/dists/woody/main/source/libs/lockdev_1.0.0.tar.gz
|
||||
Patch0: lockdev-1.0.0-rh.patch
|
||||
Patch1: lockdev-1.0.0-shared.patch
|
||||
Patch2: lockdev-1.0.0-signal.patch
|
||||
Prereq: shadow-utils, filesystem >= 2.1.4-1
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
|
||||
@ -19,7 +20,7 @@ Summary: The header files and a static library for the lockdev library.
|
||||
Group: System Environment/Libraries
|
||||
Requires: lockdev = %{version}-%{release}
|
||||
|
||||
%description -n lockdev-devel
|
||||
%description devel
|
||||
The lockdev library provides a reliable way to put an exclusive lock
|
||||
on devices using both FSSTND and SVr4 methods. The lockdev-devel
|
||||
package contains the development headers and a static library.
|
||||
@ -28,6 +29,7 @@ package contains the development headers and a static library.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .redhat
|
||||
%patch1 -p1 -b .shared
|
||||
%patch2 -p1 -b .signal
|
||||
|
||||
%build
|
||||
make "CFLAGS=${RPM_OPT_FLAGS} -fPIC"
|
||||
@ -66,10 +68,22 @@ rm -fr $RPM_BUILD_ROOT
|
||||
%{_includedir}/*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 5 2002 Jeff Johnson <jbj@redhat.com> 1.0.0-19
|
||||
- fix: don't ignore signals, use default behavior instead (#63468).
|
||||
|
||||
* Thu May 23 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.0-16
|
||||
- include liblockdev.so so that programs can link to a shared liblockdev
|
||||
- fix shared library version numbers
|
||||
|
||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Thu Nov 29 2001 Trond Eivind Glomsrød <teg@redhat.com> 1.0.0-16
|
||||
- Rebuilt
|
||||
|
||||
* Fri Oct 26 2001 Trond Eivind Glomsrød <teg@redhat.com> 1.0.0-15
|
||||
- Add copyright/license info to baudboy.h (#54321)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user