auto-import changelog data from lockdev-1.0.0-16.src.rpm

Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.0-16
- include liblockdev.so so that programs can link to a shared liblockdev
- fix shared library version numbers
This commit is contained in:
cvsdist 2004-09-09 07:59:07 +00:00
parent 92a8dd8141
commit 714ed7c48a
2 changed files with 31 additions and 5 deletions

View File

@ -0,0 +1,19 @@
--- lockdev-1.0.0/Makefile Mon Feb 25 15:36:06 2002
+++ lockdev-1.0.0/Makefile Mon Feb 25 15:36:02 2002
@@ -13,7 +13,7 @@
MVER = ${shell expr `pwd` : '.*-\([0-9]*\).[0-9]*'}
static = ${libname}.a
-shared = ${libname}.${VER}.so
+shared = ${libname}.so.${VER}
soname = ${libname}.so.${MVER}
# overwritten by caller (e.g.: debian/rules)
@@ -78,6 +78,7 @@
install_run: ${shared}
install -m755 -d ${libdir}
install -m755 ${shared} ${libdir}
+ ln -s ${shared} ${libdir}/liblockdev.so
install -m755 -d ${sbindir}
install -m755 lockdev ${sbindir}

View File

@ -1,11 +1,12 @@
Summary: A library for locking devices.
Name: lockdev
Version: 1.0.0
Release: 15
Release: 16
License: LGPL
Group: System Environment/Libraries
Source: ftp://ftp.debian.org/debian/dists/woody/main/source/libs/lockdev_1.0.0.tar.gz
Patch0: lockdev-1.0.0-rh.patch
Patch1: lockdev-1.0.0-shared.patch
Prereq: shadow-utils, filesystem >= 2.1.4-1
BuildRoot: %{_tmppath}/%{name}-root
@ -13,10 +14,10 @@ BuildRoot: %{_tmppath}/%{name}-root
Lockdev provides a reliable way to put an exclusive lock to devices
using both FSSTND and SVr4 methods.
%package -n lockdev-devel
%package devel
Summary: The header files and a static library for the lockdev library.
Group: System Environment/Libraries
Requires: lockdev = %{version}
Requires: lockdev = %{version}-%{release}
%description -n lockdev-devel
The lockdev library provides a reliable way to put an exclusive lock
@ -25,7 +26,8 @@ package contains the development headers and a static library.
%prep
%setup -q
%patch0 -p1
%patch0 -p1 -b .redhat
%patch1 -p1 -b .shared
%build
make "CFLAGS=${RPM_OPT_FLAGS} -fPIC"
@ -54,15 +56,20 @@ rm -fr $RPM_BUILD_ROOT
%defattr(-,root,root)
%attr(2755,root,lock) %{_sbindir}/lockdev
%dir %attr(775,root,lock) /var/lock
%{_libdir}/*so*
%{_libdir}/*.so.*
%files devel
%defattr(-,root,root)
%{_libdir}/*.a
%{_libdir}/*.so
%{_mandir}/man*/*
%{_includedir}/*
%changelog
* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.0-16
- include liblockdev.so so that programs can link to a shared liblockdev
- fix shared library version numbers
* Fri Oct 26 2001 Trond Eivind Glomsrød <teg@redhat.com> 1.0.0-15
- Add copyright/license info to baudboy.h (#54321)