auto-import changelog data from lm_sensors-2.8.6-1.src.rpm
Tue Apr 13 2004 Phil Knirsch <pknirsch@redhat.com> 2.8.6-1 - Update to latest upstream version. - Enabled build for x86_64. Mon Mar 08 2004 Phil Knirsch <pknirsch@redhat.com> 2.8.3-5 - Fixed initscript to work with 2.6 kernel and made it more quiet (#112286). - Changed proposed location of sensors (#116496). - Fixed rpath issue.
This commit is contained in:
parent
b6031701a0
commit
b37409f255
@ -1 +1 @@
|
|||||||
lm_sensors-2.8.3.tar.gz
|
lm_sensors-2.8.6.tar.gz
|
||||||
|
@ -1,7 +1,20 @@
|
|||||||
--- lm_sensors-2.8.3/prog/init/lm_sensors.init.redhat 2003-02-25 03:50:46.000000000 +0100
|
--- lm_sensors-2.8.3/prog/init/lm_sensors.init.redhat 2003-02-25 03:50:46.000000000 +0100
|
||||||
+++ lm_sensors-2.8.3/prog/init/lm_sensors.init 2004-02-04 16:59:07.482175057 +0100
|
+++ lm_sensors-2.8.3/prog/init/lm_sensors.init 2004-03-08 17:15:56.960344769 +0100
|
||||||
@@ -39,7 +39,7 @@
|
@@ -29,17 +29,17 @@
|
||||||
[ -e /var/lock/subsys/sensors ] || /sbin/modprobe -r i2c-proc &>/dev/null
|
# MODULE_1, MODULE_2, MODULE_3, etc.
|
||||||
|
|
||||||
|
# If sensors isn't supported by the kernel, try loading the module...
|
||||||
|
-[ -e /proc/sys/dev/sensors ] || /sbin/modprobe i2c-proc &>/dev/null
|
||||||
|
+[ -e /sys/bus/i2c ] || /sbin/modprobe i2c-dev &>/dev/null
|
||||||
|
|
||||||
|
# Don't bother if /proc/sensors still doesn't exist, kernel doesn't have
|
||||||
|
# support for sensors.
|
||||||
|
-[ -e /proc/sys/dev/sensors ] || exit 0
|
||||||
|
+[ -e /sys/bus/i2c ] || exit 0
|
||||||
|
|
||||||
|
# If sensors was not already running, unload the module...
|
||||||
|
-[ -e /var/lock/subsys/sensors ] || /sbin/modprobe -r i2c-proc &>/dev/null
|
||||||
|
+[ -e /var/lock/subsys/sensors ] || /sbin/modprobe -r i2c-dev &>/dev/null
|
||||||
|
|
||||||
CONFIG=/etc/sysconfig/lm_sensors
|
CONFIG=/etc/sysconfig/lm_sensors
|
||||||
-PSENSORS=/usr/local/bin/sensors
|
-PSENSORS=/usr/local/bin/sensors
|
||||||
@ -9,8 +22,26 @@
|
|||||||
|
|
||||||
# Source function library.
|
# Source function library.
|
||||||
. /etc/init.d/functions
|
. /etc/init.d/functions
|
||||||
|
@@ -54,7 +54,7 @@
|
||||||
|
i=0
|
||||||
|
while [ $i -lt $modules ] ; do
|
||||||
|
module=`eval echo '$'MODULE_$i`
|
||||||
|
- echo starting module __${module}__
|
||||||
|
+# echo starting module __${module}__
|
||||||
|
/sbin/modprobe $module &>/dev/null
|
||||||
|
i=`expr $i + 1`
|
||||||
|
done
|
||||||
|
@@ -81,7 +81,7 @@
|
||||||
|
/sbin/modprobe -r $module &>/dev/null
|
||||||
|
i=`expr $i - 1`
|
||||||
|
done
|
||||||
|
- /sbin/modprobe -r i2c-proc &>/dev/null
|
||||||
|
+ /sbin/modprobe -r i2c-dev &>/dev/null
|
||||||
|
|
||||||
|
RETVAL=$?
|
||||||
|
if [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/sensors ; then
|
||||||
--- lm_sensors-2.8.3/Makefile.redhat 2003-12-29 20:29:16.000000000 +0100
|
--- lm_sensors-2.8.3/Makefile.redhat 2003-12-29 20:29:16.000000000 +0100
|
||||||
+++ lm_sensors-2.8.3/Makefile 2004-02-04 16:44:02.674488462 +0100
|
+++ lm_sensors-2.8.3/Makefile 2004-03-08 16:37:36.262280059 +0100
|
||||||
@@ -44,7 +44,7 @@
|
@@ -44,7 +44,7 @@
|
||||||
# may be used mistakenly. Note: This should point to the directory
|
# may be used mistakenly. Note: This should point to the directory
|
||||||
# *above* the linux/ subdirectory, so to /usr/local/include in the
|
# *above* the linux/ subdirectory, so to /usr/local/include in the
|
||||||
|
12
lm_sensors-2.8.3-rpath.patch
Normal file
12
lm_sensors-2.8.3-rpath.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- lm_sensors-2.8.3/Makefile.rpath 2004-03-08 18:06:52.318271655 +0100
|
||||||
|
+++ lm_sensors-2.8.3/Makefile 2004-03-08 18:08:30.344078783 +0100
|
||||||
|
@@ -95,7 +95,8 @@
|
||||||
|
# library files (both static and shared) will be installed.
|
||||||
|
LIBDIR := $(libdir)
|
||||||
|
|
||||||
|
-EXLDFLAGS := -Wl,-rpath,$(LIBDIR)
|
||||||
|
+#EXLDFLAGS := -Wl,-rpath,$(LIBDIR)
|
||||||
|
+EXLDFLAGS :=
|
||||||
|
|
||||||
|
# You should not need to change this. It is the directory into which the
|
||||||
|
# executable program files will be installed. BINDIR for programs that are
|
@ -1,19 +1,21 @@
|
|||||||
Name: lm_sensors
|
Name: lm_sensors
|
||||||
Version: 2.8.3
|
Version: 2.8.6
|
||||||
Release: 4
|
Release: 1
|
||||||
URL: http://secure.netroedge.com/~lm78/
|
URL: http://secure.netroedge.com/~lm78/
|
||||||
Source: http://secure.netroedge.com/~lm78/archive/lm_sensors-%{version}.tar.gz
|
Source: http://secure.netroedge.com/~lm78/archive/lm_sensors-%{version}.tar.gz
|
||||||
Patch1: lm_sensors-2.5.5-glibc22.patch
|
Patch1: lm_sensors-2.5.5-glibc22.patch
|
||||||
Patch2: lm_sensors-2.8.3-redhat.patch
|
Patch2: lm_sensors-2.8.3-redhat.patch
|
||||||
Patch3: lm_sensors-2.8.0-utf8.patch
|
Patch3: lm_sensors-2.8.0-utf8.patch
|
||||||
Patch4: lm_sensors-2.8.2-expr.patch
|
Patch4: lm_sensors-2.8.2-expr.patch
|
||||||
|
Patch5: lm_sensors-2.8.3-local.patch
|
||||||
|
Patch6: lm_sensors-2.8.3-rpath.patch
|
||||||
Summary: Hardware monitoring tools.
|
Summary: Hardware monitoring tools.
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
License: GPL
|
License: GPL
|
||||||
Buildroot: %{_tmppath}/%{name}-root
|
Buildroot: %{_tmppath}/%{name}-root
|
||||||
Requires: kernel-utils
|
Requires: kernel-utils
|
||||||
BuildPrereq: kernel-headers >= 2.2.16
|
BuildPrereq: kernel-headers >= 2.2.16
|
||||||
ExclusiveArch: alpha %{ix86}
|
ExclusiveArch: alpha %{ix86} x86_64
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The lm_sensors package includes a collection of modules for general SMBus
|
The lm_sensors package includes a collection of modules for general SMBus
|
||||||
@ -35,6 +37,8 @@ when building applications that make use of sensor data.
|
|||||||
%patch2 -p1 -b .redhat
|
%patch2 -p1 -b .redhat
|
||||||
%patch3 -p1 -b .utf8
|
%patch3 -p1 -b .utf8
|
||||||
%patch4 -p1 -b .expr
|
%patch4 -p1 -b .expr
|
||||||
|
%patch5 -p1 -b .local
|
||||||
|
%patch6 -p1 -b .rpath
|
||||||
|
|
||||||
%build
|
%build
|
||||||
mkdir -p kernel/include/linux
|
mkdir -p kernel/include/linux
|
||||||
@ -43,7 +47,7 @@ make user
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
|
||||||
make prefix=/usr exec_prefix=/usr bindir=/usr/bin sbindir=/usr/sbin sysconfdir=/etc datadir=/usr/share includedir=/usr/include libdir=/usr/lib libexecdir=/usr/libexec localstatedir=/var sharedstatedir=/usr/com mandir=/usr/share/man infodir=/usr/share/info DESTDIR=$RPM_BUILD_ROOT user_install
|
make prefix=/usr exec_prefix=/usr bindir=/usr/bin sbindir=/usr/sbin sysconfdir=/etc datadir=/usr/share includedir=/usr/include libdir=%{_libdir} libexecdir=/usr/libexec localstatedir=/var sharedstatedir=/usr/com mandir=/usr/share/man infodir=/usr/share/info DESTDIR=$RPM_BUILD_ROOT user_install
|
||||||
chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so*
|
chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so*
|
||||||
|
|
||||||
# remove dmidecode from the buildroot
|
# remove dmidecode from the buildroot
|
||||||
@ -76,6 +80,15 @@ rm -rf $RPM_BUILD_ROOT%{_includedir}/linux
|
|||||||
%{_libdir}/lib*.so
|
%{_libdir}/lib*.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 13 2004 Phil Knirsch <pknirsch@redhat.com> 2.8.6-1
|
||||||
|
- Update to latest upstream version.
|
||||||
|
- Enabled build for x86_64.
|
||||||
|
|
||||||
|
* Mon Mar 08 2004 Phil Knirsch <pknirsch@redhat.com> 2.8.3-5
|
||||||
|
- Fixed initscript to work with 2.6 kernel and made it more quiet (#112286).
|
||||||
|
- Changed proposed location of sensors (#116496).
|
||||||
|
- Fixed rpath issue.
|
||||||
|
|
||||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
- rebuilt
|
- rebuilt
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user