b37409f255
Tue Apr 13 2004 Phil Knirsch <pknirsch@redhat.com> 2.8.6-1 - Update to latest upstream version. - Enabled build for x86_64. Mon Mar 08 2004 Phil Knirsch <pknirsch@redhat.com> 2.8.3-5 - Fixed initscript to work with 2.6 kernel and made it more quiet (#112286). - Changed proposed location of sensors (#116496). - Fixed rpath issue.
115 lines
3.8 KiB
Diff
115 lines
3.8 KiB
Diff
--- lm_sensors-2.8.3/prog/init/lm_sensors.init.redhat 2003-02-25 03:50:46.000000000 +0100
|
|
+++ lm_sensors-2.8.3/prog/init/lm_sensors.init 2004-03-08 17:15:56.960344769 +0100
|
|
@@ -29,17 +29,17 @@
|
|
# MODULE_1, MODULE_2, MODULE_3, etc.
|
|
|
|
# If sensors isn't supported by the kernel, try loading the module...
|
|
-[ -e /proc/sys/dev/sensors ] || /sbin/modprobe i2c-proc &>/dev/null
|
|
+[ -e /sys/bus/i2c ] || /sbin/modprobe i2c-dev &>/dev/null
|
|
|
|
# Don't bother if /proc/sensors still doesn't exist, kernel doesn't have
|
|
# support for sensors.
|
|
-[ -e /proc/sys/dev/sensors ] || exit 0
|
|
+[ -e /sys/bus/i2c ] || exit 0
|
|
|
|
# If sensors was not already running, unload the module...
|
|
-[ -e /var/lock/subsys/sensors ] || /sbin/modprobe -r i2c-proc &>/dev/null
|
|
+[ -e /var/lock/subsys/sensors ] || /sbin/modprobe -r i2c-dev &>/dev/null
|
|
|
|
CONFIG=/etc/sysconfig/lm_sensors
|
|
-PSENSORS=/usr/local/bin/sensors
|
|
+PSENSORS=/usr/bin/sensors
|
|
|
|
# Source function library.
|
|
. /etc/init.d/functions
|
|
@@ -54,7 +54,7 @@
|
|
i=0
|
|
while [ $i -lt $modules ] ; do
|
|
module=`eval echo '$'MODULE_$i`
|
|
- echo starting module __${module}__
|
|
+# echo starting module __${module}__
|
|
/sbin/modprobe $module &>/dev/null
|
|
i=`expr $i + 1`
|
|
done
|
|
@@ -81,7 +81,7 @@
|
|
/sbin/modprobe -r $module &>/dev/null
|
|
i=`expr $i - 1`
|
|
done
|
|
- /sbin/modprobe -r i2c-proc &>/dev/null
|
|
+ /sbin/modprobe -r i2c-dev &>/dev/null
|
|
|
|
RETVAL=$?
|
|
if [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/sensors ; then
|
|
--- lm_sensors-2.8.3/Makefile.redhat 2003-12-29 20:29:16.000000000 +0100
|
|
+++ lm_sensors-2.8.3/Makefile 2004-03-08 16:37:36.262280059 +0100
|
|
@@ -44,7 +44,7 @@
|
|
# may be used mistakenly. Note: This should point to the directory
|
|
# *above* the linux/ subdirectory, so to /usr/local/include in the
|
|
# above example.
|
|
-I2C_HEADERS := /usr/local/include
|
|
+I2C_HEADERS := /usr/src/linux/include
|
|
#I2C_HEADERS := $(LINUX_HEADERS)
|
|
|
|
# Uncomment the third line on SMP systems if the magic invocation fails. It
|
|
@@ -63,8 +63,8 @@
|
|
|
|
# Uncomment the second line if you are a developer. This will enable many
|
|
# additional warnings at compile-time
|
|
-WARN := 0
|
|
-#WARN := 1
|
|
+#WARN := 0
|
|
+WARN := 1
|
|
|
|
# Uncomment the second line if you want to get (loads of) debug information
|
|
# at run-time.
|
|
@@ -77,7 +77,7 @@
|
|
DESTDIR :=
|
|
|
|
# This is the prefix that will be used for almost all directories below.
|
|
-PREFIX := /usr/local
|
|
+PREFIX := $(prefix)
|
|
|
|
# This is the main modules directory into which the modules will be installed.
|
|
# The magic invocation will return something like this:
|
|
@@ -89,11 +89,11 @@
|
|
|
|
# This is the directory where sensors.conf will be installed, if no other
|
|
# configuration file is found
|
|
-ETCDIR := /etc
|
|
+ETCDIR := $(sysconfdir)
|
|
|
|
# You should not need to change this. It is the directory into which the
|
|
# library files (both static and shared) will be installed.
|
|
-LIBDIR := $(PREFIX)/lib
|
|
+LIBDIR := $(libdir)
|
|
|
|
EXLDFLAGS := -Wl,-rpath,$(LIBDIR)
|
|
|
|
@@ -104,8 +104,8 @@
|
|
# Note that not all programs in this package are really installed;
|
|
# some are just examples. You can always install them by hand, of
|
|
# course.
|
|
-BINDIR := $(PREFIX)/bin
|
|
-SBINDIR := $(PREFIX)/sbin
|
|
+BINDIR := $(bindir)
|
|
+SBINDIR := $(sbindir)
|
|
|
|
# You should not need to change this. It is the basic directory into which
|
|
# include files will be installed. The actual directory will be
|
|
@@ -113,13 +113,13 @@
|
|
# for library include files. If PREFIX equals the default /usr/local/bin,
|
|
# you will be able to use '#include <linux/sensors.h>' regardless of the
|
|
# current kernel selected.
|
|
-INCLUDEDIR := $(PREFIX)/include
|
|
+INCLUDEDIR := $(includedir)
|
|
SYSINCLUDEDIR := $(INCLUDEDIR)/linux
|
|
LIBINCLUDEDIR := $(INCLUDEDIR)/sensors
|
|
|
|
# You should not need to change this. It is the base directory under which the
|
|
# manual pages will be installed.
|
|
-MANDIR := $(PREFIX)/man
|
|
+MANDIR := $(mandir)
|
|
|
|
MACHINE := $(shell uname -m)
|
|
|