Update to 9.0.0

This commit is contained in:
Benjamin A. Beasley 2023-08-01 09:32:04 -04:00
parent 99ff5de1e7
commit 97b2a088f3
4 changed files with 6 additions and 35 deletions

2
.gitignore vendored
View File

@ -10,3 +10,5 @@
/llhttp-8.1.0-nm-dev.tgz
/llhttp-8.1.1.tar.gz
/llhttp-8.1.1-nm-dev.tgz
/llhttp-9.0.0.tar.gz
/llhttp-9.0.0-nm-dev.tgz

View File

@ -1,24 +0,0 @@
From 553ae7d1bda0b97a43af6b57ea2fd7ce04b6630d Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Tue, 27 Jun 2023 18:27:17 -0400
Subject: [PATCH] Do not assume a particular sed implementation
Make the release target in the Makefile more portable.
---
Makefile | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 5b941b3..d9c6d35 100644
--- a/Makefile
+++ b/Makefile
@@ -52,8 +52,7 @@ release: clean generate
cp -rf src/native/*.c release/src/
cp -rf src/llhttp.gyp release/
cp -rf src/common.gypi release/
- cp -rf CMakeLists.txt release/
- sed -i '' s/_RELEASE_/$(RELEASE)/ release/CMakeLists.txt
+ sed s/_RELEASE_/$(RELEASE)/ CMakeLists.txt > release/CMakeLists.txt
cp -rf libllhttp.pc.in release/
cp -rf README.md release/
cp -rf LICENSE-MIT release/

View File

@ -26,8 +26,8 @@
# additional source even if we do not do the re-generation ourselves.
Name: llhttp
Version: 8.1.1
%global so_version 8.1
Version: 9.0.0
%global so_version 9.0
Release: %autorelease
Summary: Port of http_parser to llparse
@ -54,10 +54,6 @@ Source2: llhttp-%{version}-nm-dev.tgz
Source3: check-null-licenses
Source4: audited-null-licenses.toml
# Do not assume a particular sed implementation
# https://github.com/nodejs/llhttp/pull/230
Patch: %{url}/pull/230.patch
# The compiled RPM does not depend on NodeJS at all, but we cannot *build* it
# on architectures without NodeJS.
ExclusiveArch: %{nodejs_arches}
@ -81,9 +77,6 @@ This project is a port of http_parser to TypeScript. llparse is used to
generate the output C source file, which could be compiled and linked with the
embedder's program (like Node.js).
This copy of the library is compiled with LLHTTP_STRICT_MODE set to 0
(disabled), which is the default.
%package devel
Summary: Development files for llhttp

View File

@ -1,2 +1,2 @@
SHA512 (llhttp-8.1.1.tar.gz) = 18530d1fcfde13ba634b367852e53bf7a2dc0eb130f07fbbb5b5e02b3d4ff0ab0cd7c5a0adef8a7a0e93a0104a2544ce11d3631792539c48e1a918c5d40f7f3c
SHA512 (llhttp-8.1.1-nm-dev.tgz) = 5348f09a4d8a7b7ecb5d4204d47b1f6c36ed7d131cd89f84feef475cba74fc651bf63bc10293fb5481c19c88e07e3ae2e44881ffda19606876e1f38de32ae80f
SHA512 (llhttp-9.0.0.tar.gz) = 2674dc7011d36951dec019ac980d31d58e0412416383d76186ed706cadcfcc7e60687555adad77026acf4ad32df14ce886cb5cf2f0375d604e2650a12fae2a14
SHA512 (llhttp-9.0.0-nm-dev.tgz) = aa37c969c18df6f57c4097d1e6a11938a6e6fb7754030243bc0f0c16624cb9b4cd7577b725070a7ff0b96bfbe218d557f51034aace04cfb934d31af7ffab4302