Update to 8.1.1 (close RHBZ#2216591)

This commit is contained in:
Benjamin A. Beasley 2023-06-22 11:38:58 -04:00
parent 44460d50b5
commit 99ff5de1e7
5 changed files with 46 additions and 4 deletions

2
.gitignore vendored
View File

@ -8,3 +8,5 @@
/llhttp-8.0.0-nm-dev.tgz
/llhttp-8.1.0.tar.gz
/llhttp-8.1.0-nm-dev.tgz
/llhttp-8.1.1.tar.gz
/llhttp-8.1.1-nm-dev.tgz

24
230.patch Normal file
View File

@ -0,0 +1,24 @@
From 553ae7d1bda0b97a43af6b57ea2fd7ce04b6630d Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Tue, 27 Jun 2023 18:27:17 -0400
Subject: [PATCH] Do not assume a particular sed implementation
Make the release target in the Makefile more portable.
---
Makefile | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 5b941b3..d9c6d35 100644
--- a/Makefile
+++ b/Makefile
@@ -52,8 +52,7 @@ release: clean generate
cp -rf src/native/*.c release/src/
cp -rf src/llhttp.gyp release/
cp -rf src/common.gypi release/
- cp -rf CMakeLists.txt release/
- sed -i '' s/_RELEASE_/$(RELEASE)/ release/CMakeLists.txt
+ sed s/_RELEASE_/$(RELEASE)/ CMakeLists.txt > release/CMakeLists.txt
cp -rf libllhttp.pc.in release/
cp -rf README.md release/
cp -rf LICENSE-MIT release/

View File

@ -5,7 +5,7 @@
[dev]
# Just a module wrapper around the code in tslib, which does have a proper
# license in its package.json:
# license (0BSD) in its package.json:
# tslib/modules
modules = "<unknown version>"
# A “dummy” module in the tests for tslib
@ -29,3 +29,15 @@ baz = "<unknown version>"
browser_field = "<unknown version>"
# resolve/test/resolver/symlinked/package
package = "<unknown version>"
# These are all part of nanoid, which is MIT-licensed.
# nanoid/url-alphabet
url-alphabet = "<unknown version>"
# nanoid/non-secure
non-secure = "<unknown version>"
# nanoid/async
async = "<unknown version>"
# This is part of yargs, which is MIT-licensed.
# mocha/node_modules/yargs/helpers
helpers = "<unknown version>"

View File

@ -26,7 +26,7 @@
# additional source even if we do not do the re-generation ourselves.
Name: llhttp
Version: 8.1.0
Version: 8.1.1
%global so_version 8.1
Release: %autorelease
Summary: Port of http_parser to llparse
@ -54,6 +54,10 @@ Source2: llhttp-%{version}-nm-dev.tgz
Source3: check-null-licenses
Source4: audited-null-licenses.toml
# Do not assume a particular sed implementation
# https://github.com/nodejs/llhttp/pull/230
Patch: %{url}/pull/230.patch
# The compiled RPM does not depend on NodeJS at all, but we cannot *build* it
# on architectures without NodeJS.
ExclusiveArch: %{nodejs_arches}

View File

@ -1,2 +1,2 @@
SHA512 (llhttp-8.1.0.tar.gz) = 363f8b3f8aa743f2529c0738b8b95dd682bacf7bd1afa1fc9b8a1d67251e1ced90b986402939ea484bc2cf511a83819b3def6345885ad59e8854c7c263d999da
SHA512 (llhttp-8.1.0-nm-dev.tgz) = 4b5aa38a4b77ade1e2f3758a156efe8698f5f0cbb7cafe9f547dd45d425f66d17bbb10b20cc98cef1268a0f8f6a8fa11f95e5e0ddde363e196425bc565f87431
SHA512 (llhttp-8.1.1.tar.gz) = 18530d1fcfde13ba634b367852e53bf7a2dc0eb130f07fbbb5b5e02b3d4ff0ab0cd7c5a0adef8a7a0e93a0104a2544ce11d3631792539c48e1a918c5d40f7f3c
SHA512 (llhttp-8.1.1-nm-dev.tgz) = 5348f09a4d8a7b7ecb5d4204d47b1f6c36ed7d131cd89f84feef475cba74fc651bf63bc10293fb5481c19c88e07e3ae2e44881ffda19606876e1f38de32ae80f