Backport ignoring --no-add-needed
Resolves: rhbz#2061041
This commit is contained in:
parent
22967a4a2a
commit
f3b72993c3
22
ignore-no-add-needed.patch
Normal file
22
ignore-no-add-needed.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff -ruN lld-14.0.0.src.orig/ELF/Options.td lld-14.0.0.src/ELF/Options.td
|
||||
--- a/lld-14.0.0.src.orig/ELF/Options.td 2022-03-14 10:44:55.000000000 +0100
|
||||
+++ b/lld-14.0.0.src/ELF/Options.td 2022-05-05 13:27:06.029896421 +0200
|
||||
@@ -695,6 +695,7 @@
|
||||
def: F<"detect-odr-violations">;
|
||||
def: Flag<["-"], "g">;
|
||||
def: F<"long-plt">;
|
||||
+def: FF<"no-add-needed">;
|
||||
def: F<"no-copy-dt-needed-entries">;
|
||||
def: F<"no-ctors-in-init-array">;
|
||||
def: F<"no-keep-memory">;
|
||||
diff -ruN lld-14.0.0.src.orig/test/ELF/silent-ignore.test lld-14.0.0.src/test/ELF/silent-ignore.test
|
||||
--- a/lld-14.0.0.src.orig/test/ELF/silent-ignore.test 2022-03-14 10:44:55.000000000 +0100
|
||||
+++ b/lld-14.0.0.src/test/ELF/silent-ignore.test 2022-05-05 13:27:29.734085587 +0200
|
||||
@@ -2,6 +2,7 @@
|
||||
RUN: -detect-odr-violations \
|
||||
RUN: -g \
|
||||
RUN: -long-plt \
|
||||
+RUN: --no-add-needed \
|
||||
RUN: -no-copy-dt-needed-entries \
|
||||
RUN: -no-ctors-in-init-array \
|
||||
RUN: -no-keep-memory \
|
8
lld.spec
8
lld.spec
@ -12,7 +12,7 @@
|
||||
|
||||
Name: lld
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: The LLVM Linker
|
||||
|
||||
License: NCSA
|
||||
@ -30,6 +30,9 @@ Patch0: 0001-PATCH-lld-CMake-Check-for-gtest-headers-even-if-lit..patch
|
||||
# Bundle libunwind header need during build for MachO support
|
||||
Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
|
||||
|
||||
# https://github.com/llvm/llvm-project/commit/c29c19cb5327624dd31fcb776f8fbe66ca1011bb
|
||||
Patch2: ignore-no-add-needed.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
@ -205,6 +208,9 @@ fi
|
||||
%{_datadir}/lld/lit.lld-test.cfg.py
|
||||
|
||||
%changelog
|
||||
* Fri May 06 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-2
|
||||
- Backport ignoring --no-add-needed
|
||||
|
||||
* Mon Apr 25 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
|
||||
- 14.0.0 Release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user