14.0.0 Release

Resolves: rhbz#2061041
This commit is contained in:
Timm Bäder 2022-04-25 11:58:57 +02:00
parent a9d3488519
commit 22967a4a2a
4 changed files with 14 additions and 11 deletions

2
.gitignore vendored
View File

@ -77,3 +77,5 @@
/lld-13.0.0.src.tar.xz.sig
/lld-13.0.1.src.tar.xz
/lld-13.0.1.src.tar.xz.sig
/lld-14.0.0.src.tar.xz
/lld-14.0.0.src.tar.xz.sig

View File

@ -14,7 +14,7 @@ diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
index d4e561b..a7406d1c 100644
--- a/lld/CMakeLists.txt
+++ b/lld/CMakeLists.txt
@@ -65,6 +65,15 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
@@ -68,6 +68,15 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
set(LLVM_UTILS_PROVIDED ON)
endif()
@ -30,7 +30,7 @@ index d4e561b..a7406d1c 100644
if(EXISTS ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
# Note: path not really used, except for checking if lit was found
set(LLVM_LIT ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
@@ -74,12 +83,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
@@ -77,12 +86,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
set(LLVM_UTILS_PROVIDED ON)
set(LLD_TEST_DEPS FileCheck not)
endif()

View File

@ -1,10 +1,10 @@
%bcond_without check
#global rc_ver 4
#global rc_ver 1
%global lld_srcdir lld-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
%global maj_ver 13
%global maj_ver 14
%global min_ver 0
%global patch_ver 1
%global patch_ver 0
# Don't include unittests in automatic generation of provides or requires.
%global __provides_exclude_from ^%{_libdir}/lld/.*$
@ -145,8 +145,8 @@ install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/lld
# Install unit test binaries
install -d %{buildroot}%{_libdir}/lld/
cp -R %{__cmake_builddir}/unittests %{buildroot}%{_libdir}/lld/
rm -rf `find %{buildroot}%{_libdir}/lld/ -iname '*make*'`
rm -rf $(find %{buildroot}%{_libdir}/lld/ -iname '*make*')
# Install gtest libraries
cp %{__cmake_builddir}/%{_lib}/libgtest*so* %{buildroot}%{_libdir}/lld/
@ -186,8 +186,6 @@ fi
%{_bindir}/lld*
%{_bindir}/ld.lld
%{_bindir}/ld64.lld
%{_bindir}/ld64.lld.darwinnew
%{_bindir}/ld64.lld.darwinold
%{_bindir}/wasm-ld
%files devel
@ -207,6 +205,9 @@ fi
%{_datadir}/lld/lit.lld-test.cfg.py
%changelog
* Mon Apr 25 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
- 14.0.0 Release
* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
- 13.0.1 Release

View File

@ -1,2 +1,2 @@
SHA512 (lld-13.0.1.src.tar.xz) = cc0b401e741b9d3d283d9d41969354be55791f74ab80d3d3ac50bb653c4b5826d9ce11e7fdd38517c98e0abceaa21cf0407fc8e418f9db1a30f2f3587e0f0db0
SHA512 (lld-13.0.1.src.tar.xz.sig) = de77a62fc413245f92cc005c38ef0e76446d8fc877d78aa3d838cd4de3a573a33ad8e9c53c300ff775dbf9029571bf929bbc26fec625c000abba04d76bbdeb43
SHA512 (lld-14.0.0.src.tar.xz) = 08944782d138795bbf45903bf2459cf93bf296a8f7e97ece9a94b1a5c86d791dc3eb81a688b678a8a42c6f5a44b3a2f4bf6523f03617831c27372343dfd26891
SHA512 (lld-14.0.0.src.tar.xz.sig) = 29d79bf200c45849af717e1717ae7524821fa47e2db8abf079b443fc3441eb391fa770674190ef8b3d9eed5e7ca58514ea64cf0428e145a1bd15b29adb4dfffa