Update to 1.1.32
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
73fb2d7a9d
commit
157ff26e81
@ -1,117 +0,0 @@
|
|||||||
From 76df4c960c7247d82bf1c26344e76236cb37a175 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Nick Wellnhofer <wellnhofer@aevum.de>
|
|
||||||
Date: Thu, 14 Sep 2017 16:24:16 +0200
|
|
||||||
Subject: [PATCH] Fix pkg-config related regressions in configure script
|
|
||||||
|
|
||||||
Fix bashism in configure.in. Resulted in pkg-config never getting used
|
|
||||||
for libxml if sh is not bash.
|
|
||||||
|
|
||||||
Move pkg-config block to correct location. Rework libxml2 detection
|
|
||||||
logic.
|
|
||||||
|
|
||||||
Fixes bugs 787602 and 787617.
|
|
||||||
---
|
|
||||||
configure.in | 54 ++++++++++++++++++++++--------------------------------
|
|
||||||
1 file changed, 22 insertions(+), 32 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.in b/configure.in
|
|
||||||
index d6aa3664..d39a916b 100644
|
|
||||||
--- a/configure.in
|
|
||||||
+++ b/configure.in
|
|
||||||
@@ -501,32 +501,11 @@ AC_ARG_WITH(libxml-src,
|
|
||||||
)
|
|
||||||
AC_SUBST(LIBXML_SRC)
|
|
||||||
|
|
||||||
-dnl
|
|
||||||
-dnl Try pkg-config first if nothing is set
|
|
||||||
-dnl
|
|
||||||
-
|
|
||||||
-if test "x$LIBXML_CONFIG_PREFIX" == "x" -a "x$LIBXML_SRC" == "x"
|
|
||||||
-then
|
|
||||||
- PKG_CHECK_MODULES([LIBXML], [libxml-2.0 >= $LIBXML_REQUIRED_VERSION], [
|
|
||||||
- LIBXML_MANUAL_SEARCH=no
|
|
||||||
- WITH_MODULES="`$PKG_CONFIG --variable=modules libxml-2.0`"
|
|
||||||
- ],
|
|
||||||
- [
|
|
||||||
- LIBXML_MANUAL_SEARCH=yes
|
|
||||||
- ])
|
|
||||||
-else
|
|
||||||
- LIBXML_MANUAL_SEARCH=yes
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-if test "x$LIBXML_MANUAL_SEARCH" != "xno"
|
|
||||||
-then
|
|
||||||
-
|
|
||||||
dnl
|
|
||||||
dnl where is xml2-config
|
|
||||||
dnl
|
|
||||||
|
|
||||||
AC_SUBST(LIBXML_REQUIRED_VERSION)
|
|
||||||
-AC_MSG_CHECKING(for libxml libraries >= $LIBXML_REQUIRED_VERSION)
|
|
||||||
if test "x$LIBXML_CONFIG_PREFIX" != "x"
|
|
||||||
then
|
|
||||||
AC_PATH_TOOL([XML_CONFIG], [xml2-config], [false], [${LIBXML_CONFIG_PREFIX}/bin])
|
|
||||||
@@ -570,20 +549,33 @@ then
|
|
||||||
LIBXML_SRC=`pwd`
|
|
||||||
XML_CONFIG="${LIBXML_SRC}/xml2-config"
|
|
||||||
LIBXML_CFLAGS="-I${LIBXML_SRC}/include"
|
|
||||||
- LIBXML_LIBS="-L${LIBXML_SRC}"
|
|
||||||
+ LIBXML_LIBS="-L${LIBXML_SRC} `$XML_CONFIG --libs`"
|
|
||||||
+ WITH_MODULES="`$XML_CONFIG --modules`"
|
|
||||||
cd $CWD
|
|
||||||
else
|
|
||||||
AC_MSG_ERROR([libxml source dir not found (${LIBXML_SRC}), typo?])
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
+dnl
|
|
||||||
+dnl Try pkg-config first if nothing is set
|
|
||||||
+dnl
|
|
||||||
+
|
|
||||||
+if test "x$LIBXML_CONFIG_PREFIX" = "x" -a "x$LIBXML_LIBS" = "x"
|
|
||||||
+then
|
|
||||||
+ PKG_CHECK_MODULES([LIBXML], [libxml-2.0 >= $LIBXML_REQUIRED_VERSION], [
|
|
||||||
+ WITH_MODULES="`$PKG_CONFIG --variable=modules libxml-2.0`"
|
|
||||||
+ ], [ ])
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
dnl
|
|
||||||
dnl make sure xml2-config is executable,
|
|
||||||
dnl test version and init our variables
|
|
||||||
dnl
|
|
||||||
|
|
||||||
-if ${XML_CONFIG} --libs print > /dev/null 2>&1
|
|
||||||
+if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs print > /dev/null 2>&1
|
|
||||||
then
|
|
||||||
+ AC_MSG_CHECKING(for libxml libraries >= $LIBXML_REQUIRED_VERSION)
|
|
||||||
XMLVERS=`$XML_CONFIG --version`
|
|
||||||
if test VERSION_TO_NUMBER(echo $XMLVERS) -ge VERSION_TO_NUMBER(echo $LIBXML_REQUIRED_VERSION)
|
|
||||||
then
|
|
||||||
@@ -591,17 +583,15 @@ then
|
|
||||||
else
|
|
||||||
AC_MSG_ERROR(Version $XMLVERS found. You need at least libxml2 $LIBXML_REQUIRED_VERSION for this version of libxslt)
|
|
||||||
fi
|
|
||||||
- LIBXML_LIBS="$LIBXML_LIBS `$XML_CONFIG --libs`"
|
|
||||||
- if test "x$LIBXML_SRC" = "x"; then
|
|
||||||
- LIBXML_CFLAGS="$LIBXML_CFLAGS `$XML_CONFIG --cflags`"
|
|
||||||
- fi
|
|
||||||
-else
|
|
||||||
- AC_MSG_ERROR([Could not find libxml2 anywhere, check ftp://xmlsoft.org/.])
|
|
||||||
+ LIBXML_LIBS="`$XML_CONFIG --libs`"
|
|
||||||
+ LIBXML_CFLAGS="`$XML_CONFIG --cflags`"
|
|
||||||
+ WITH_MODULES="`$XML_CONFIG --modules`"
|
|
||||||
fi
|
|
||||||
|
|
||||||
-WITH_MODULES="`$XML_CONFIG --modules`"
|
|
||||||
-
|
|
||||||
-fi # LIBXML_MANUAL_SEARCH
|
|
||||||
+if test "x$LIBXML_LIBS" = "x"
|
|
||||||
+then
|
|
||||||
+ AC_MSG_ERROR([Could not find libxml2 anywhere, check ftp://xmlsoft.org/.])
|
|
||||||
+fi
|
|
||||||
|
|
||||||
|
|
||||||
AC_SUBST(CFLAGS)
|
|
||||||
--
|
|
||||||
2.14.2
|
|
||||||
|
|
13
libxslt.spec
13
libxslt.spec
@ -1,7 +1,7 @@
|
|||||||
Name: libxslt
|
Name: libxslt
|
||||||
Summary: Library providing the Gnome XSLT engine
|
Summary: Library providing the Gnome XSLT engine
|
||||||
Version: 1.1.30
|
Version: 1.1.32
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://xmlsoft.org/XSLT
|
URL: http://xmlsoft.org/XSLT
|
||||||
@ -19,10 +19,6 @@ BuildRequires: pkgconfig(libxml-2.0) >= 2.6.27
|
|||||||
Patch0: multilib.patch
|
Patch0: multilib.patch
|
||||||
Patch1: libxslt-1.1.26-utf8-docs.patch
|
Patch1: libxslt-1.1.26-utf8-docs.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1498539
|
|
||||||
# https://git.gnome.org/browse/libxslt/commit/?id=76df4c960c7247d82bf1c26344e76236cb37a175
|
|
||||||
Patch2: 0001-Fix-pkg-config-related-regressions-in-configure-scri.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This C library allows to transform XML files into other XML files
|
This C library allows to transform XML files into other XML files
|
||||||
(or HTML, text, ...) using the standard XSLT stylesheet transformation
|
(or HTML, text, ...) using the standard XSLT stylesheet transformation
|
||||||
@ -122,6 +118,11 @@ rm -vrf %{buildroot}%{_docdir}
|
|||||||
%doc python/tests/*.xsl
|
%doc python/tests/*.xsl
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.1.32-1
|
||||||
|
- Update to 1.1.32
|
||||||
|
- Cleanup spec
|
||||||
|
- Re-enable hardened build
|
||||||
|
|
||||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.30-5
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.30-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libxslt-1.1.30.tar.gz) = d24e37398503b6bc29245a993738df51bf3948c4a8f052eedd7eac0a9fcff2d5b54220f37070c46f763e073c34bdb3153c9f129aa0df60c3d7cf7eadbbf15986
|
SHA512 (libxslt-1.1.32.tar.gz) = e1ed3c103cd4c9897e7dd2360a11f63cf30382b7566ce6fcc81117804e203714446b5a62179ce628c3834b0b32ecdeeceecbdfa417507ce9ed5a107a0ebefb39
|
||||||
|
Loading…
Reference in New Issue
Block a user