Upstream release of libxml2-2.8.0
Revert the couple of old patches, add new dep for xz-devel
This commit is contained in:
parent
e047144a9e
commit
ae9b3feb87
1
.gitignore
vendored
1
.gitignore
vendored
@ -27,3 +27,4 @@ libxml2-2.7.5.tar.gz
|
||||
libxml2-2.7.6.tar.gz
|
||||
libxml2-2.7.7.tar.gz
|
||||
/libxml2-2.7.8.tar.gz
|
||||
/libxml2-2.8.0.tar.gz
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- a/xpath.c
|
||||
+++ a/xpath.c
|
||||
@@ -11763,11 +11763,16 @@ xmlXPathCompOpEvalPositionalPredicate(xmlXPathParserContextPtr ctxt,
|
||||
|
||||
if ((ctxt->error != XPATH_EXPRESSION_OK) || (res == -1)) {
|
||||
xmlXPathObjectPtr tmp;
|
||||
- /* pop the result */
|
||||
+ /* pop the result if any */
|
||||
tmp = valuePop(ctxt);
|
||||
- xmlXPathReleaseObject(xpctxt, tmp);
|
||||
- /* then pop off contextObj, which will be freed later */
|
||||
- valuePop(ctxt);
|
||||
+ if (tmp != contextObj) {
|
||||
+ /*
|
||||
+ * Free up the result
|
||||
+ * then pop off contextObj, which will be freed later
|
||||
+ */
|
||||
+ xmlXPathReleaseObject(xpctxt, tmp);
|
||||
+ valuePop(ctxt);
|
||||
+ }
|
||||
goto evaluation_error;
|
||||
}
|
@ -1,58 +0,0 @@
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 59d0629..39b66dd 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -75,6 +75,8 @@ dnl if the system support linker version scripts for symbol versioning
|
||||
dnl then add it
|
||||
dnl
|
||||
VERSION_SCRIPT_FLAGS=
|
||||
+echo host $host
|
||||
+echo lt_cv_prog_gnu_ld $lt_cv_prog_gnu_ld
|
||||
# lt_cv_prog_gnu_ld is from libtool 2.+
|
||||
if test "$lt_cv_prog_gnu_ld" = yes; then
|
||||
VERSION_SCRIPT_FLAGS=-Wl,--version-script=
|
||||
@@ -82,9 +84,12 @@ else
|
||||
case $host in
|
||||
*-*-sunos*) VERSION_SCRIPT_FLAGS="-Wl,-M -Wl,";;
|
||||
esac
|
||||
+ case $host in
|
||||
+ *-*-linux*) VERSION_SCRIPT_FLAGS="-Wl,--version-script=";;
|
||||
+ esac
|
||||
fi
|
||||
AC_SUBST(VERSION_SCRIPT_FLAGS)
|
||||
-AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -z "$VERSION_SCRIPT_FLAGS"])
|
||||
+AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -n "$VERSION_SCRIPT_FLAGS"])
|
||||
|
||||
dnl
|
||||
dnl We process the AC_ARG_WITH first so that later we can modify
|
||||
diff --git a/configure.in b/configure.in
|
||||
*** a/configure
|
||||
--- b/configure
|
||||
*************** CC="$lt_save_CC"
|
||||
*** 11405,11410 ****
|
||||
--- 11405,11412 ----
|
||||
|
||||
|
||||
VERSION_SCRIPT_FLAGS=
|
||||
+ echo host $host
|
||||
+ echo lt_cv_prog_gnu_ld $lt_cv_prog_gnu_ld
|
||||
# lt_cv_prog_gnu_ld is from libtool 2.+
|
||||
if test "$lt_cv_prog_gnu_ld" = yes; then
|
||||
VERSION_SCRIPT_FLAGS=-Wl,--version-script=
|
||||
*************** else
|
||||
*** 11414,11420 ****
|
||||
esac
|
||||
fi
|
||||
|
||||
! if test -z "$VERSION_SCRIPT_FLAGS"; then
|
||||
USE_VERSION_SCRIPT_TRUE=
|
||||
USE_VERSION_SCRIPT_FALSE='#'
|
||||
else
|
||||
--- 11416,11422 ----
|
||||
esac
|
||||
fi
|
||||
|
||||
! if test -n "$VERSION_SCRIPT_FLAGS"; then
|
||||
USE_VERSION_SCRIPT_TRUE=
|
||||
USE_VERSION_SCRIPT_FALSE='#'
|
||||
else
|
17
libxml2.spec
17
libxml2.spec
@ -1,16 +1,14 @@
|
||||
Summary: Library providing XML and HTML support
|
||||
Name: libxml2
|
||||
Version: 2.7.8
|
||||
Release: 7%{?dist}%{?extra_release}
|
||||
Version: 2.8.0
|
||||
Release: 1%{?dist}%{?extra_release}
|
||||
License: MIT
|
||||
Group: Development/Libraries
|
||||
Source: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: python python-devel zlib-devel pkgconfig
|
||||
BuildRequires: python python-devel zlib-devel pkgconfig xz-devel
|
||||
URL: http://xmlsoft.org/
|
||||
Patch0: libxml2-multilib.patch
|
||||
Patch1: libxml2-2.7.8-reactivate-versionning-script.patch
|
||||
Patch2: libxml2-2.7.7-xpath-double-free.patch
|
||||
|
||||
%description
|
||||
This library allows to manipulate XML files. It includes support
|
||||
@ -28,6 +26,7 @@ Summary: Libraries, includes, etc. to develop XML and HTML applications
|
||||
Group: Development/Libraries
|
||||
Requires: libxml2 = %{version}-%{release}
|
||||
Requires: zlib-devel
|
||||
Requires: xz-devel
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
@ -69,8 +68,6 @@ at parse time or later once the document has been modified.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -111,6 +108,7 @@ rm -fr %{buildroot}
|
||||
%defattr(-, root, root)
|
||||
|
||||
%doc %{_mandir}/man1/xml2-config.1*
|
||||
%doc AUTHORS ChangeLog.gz NEWS README Copyright
|
||||
%doc doc/*.html doc/html doc/*.gif doc/*.png
|
||||
%doc doc/tutorial doc/libxml2-api.xml.gz
|
||||
%doc doc/examples
|
||||
@ -145,6 +143,11 @@ rm -fr %{buildroot}
|
||||
%doc doc/python.html
|
||||
|
||||
%changelog
|
||||
* Wed May 23 2012 Daniel Veillard <veillard@redhat.com> - 2.8.0-1
|
||||
- upstream release of 2.8.0
|
||||
- add lzma compression support
|
||||
- many bug fixes and small improvements
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.8-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user