libxml2/libxml2-2.7.8-reactivate-versionning-script.patch
2010-11-05 09:36:03 +01:00

59 lines
1.5 KiB
Diff

diff --git a/configure.in b/configure.in
index 59d0629..39b66dd 100644
--- a/configure.in
+++ b/configure.in
@@ -75,6 +75,8 @@ dnl if the system support linker version scripts for symbol versioning
dnl then add it
dnl
VERSION_SCRIPT_FLAGS=
+echo host $host
+echo lt_cv_prog_gnu_ld $lt_cv_prog_gnu_ld
# lt_cv_prog_gnu_ld is from libtool 2.+
if test "$lt_cv_prog_gnu_ld" = yes; then
VERSION_SCRIPT_FLAGS=-Wl,--version-script=
@@ -82,9 +84,12 @@ else
case $host in
*-*-sunos*) VERSION_SCRIPT_FLAGS="-Wl,-M -Wl,";;
esac
+ case $host in
+ *-*-linux*) VERSION_SCRIPT_FLAGS="-Wl,--version-script=";;
+ esac
fi
AC_SUBST(VERSION_SCRIPT_FLAGS)
-AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -z "$VERSION_SCRIPT_FLAGS"])
+AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -n "$VERSION_SCRIPT_FLAGS"])
dnl
dnl We process the AC_ARG_WITH first so that later we can modify
diff --git a/configure.in b/configure.in
*** a/configure
--- b/configure
*************** CC="$lt_save_CC"
*** 11405,11410 ****
--- 11405,11412 ----
VERSION_SCRIPT_FLAGS=
+ echo host $host
+ echo lt_cv_prog_gnu_ld $lt_cv_prog_gnu_ld
# lt_cv_prog_gnu_ld is from libtool 2.+
if test "$lt_cv_prog_gnu_ld" = yes; then
VERSION_SCRIPT_FLAGS=-Wl,--version-script=
*************** else
*** 11414,11420 ****
esac
fi
! if test -z "$VERSION_SCRIPT_FLAGS"; then
USE_VERSION_SCRIPT_TRUE=
USE_VERSION_SCRIPT_FALSE='#'
else
--- 11416,11422 ----
esac
fi
! if test -n "$VERSION_SCRIPT_FLAGS"; then
USE_VERSION_SCRIPT_TRUE=
USE_VERSION_SCRIPT_FALSE='#'
else