52 lines
1.7 KiB
Diff
52 lines
1.7 KiB
Diff
This patch is generated from running autogen.sh after applying
|
|
the upstream patch to configure.in (see libxklaver-2.1-xkb-path.patch)
|
|
and then removing the portions which are not relevant. These include
|
|
changes to whitespace, quoting, line numbers, etc.
|
|
|
|
diff -u config.h.in.xkb-path-autogen config.h.in
|
|
--- config.h.in.xkb-path-autogen 2005-12-27 13:21:11.000000000 -0400
|
|
+++ config.h.in 2005-12-27 18:02:40.000000000 -0400
|
|
@@ -75,6 +75,9 @@
|
|
/* Base for XKB configuration */
|
|
#undef XKB_BASE
|
|
|
|
+/* Base for XKB executables */
|
|
+#undef XKB_BIN_BASE
|
|
+
|
|
/* Default XKB set of rules */
|
|
#undef XKB_DEFAULT_RULESET
|
|
|
|
diff -u configure.xkb-path-autogen configure
|
|
--- configure.xkb-path-autogen 2005-12-27 13:21:11.000000000 -0400
|
|
+++ configure 2005-12-27 18:02:41.000000000 -0400
|
|
@@ -1068,6 +1068,7 @@
|
|
--without-libiconv-prefix don't search for libiconv in includedir and libdir
|
|
--with-x use the X Window System
|
|
--with-xkb-base=DIR XKB base path (by default it is /usr/X11R6/lib/X11/xkb)
|
|
+ --with-xkb-bin-base=DIR XKB executables base path
|
|
--with-xkb-default-ruleset=RULES XKB default set of rules (by default it is base)
|
|
--with-xmodmap-base=DIR xmodmap base path (by default it is /usr/share/xmodmap)
|
|
|
|
@@ -20693,6 +20744,21 @@
|
|
|
|
|
|
|
|
+# Check whether --with-xkb_bin_base or --without-xkb_bin_base was given.
|
|
+if test "${with_xkb_bin_base+set}" = set; then
|
|
+ withval="$with_xkb_bin_base"
|
|
+ xkb_bin_base="$withval"
|
|
+else
|
|
+ xkb_bin_base="$xkb_base"
|
|
+fi;
|
|
+
|
|
+
|
|
+cat >>confdefs.h <<_ACEOF
|
|
+#define XKB_BIN_BASE "${xkb_bin_base}"
|
|
+_ACEOF
|
|
+
|
|
+
|
|
+
|
|
# Check whether --with-xkb_default_ruleset or --without-xkb_default_ruleset was given.
|
|
if test "${with_xkb_default_ruleset+set}" = set; then
|
|
withval="$with_xkb_default_ruleset"
|