- Pull in latest version and get rid of the annoying XKB error dialog
This commit is contained in:
parent
76c6d2bf6b
commit
0119bf1898
@ -1,3 +1,4 @@
|
||||
libxklavier-1.02.tar.gz
|
||||
libxklavier-1.14.tar.gz
|
||||
libxklavier-2.0.tar.gz
|
||||
libxklavier-2.1.tar.gz
|
||||
|
51
libxklavier-2.1-xkb-path-autogen.patch
Normal file
51
libxklavier-2.1-xkb-path-autogen.patch
Normal file
@ -0,0 +1,51 @@
|
||||
This patch is generated from running autogen.sh after applying
|
||||
the upstream patch to configure.in (see libxklaver-2.1-xkb-path.patch)
|
||||
and then removing the portions which are not relevant. These include
|
||||
changes to whitespace, quoting, line numbers, etc.
|
||||
|
||||
diff -u config.h.in.xkb-path-autogen config.h.in
|
||||
--- config.h.in.xkb-path-autogen 2005-12-27 13:21:11.000000000 -0400
|
||||
+++ config.h.in 2005-12-27 18:02:40.000000000 -0400
|
||||
@@ -75,6 +75,9 @@
|
||||
/* Base for XKB configuration */
|
||||
#undef XKB_BASE
|
||||
|
||||
+/* Base for XKB executables */
|
||||
+#undef XKB_BIN_BASE
|
||||
+
|
||||
/* Default XKB set of rules */
|
||||
#undef XKB_DEFAULT_RULESET
|
||||
|
||||
diff -u configure.xkb-path-autogen configure
|
||||
--- configure.xkb-path-autogen 2005-12-27 13:21:11.000000000 -0400
|
||||
+++ configure 2005-12-27 18:02:41.000000000 -0400
|
||||
@@ -1068,6 +1068,7 @@
|
||||
--without-libiconv-prefix don't search for libiconv in includedir and libdir
|
||||
--with-x use the X Window System
|
||||
--with-xkb-base=DIR XKB base path (by default it is /usr/X11R6/lib/X11/xkb)
|
||||
+ --with-xkb-bin-base=DIR XKB executables base path
|
||||
--with-xkb-default-ruleset=RULES XKB default set of rules (by default it is base)
|
||||
--with-xmodmap-base=DIR xmodmap base path (by default it is /usr/share/xmodmap)
|
||||
|
||||
@@ -20693,6 +20744,21 @@
|
||||
|
||||
|
||||
|
||||
+# Check whether --with-xkb_bin_base or --without-xkb_bin_base was given.
|
||||
+if test "${with_xkb_bin_base+set}" = set; then
|
||||
+ withval="$with_xkb_bin_base"
|
||||
+ xkb_bin_base="$withval"
|
||||
+else
|
||||
+ xkb_bin_base="$xkb_base"
|
||||
+fi;
|
||||
+
|
||||
+
|
||||
+cat >>confdefs.h <<_ACEOF
|
||||
+#define XKB_BIN_BASE "${xkb_bin_base}"
|
||||
+_ACEOF
|
||||
+
|
||||
+
|
||||
+
|
||||
# Check whether --with-xkb_default_ruleset or --without-xkb_default_ruleset was given.
|
||||
if test "${with_xkb_default_ruleset+set}" = set; then
|
||||
withval="$with_xkb_default_ruleset"
|
60
libxklavier-2.1-xkb-path.patch
Normal file
60
libxklavier-2.1-xkb-path.patch
Normal file
@ -0,0 +1,60 @@
|
||||
Index: configure.in
|
||||
===================================================================
|
||||
RCS file: /cvs/xklavier/libxklavier/configure.in,v
|
||||
retrieving revision 1.26
|
||||
retrieving revision 1.27
|
||||
diff -d -u -p -r1.26 -r1.27
|
||||
--- configure.in 11 Dec 2005 02:51:19 -0000 1.26
|
||||
+++ configure.in 26 Dec 2005 18:55:32 -0000 1.27
|
||||
@@ -57,9 +57,16 @@ AC_ARG_WITH( xkb_base,
|
||||
[ --with-xkb-base=DIR XKB base path (by default it is /usr/X11R6/lib/X11/xkb)],
|
||||
xkb_base="$withval",
|
||||
xkb_base="$x_libraries/X11/xkb" )
|
||||
-
|
||||
+
|
||||
AC_DEFINE_UNQUOTED(XKB_BASE,"${xkb_base}",Base for XKB configuration)
|
||||
|
||||
+AC_ARG_WITH( xkb_bin_base,
|
||||
+ [ --with-xkb-bin-base=DIR XKB executables base path],
|
||||
+ xkb_bin_base="$withval",
|
||||
+ xkb_bin_base="$xkb_base" )
|
||||
+
|
||||
+AC_DEFINE_UNQUOTED(XKB_BIN_BASE,"${xkb_bin_base}",Base for XKB executables)
|
||||
+
|
||||
AC_ARG_WITH( xkb_default_ruleset,
|
||||
[ --with-xkb-default-ruleset=RULES XKB default set of rules (by default it is base)],
|
||||
xkb_default_ruleset="$withval",
|
||||
Index: libxklavier/xklavier_config_xkb.c
|
||||
===================================================================
|
||||
RCS file: /cvs/xklavier/libxklavier/libxklavier/xklavier_config_xkb.c,v
|
||||
retrieving revision 1.30
|
||||
retrieving revision 1.31
|
||||
diff -d -u -p -r1.30 -r1.31
|
||||
--- libxklavier/xklavier_config_xkb.c 3 Dec 2005 13:31:58 -0000 1.30
|
||||
+++ libxklavier/xklavier_config_xkb.c 26 Dec 2005 18:55:32 -0000 1.31
|
||||
@@ -24,7 +24,7 @@
|
||||
/* For "bad" X servers we hold our own copy */
|
||||
#define XML_CFG_FALLBACK_PATH ( DATA_DIR "/xfree86.xml" )
|
||||
|
||||
-#define XKBCOMP ( XKB_BASE "/xkbcomp" )
|
||||
+#define XKBCOMP ( XKB_BIN_BASE "/xkbcomp" )
|
||||
|
||||
#define XK_XKB_KEYS
|
||||
#include <X11/keysymdef.h>
|
||||
Index: ChangeLog
|
||||
===================================================================
|
||||
RCS file: /cvs/xklavier/libxklavier/ChangeLog,v
|
||||
retrieving revision 1.31
|
||||
retrieving revision 1.32
|
||||
diff -d -u -p -r1.31 -r1.32
|
||||
--- ChangeLog 11 Dec 2005 02:51:19 -0000 1.31
|
||||
+++ ChangeLog 26 Dec 2005 18:55:32 -0000 1.32
|
||||
@@ -1,3 +1,8 @@
|
||||
+2005-12-26 svu
|
||||
+
|
||||
+ * configure.in, libxklavier/xklavier_config_xkb.c: adding XKB_BIN_BASE,
|
||||
+ closing https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174361
|
||||
+
|
||||
2005-12-10 svu
|
||||
|
||||
* NEWS: update for 2.1
|
@ -1,7 +1,7 @@
|
||||
Summary: library providing high-level API for X Keyboard Extension
|
||||
Name: libxklavier
|
||||
Version: 2.0
|
||||
Release: 3.1
|
||||
Version: 2.1
|
||||
Release: 2
|
||||
License: LGPL
|
||||
Group: Development/Libraries
|
||||
Url: http://gswitchit.sourceforge.net/
|
||||
@ -10,6 +10,8 @@ Source: http://gswitchit.sourceforge.net/%{name}-%{version}.tar.gz
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
Patch0: libxklavier-1.14-werror.patch
|
||||
Patch1: libxklavier-2.1-xkb-path.patch
|
||||
Patch2: libxklavier-2.1-xkb-path-autogen.patch
|
||||
|
||||
%description
|
||||
libxklavier is a library providing high-level API for X Keyboard Extension
|
||||
@ -28,10 +30,11 @@ Libraries, include files, etc you can use to develop libxklavier applications.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .werror
|
||||
|
||||
%patch1 -p0 -b .xkb-path
|
||||
%patch2 -p0 -b .xkb-path-autogen
|
||||
%build
|
||||
|
||||
%configure --enable-doxygen
|
||||
%configure --enable-doxygen --with-xkb-base='%{_datadir}/X11/xkb' --with-xkb-bin-base='%{_bindir}'
|
||||
make
|
||||
|
||||
%install
|
||||
@ -65,6 +68,9 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 27 2005 Christopher Aillon <caillon@redhat.com> 2.1-2
|
||||
- Pull in latest version and get rid of the annoying XKB error dialog
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user