64 lines
2.2 KiB
Diff
64 lines
2.2 KiB
Diff
From 77bbad4d3aafc20bf8532de2f6215bb8bb4a02a5 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
|
|
Date: Fri, 13 Jul 2018 21:58:02 +0200
|
|
Subject: [PATCH] Makefile: Fix warnings from automake
|
|
|
|
---
|
|
Makefile.am | 22 ++++++++++++++++------
|
|
1 file changed, 16 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 8605ce7..f5e8df4 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -37,9 +37,11 @@ libcrypt_la_SOURCES = \
|
|
|
|
pkgconfig_DATA = libxcrypt.pc
|
|
# Install libcrypt.pc symlink to libxcrypt.pc file.
|
|
-.PHONY: install-data-hook-pkgconfig uninstall-hook-pkgconfig
|
|
+phony_targets = \
|
|
+ install-data-hook-pkgconfig uninstall-hook-pkgconfig
|
|
install-data-hook: install-data-hook-pkgconfig
|
|
-uninstall-hook: uninstall-hook-pkgconfig
|
|
+uninstall_hook_targets = \
|
|
+ uninstall-hook-pkgconfig
|
|
install-data-hook-pkgconfig:
|
|
cd $(DESTDIR)$(pkgconfigdir) && \
|
|
$(LN_S) libxcrypt.pc libcrypt.pc
|
|
@@ -110,9 +112,11 @@ if ENABLE_COMPAT_SUSE
|
|
# shipped libowcrypt.so.1.)
|
|
if ENABLE_OBSOLETE_API
|
|
if ENABLE_STATIC
|
|
-.PHONY: install-exec-hook-libstatic uninstall-hook-libstatic
|
|
+phony_targets += \
|
|
+ install-exec-hook-libstatic uninstall-hook-libstatic
|
|
install-exec-hook: install-exec-hook-libstatic
|
|
-uninstall-hook: uninstall-hook-libstatic
|
|
+uninstall_hook_targets += \
|
|
+ uninstall-hook-libstatic
|
|
install-exec-hook-libstatic:
|
|
cd $(DESTDIR)$(libdir) && \
|
|
$(LN_S) libcrypt.a libowcrypt.a
|
|
@@ -120,9 +124,11 @@ uninstall-hook-libstatic:
|
|
-rm -f $(DESTDIR)$(libdir)/libowcrypt.a
|
|
endif
|
|
if ENABLE_SHARED
|
|
-.PHONY: install-exec-hook-libshared uninstall-hook-libshared
|
|
+phony_targets += \
|
|
+ install-exec-hook-libshared uninstall-hook-libshared
|
|
install-exec-hook: install-exec-hook-libshared
|
|
-uninstall-hook: uninstall-hook-libshared
|
|
+uninstall_hook_targets += \
|
|
+ uninstall-hook-libshared
|
|
install-exec-hook-libshared:
|
|
cd $(DESTDIR)$(libdir) && \
|
|
$(LN_S) libcrypt.so libowcrypt.so && \
|
|
@@ -215,3 +221,7 @@ endif
|
|
# will reveal the direct dependency) but a few don't.
|
|
$(libcrypt_la_OBJECTS): crypt-symbol-vers.h crypt-hashes.h
|
|
$(test_byteorder_OBJECTS): crypt-symbol-vers.h crypt-hashes.h
|
|
+
|
|
+# Add additional targets
|
|
+.PHONY: $(phony_targets)
|
|
+uninstall-hook: $(uninstall_hook_targets)
|