New upstream release

This commit is contained in:
Björn Esser 2018-07-13 20:59:08 +02:00
parent f81f022b3e
commit 7dfd4289c7
No known key found for this signature in database
GPG Key ID: F52E98007594C21D
5 changed files with 71 additions and 12913 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
/libxcrypt-4.0.0-20180120git3436e7b.tar.gz
/libxcrypt-4.0.0.tar.gz
/libxcrypt-4.0.1.tar.gz
/libxcrypt-4.1.0.tar.gz

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,63 @@
From 77bbad4d3aafc20bf8532de2f6215bb8bb4a02a5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Fri, 13 Jul 2018 21:58:02 +0200
Subject: [PATCH] Makefile: Fix warnings from automake
---
Makefile.am | 22 ++++++++++++++++------
1 file changed, 16 insertions(+), 6 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 8605ce7..f5e8df4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,9 +37,11 @@ libcrypt_la_SOURCES = \
pkgconfig_DATA = libxcrypt.pc
# Install libcrypt.pc symlink to libxcrypt.pc file.
-.PHONY: install-data-hook-pkgconfig uninstall-hook-pkgconfig
+phony_targets = \
+ install-data-hook-pkgconfig uninstall-hook-pkgconfig
install-data-hook: install-data-hook-pkgconfig
-uninstall-hook: uninstall-hook-pkgconfig
+uninstall_hook_targets = \
+ uninstall-hook-pkgconfig
install-data-hook-pkgconfig:
cd $(DESTDIR)$(pkgconfigdir) && \
$(LN_S) libxcrypt.pc libcrypt.pc
@@ -110,9 +112,11 @@ if ENABLE_COMPAT_SUSE
# shipped libowcrypt.so.1.)
if ENABLE_OBSOLETE_API
if ENABLE_STATIC
-.PHONY: install-exec-hook-libstatic uninstall-hook-libstatic
+phony_targets += \
+ install-exec-hook-libstatic uninstall-hook-libstatic
install-exec-hook: install-exec-hook-libstatic
-uninstall-hook: uninstall-hook-libstatic
+uninstall_hook_targets += \
+ uninstall-hook-libstatic
install-exec-hook-libstatic:
cd $(DESTDIR)$(libdir) && \
$(LN_S) libcrypt.a libowcrypt.a
@@ -120,9 +124,11 @@ uninstall-hook-libstatic:
-rm -f $(DESTDIR)$(libdir)/libowcrypt.a
endif
if ENABLE_SHARED
-.PHONY: install-exec-hook-libshared uninstall-hook-libshared
+phony_targets += \
+ install-exec-hook-libshared uninstall-hook-libshared
install-exec-hook: install-exec-hook-libshared
-uninstall-hook: uninstall-hook-libshared
+uninstall_hook_targets += \
+ uninstall-hook-libshared
install-exec-hook-libshared:
cd $(DESTDIR)$(libdir) && \
$(LN_S) libcrypt.so libowcrypt.so && \
@@ -215,3 +221,7 @@ endif
# will reveal the direct dependency) but a few don't.
$(libcrypt_la_OBJECTS): crypt-symbol-vers.h crypt-hashes.h
$(test_byteorder_OBJECTS): crypt-symbol-vers.h crypt-hashes.h
+
+# Add additional targets
+.PHONY: $(phony_targets)
+uninstall-hook: $(uninstall_hook_targets)

View File

@ -18,8 +18,8 @@
Name: libxcrypt
Version: 4.0.1
Release: 6%{?dist}
Version: 4.1.0
Release: 1%{?dist}
Summary: Extended crypt library for DES, MD5, Blowfish and others
# For explicit license breakdown, see the
@ -28,7 +28,7 @@ License: LGPLv2+ and BSD and Public Domain
URL: https://github.com/besser82/%{name}
Source0: %{url}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
Patch1: %{url}/compare/v4.0.1...develop.patch#/%{name}-4.0.1_to_develop.patch
Patch0: %{url}/commit/77bbad4.patch#/%{name}-4.1.0_fix_automake.patch
BuildRequires: fipscheck
BuildRequires: libtool
@ -177,6 +177,9 @@ is highly discouraged.
%changelog
* Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.0-1
- New upstream release
* Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-6
- Make testsuite fail on error again
- Update patch0 with more upstream fixes

View File

@ -1 +1 @@
SHA512 (libxcrypt-4.0.1.tar.gz) = d23503a61a89f23e78347314f400dcaac05d17ec35d9233c09dc5b6019d337c15655d288347eb44af168c16a32f72ec66147a24e067c2a025693cdfb30a908b1
SHA512 (libxcrypt-4.1.0.tar.gz) = a4b0b0fb683df91a01b475ab0b2625d3c5d34c296885b7b23cffb412afb734933f9b314729853e4c58c68934b1c411a27388edf0055f019c9aeef8f1512fb9a6