libwebp/libwebp-freeglut.patch
2022-07-20 12:25:26 +02:00

35 lines
1.3 KiB
Diff

diff -rupN --no-dereference libwebp-1.2.3/CMakeLists.txt libwebp-1.2.3-new/CMakeLists.txt
--- libwebp-1.2.3/CMakeLists.txt 2022-07-15 21:48:16.000000000 +0200
+++ libwebp-1.2.3-new/CMakeLists.txt 2022-07-20 12:24:07.196022397 +0200
@@ -558,15 +558,15 @@ endif()
if(WEBP_BUILD_VWEBP)
# vwebp
- find_package(GLUT)
- if(GLUT_FOUND)
+ find_package(FreeGLUT)
+ if(FreeGLUT_FOUND)
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
add_executable(vwebp ${VWEBP_SRCS})
target_link_libraries(vwebp
${OPENGL_LIBRARIES}
exampleutil
- ${GLUT_glut_LIBRARY}
+ glut
imageioutil
webp
webpdemux)
diff -rupN --no-dereference libwebp-1.2.3/examples/vwebp.c libwebp-1.2.3-new/examples/vwebp.c
--- libwebp-1.2.3/examples/vwebp.c 2022-07-15 21:48:16.000000000 +0200
+++ libwebp-1.2.3-new/examples/vwebp.c 2022-07-20 12:24:07.196022397 +0200
@@ -27,7 +27,7 @@
#if defined(HAVE_GLUT_GLUT_H)
#include <GLUT/glut.h>
#else
-#include <GL/glut.h>
+#include <GL/freeglut.h>
#ifdef FREEGLUT
#include <GL/freeglut.h>
#endif