Update to 1.3.0
This commit is contained in:
parent
ec81636d7e
commit
b17145db5c
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@
|
|||||||
/libwebp-1.2.2.tar.gz
|
/libwebp-1.2.2.tar.gz
|
||||||
/libwebp-1.2.3.tar.gz
|
/libwebp-1.2.3.tar.gz
|
||||||
/libwebp-1.2.4.tar.gz
|
/libwebp-1.2.4.tar.gz
|
||||||
|
/libwebp-1.3.0.tar.gz
|
||||||
|
@ -1,12 +1,27 @@
|
|||||||
diff -rupN --no-dereference libwebp-1.2.4/CMakeLists.txt libwebp-1.2.4-new/CMakeLists.txt
|
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMakeLists.txt
|
||||||
--- libwebp-1.2.4/CMakeLists.txt 2022-08-07 11:33:19.069010628 +0200
|
--- libwebp-1.3.0/CMakeLists.txt 2023-01-13 13:06:13.623139692 +0100
|
||||||
+++ libwebp-1.2.4-new/CMakeLists.txt 2022-08-07 11:33:19.073010628 +0200
|
+++ libwebp-1.3.0-new/CMakeLists.txt 2023-01-13 13:06:13.627139720 +0100
|
||||||
@@ -726,7 +726,7 @@ install(TARGETS ${INSTALLED_LIBRARIES}
|
@@ -716,7 +716,7 @@ install(
|
||||||
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
|
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
|
||||||
-set(ConfigPackageLocation ${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake/)
|
-set(ConfigPackageLocation ${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake/)
|
||||||
+set(ConfigPackageLocation ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/)
|
+set(ConfigPackageLocation ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/)
|
||||||
install(EXPORT ${PROJECT_NAME}Targets
|
install(EXPORT ${PROJECT_NAME}Targets NAMESPACE ${PROJECT_NAME}::
|
||||||
NAMESPACE ${PROJECT_NAME}::
|
|
||||||
DESTINATION ${ConfigPackageLocation})
|
DESTINATION ${ConfigPackageLocation})
|
||||||
|
|
||||||
|
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt.rej libwebp-1.3.0-new/CMakeLists.txt.rej
|
||||||
|
--- libwebp-1.3.0/CMakeLists.txt.rej 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ libwebp-1.3.0-new/CMakeLists.txt.rej 2023-01-13 13:06:13.627139720 +0100
|
||||||
|
@@ -0,0 +1,11 @@
|
||||||
|
+--- CMakeLists.txt 2022-08-07 11:33:19.069010628 +0200
|
||||||
|
++++ CMakeLists.txt 2022-08-07 11:33:19.073010628 +0200
|
||||||
|
+@@ -726,7 +726,7 @@ install(TARGETS ${INSTALLED_LIBRARIES}
|
||||||
|
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
|
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
|
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
|
||||||
|
+-set(ConfigPackageLocation ${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake/)
|
||||||
|
++set(ConfigPackageLocation ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/)
|
||||||
|
+ install(EXPORT ${PROJECT_NAME}Targets
|
||||||
|
+ NAMESPACE ${PROJECT_NAME}::
|
||||||
|
+ DESTINATION ${ConfigPackageLocation})
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN --no-dereference libwebp-1.2.4/CMakeLists.txt libwebp-1.2.4-new/CMakeLists.txt
|
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMakeLists.txt
|
||||||
--- libwebp-1.2.4/CMakeLists.txt 2022-08-06 01:49:26.000000000 +0200
|
--- libwebp-1.3.0/CMakeLists.txt 2022-12-20 01:23:35.000000000 +0100
|
||||||
+++ libwebp-1.2.4-new/CMakeLists.txt 2022-08-07 11:33:19.006010626 +0200
|
+++ libwebp-1.3.0-new/CMakeLists.txt 2023-01-13 13:06:13.548139166 +0100
|
||||||
@@ -559,15 +559,15 @@ endif()
|
@@ -552,8 +552,8 @@ endif()
|
||||||
|
|
||||||
if(WEBP_BUILD_VWEBP)
|
if(WEBP_BUILD_VWEBP)
|
||||||
# vwebp
|
# vwebp
|
||||||
@ -12,17 +12,18 @@ diff -rupN --no-dereference libwebp-1.2.4/CMakeLists.txt libwebp-1.2.4-new/CMake
|
|||||||
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
|
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
|
||||||
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
|
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
|
||||||
add_executable(vwebp ${VWEBP_SRCS})
|
add_executable(vwebp ${VWEBP_SRCS})
|
||||||
target_link_libraries(vwebp
|
@@ -561,7 +561,7 @@ if(WEBP_BUILD_VWEBP)
|
||||||
${OPENGL_LIBRARIES}
|
vwebp
|
||||||
exampleutil
|
${OPENGL_LIBRARIES}
|
||||||
- ${GLUT_glut_LIBRARY}
|
exampleutil
|
||||||
+ glut
|
- GLUT::GLUT
|
||||||
imageioutil
|
+ glut
|
||||||
webp
|
imageioutil
|
||||||
webpdemux)
|
webp
|
||||||
diff -rupN --no-dereference libwebp-1.2.4/examples/vwebp.c libwebp-1.2.4-new/examples/vwebp.c
|
webpdemux)
|
||||||
--- libwebp-1.2.4/examples/vwebp.c 2022-08-06 01:49:26.000000000 +0200
|
diff -rupN --no-dereference libwebp-1.3.0/examples/vwebp.c libwebp-1.3.0-new/examples/vwebp.c
|
||||||
+++ libwebp-1.2.4-new/examples/vwebp.c 2022-08-07 11:33:19.007010626 +0200
|
--- libwebp-1.3.0/examples/vwebp.c 2022-12-20 01:23:35.000000000 +0100
|
||||||
|
+++ libwebp-1.3.0-new/examples/vwebp.c 2023-01-13 13:06:13.548139166 +0100
|
||||||
@@ -27,7 +27,7 @@
|
@@ -27,7 +27,7 @@
|
||||||
#if defined(HAVE_GLUT_GLUT_H)
|
#if defined(HAVE_GLUT_GLUT_H)
|
||||||
#include <GLUT/glut.h>
|
#include <GLUT/glut.h>
|
||||||
|
@ -1,13 +1,13 @@
|
|||||||
diff -rupN --no-dereference libwebp-1.2.4/CMakeLists.txt libwebp-1.2.4-new/CMakeLists.txt
|
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMakeLists.txt
|
||||||
--- libwebp-1.2.4/CMakeLists.txt 2022-08-07 11:33:19.037010627 +0200
|
--- libwebp-1.3.0/CMakeLists.txt 2023-01-13 13:06:13.583139412 +0100
|
||||||
+++ libwebp-1.2.4-new/CMakeLists.txt 2022-08-07 11:33:19.041010627 +0200
|
+++ libwebp-1.3.0-new/CMakeLists.txt 2023-01-13 13:06:13.588139447 +0100
|
||||||
@@ -396,6 +396,9 @@ macro(set_version FILE TARGET_NAME NAME_
|
@@ -275,6 +275,9 @@ macro(set_version FILE TARGET_NAME NAME_
|
||||||
${LT_CURRENT_MINUS_AGE}.${LT_AGE}.${LT_REVISION}
|
MACHO_CURRENT_VERSION
|
||||||
SOVERSION
|
${LIBWEBP_MACHO_COMPATIBILITY_VERSION}.${LT_REVISION})
|
||||||
${LT_CURRENT_MINUS_AGE})
|
endif()
|
||||||
+ if(WIN32)
|
+ if(WIN32)
|
||||||
+ set_target_properties(${TARGET_NAME} PROPERTIES SUFFIX "-${LT_CURRENT_MINUS_AGE}${CMAKE_SHARED_LIBRARY_SUFFIX}")
|
+ set_target_properties(${TARGET_NAME} PROPERTIES SUFFIX "-${LT_CURRENT_MINUS_AGE}${CMAKE_SHARED_LIBRARY_SUFFIX}")
|
||||||
+ endif(WIN32)
|
+ endif(WIN32)
|
||||||
endmacro()
|
endmacro()
|
||||||
set_version(Makefile.am webp webp)
|
|
||||||
set_version(Makefile.am webpdecoder webpdecoder)
|
# ##############################################################################
|
||||||
|
18
libwebp-rpath.patch
Normal file
18
libwebp-rpath.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMakeLists.txt
|
||||||
|
--- libwebp-1.3.0/CMakeLists.txt 2023-01-13 13:06:13.664139980 +0100
|
||||||
|
+++ libwebp-1.3.0-new/CMakeLists.txt 2023-01-13 13:06:13.669140015 +0100
|
||||||
|
@@ -101,11 +101,11 @@ endif()
|
||||||
|
include(cmake/deps.cmake)
|
||||||
|
include(GNUInstallDirs)
|
||||||
|
|
||||||
|
-if(BUILD_SHARED_LIBS AND NOT CMAKE_INSTALL_RPATH)
|
||||||
|
+#if(BUILD_SHARED_LIBS AND NOT CMAKE_INSTALL_RPATH)
|
||||||
|
# Set the rpath to match autoconf/libtool behavior. Note this must be set
|
||||||
|
# before target creation.
|
||||||
|
- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
|
||||||
|
-endif()
|
||||||
|
+ # set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
|
||||||
|
+#endif()
|
||||||
|
|
||||||
|
# ##############################################################################
|
||||||
|
# Options.
|
25
libwebp.spec
25
libwebp.spec
@ -7,8 +7,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: libwebp
|
Name: libwebp
|
||||||
Version: 1.2.4
|
Version: 1.3.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://webmproject.org/
|
URL: http://webmproject.org/
|
||||||
Summary: Library and tools for the WebP graphics format
|
Summary: Library and tools for the WebP graphics format
|
||||||
# Additional IPR is licensed as well. See PATENTS file for details
|
# Additional IPR is licensed as well. See PATENTS file for details
|
||||||
@ -21,8 +21,8 @@ Patch0: libwebp-freeglut.patch
|
|||||||
Patch1: libwebp-mingw-libsuffix.patch
|
Patch1: libwebp-mingw-libsuffix.patch
|
||||||
# Fix cmake module install location
|
# Fix cmake module install location
|
||||||
Patch2: libwebp-cmakedir.patch
|
Patch2: libwebp-cmakedir.patch
|
||||||
# Honour libsuffix in libdir set in pkgconfig files
|
# Kill rpath
|
||||||
Patch3: libwebp_libsuffix.patch
|
Patch3: libwebp-rpath.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: freeglut-devel
|
BuildRequires: freeglut-devel
|
||||||
@ -183,14 +183,20 @@ cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
|
|||||||
%{_libdir}/%{name}decoder.so.3*
|
%{_libdir}/%{name}decoder.so.3*
|
||||||
%{_libdir}/%{name}demux.so.2*
|
%{_libdir}/%{name}demux.so.2*
|
||||||
%{_libdir}/%{name}mux.so.3*
|
%{_libdir}/%{name}mux.so.3*
|
||||||
|
%{_libdir}/libsharpyuv.so.0*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/%{name}*.so
|
%{_libdir}/%{name}.so
|
||||||
|
%{_libdir}/%{name}decoder.so
|
||||||
|
%{_libdir}/%{name}demux.so
|
||||||
|
%{_libdir}/%{name}mux.so
|
||||||
|
%{_libdir}/libsharpyuv.so
|
||||||
%{_includedir}/webp/
|
%{_includedir}/webp/
|
||||||
%{_libdir}/pkgconfig/libwebp.pc
|
%{_libdir}/pkgconfig/libwebp.pc
|
||||||
%{_libdir}/pkgconfig/libwebpdecoder.pc
|
%{_libdir}/pkgconfig/libwebpdecoder.pc
|
||||||
%{_libdir}/pkgconfig/libwebpdemux.pc
|
%{_libdir}/pkgconfig/libwebpdemux.pc
|
||||||
%{_libdir}/pkgconfig/libwebpmux.pc
|
%{_libdir}/pkgconfig/libwebpmux.pc
|
||||||
|
%{_libdir}/pkgconfig/libsharpyuv.pc
|
||||||
%{_libdir}/cmake/WebP/
|
%{_libdir}/cmake/WebP/
|
||||||
|
|
||||||
%files tools
|
%files tools
|
||||||
@ -221,16 +227,19 @@ cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
|
|||||||
%{mingw32_bindir}/libwebpdecoder-3.dll
|
%{mingw32_bindir}/libwebpdecoder-3.dll
|
||||||
%{mingw32_bindir}/libwebpdemux-2.dll
|
%{mingw32_bindir}/libwebpdemux-2.dll
|
||||||
%{mingw32_bindir}/libwebpmux-3.dll
|
%{mingw32_bindir}/libwebpmux-3.dll
|
||||||
|
%{mingw32_bindir}/libsharpyuv-0.dll
|
||||||
%{mingw32_includedir}/webp/
|
%{mingw32_includedir}/webp/
|
||||||
%{mingw32_libdir}/pkgconfig/libwebp.pc
|
%{mingw32_libdir}/pkgconfig/libwebp.pc
|
||||||
%{mingw32_libdir}/pkgconfig/libwebpdecoder.pc
|
%{mingw32_libdir}/pkgconfig/libwebpdecoder.pc
|
||||||
%{mingw32_libdir}/pkgconfig/libwebpdemux.pc
|
%{mingw32_libdir}/pkgconfig/libwebpdemux.pc
|
||||||
%{mingw32_libdir}/pkgconfig/libwebpmux.pc
|
%{mingw32_libdir}/pkgconfig/libwebpmux.pc
|
||||||
|
%{mingw32_libdir}/pkgconfig/libsharpyuv.pc
|
||||||
%{mingw32_libdir}/cmake/WebP/
|
%{mingw32_libdir}/cmake/WebP/
|
||||||
%{mingw32_libdir}/libwebp.dll.a
|
%{mingw32_libdir}/libwebp.dll.a
|
||||||
%{mingw32_libdir}/libwebpdecoder.dll.a
|
%{mingw32_libdir}/libwebpdecoder.dll.a
|
||||||
%{mingw32_libdir}/libwebpdemux.dll.a
|
%{mingw32_libdir}/libwebpdemux.dll.a
|
||||||
%{mingw32_libdir}/libwebpmux.dll.a
|
%{mingw32_libdir}/libwebpmux.dll.a
|
||||||
|
%{mingw32_libdir}/libsharpyuv.dll.a
|
||||||
|
|
||||||
%files -n mingw64-libwebp
|
%files -n mingw64-libwebp
|
||||||
%license PATENTS COPYING
|
%license PATENTS COPYING
|
||||||
@ -244,19 +253,25 @@ cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
|
|||||||
%{mingw64_bindir}/libwebpdecoder-3.dll
|
%{mingw64_bindir}/libwebpdecoder-3.dll
|
||||||
%{mingw64_bindir}/libwebpdemux-2.dll
|
%{mingw64_bindir}/libwebpdemux-2.dll
|
||||||
%{mingw64_bindir}/libwebpmux-3.dll
|
%{mingw64_bindir}/libwebpmux-3.dll
|
||||||
|
%{mingw64_bindir}/libsharpyuv-0.dll
|
||||||
%{mingw64_includedir}/webp/
|
%{mingw64_includedir}/webp/
|
||||||
%{mingw64_libdir}/pkgconfig/libwebp.pc
|
%{mingw64_libdir}/pkgconfig/libwebp.pc
|
||||||
%{mingw64_libdir}/pkgconfig/libwebpdecoder.pc
|
%{mingw64_libdir}/pkgconfig/libwebpdecoder.pc
|
||||||
%{mingw64_libdir}/pkgconfig/libwebpdemux.pc
|
%{mingw64_libdir}/pkgconfig/libwebpdemux.pc
|
||||||
%{mingw64_libdir}/pkgconfig/libwebpmux.pc
|
%{mingw64_libdir}/pkgconfig/libwebpmux.pc
|
||||||
|
%{mingw64_libdir}/pkgconfig/libsharpyuv.pc
|
||||||
%{mingw64_libdir}/cmake/WebP/
|
%{mingw64_libdir}/cmake/WebP/
|
||||||
%{mingw64_libdir}/libwebp.dll.a
|
%{mingw64_libdir}/libwebp.dll.a
|
||||||
%{mingw64_libdir}/libwebpdecoder.dll.a
|
%{mingw64_libdir}/libwebpdecoder.dll.a
|
||||||
%{mingw64_libdir}/libwebpdemux.dll.a
|
%{mingw64_libdir}/libwebpdemux.dll.a
|
||||||
%{mingw64_libdir}/libwebpmux.dll.a
|
%{mingw64_libdir}/libwebpmux.dll.a
|
||||||
|
%{mingw64_libdir}/libsharpyuv.dll.a
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 13 2023 Sandro Mani <manisandro@gmail.com> - 1.3.0-1
|
||||||
|
- Update to 1.3.0
|
||||||
|
|
||||||
* Thu Sep 22 2022 Sandro Mani <manisandro@gmail.com> - 1.2.4-2
|
* Thu Sep 22 2022 Sandro Mani <manisandro@gmail.com> - 1.2.4-2
|
||||||
- Add libwebp_libsuffix.patch
|
- Add libwebp_libsuffix.patch
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libwebp-1.2.4.tar.gz) = 01f21e2c3057f5878b33664d0070832d78420de3cb2fe4379b07ae6a27bb569fd1c27a920fe324beccb96ae7bfa8c05fdd9e7b0aeba6de06ab4d8b084bb38803
|
SHA512 (libwebp-1.3.0.tar.gz) = 5af6999654e9ba3189574158c194396e3ad7b7d5061abf2711a7c93558a5898cd99adccd1c051e9a7910beb915fba8e703d33e7b6f06753b6f68c009c0e0d2bc
|
||||||
|
Loading…
Reference in New Issue
Block a user