Add libwebp_libsuffix.patch

This commit is contained in:
Sandro Mani 2022-09-22 13:23:25 +02:00
parent d2e20e34e0
commit ec81636d7e
2 changed files with 18 additions and 1 deletions

View File

@ -8,7 +8,7 @@
Name: libwebp
Version: 1.2.4
Release: 1%{?dist}
Release: 2%{?dist}
URL: http://webmproject.org/
Summary: Library and tools for the WebP graphics format
# Additional IPR is licensed as well. See PATENTS file for details
@ -21,6 +21,8 @@ Patch0: libwebp-freeglut.patch
Patch1: libwebp-mingw-libsuffix.patch
# Fix cmake module install location
Patch2: libwebp-cmakedir.patch
# Honour libsuffix in libdir set in pkgconfig files
Patch3: libwebp_libsuffix.patch
BuildRequires: cmake
BuildRequires: freeglut-devel
@ -255,6 +257,9 @@ cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
%changelog
* Thu Sep 22 2022 Sandro Mani <manisandro@gmail.com> - 1.2.4-2
- Add libwebp_libsuffix.patch
* Sun Aug 07 2022 Sandro Mani <manisandro@gmail.com> - 1.2.4-1
- Update to 1.2.4

12
libwebp_libsuffix.patch Normal file
View File

@ -0,0 +1,12 @@
diff -rupN libwebp-1.2.4/CMakeLists.txt libwebp-1.2.4-new/CMakeLists.txt
--- libwebp-1.2.4/CMakeLists.txt 2022-08-06 01:49:26.000000000 +0200
+++ libwebp-1.2.4-new/CMakeLists.txt 2022-09-22 12:56:18.542998584 +0200
@@ -112,7 +112,7 @@ endif()
set(prefix ${CMAKE_INSTALL_PREFIX})
set(exec_prefix "\$\{prefix\}")
-set(libdir "\$\{prefix\}/lib")
+set(libdir "\$\{prefix\}/lib${LIB_SUFFIX}")
set(includedir "\$\{prefix\}/include")
set(PTHREAD_LIBS ${CMAKE_THREAD_LIBS_INIT})
set(INSTALLED_LIBRARIES)