libvirt-python-6.9.0-1
Update to version 6.9.0
This commit is contained in:
parent
0f9904c901
commit
ee4203c85b
@ -1,33 +0,0 @@
|
|||||||
From 613411502d2cdf3541837710239409044a376b0a Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
|
||||||
Date: Tue, 6 Oct 2020 10:30:59 +0100
|
|
||||||
Subject: [PATCH] fix constructor param name for virDomainSnapshot /
|
|
||||||
virDomainCheckpoint
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Fixes 7f021c21d6a091ca33615852d6061e75b2500f3f
|
|
||||||
Resolves https://gitlab.com/libvirt/libvirt-python/-/issues/4
|
|
||||||
|
|
||||||
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
|
|
||||||
---
|
|
||||||
generator.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/generator.py b/generator.py
|
|
||||||
index 3eb997f..43183b4 100755
|
|
||||||
--- a/generator.py
|
|
||||||
+++ b/generator.py
|
|
||||||
@@ -1482,7 +1482,7 @@ def buildWrappers(module: str) -> None:
|
|
||||||
classes.write(" def __init__(self, conn, _obj=None):\n")
|
|
||||||
classes.write(" self._conn = conn\n")
|
|
||||||
elif classname in ["virDomainCheckpoint", "virDomainSnapshot"]:
|
|
||||||
- classes.write(" def __init__(self, net, _obj=None):\n")
|
|
||||||
+ classes.write(" def __init__(self, dom, _obj=None):\n")
|
|
||||||
classes.write(" self._dom = dom\n")
|
|
||||||
classes.write(" self._conn = dom.connect()\n")
|
|
||||||
elif classname in ["virNetworkPort"]:
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -14,10 +14,9 @@
|
|||||||
|
|
||||||
Summary: The libvirt virtualization API python3 binding
|
Summary: The libvirt virtualization API python3 binding
|
||||||
Name: libvirt-python
|
Name: libvirt-python
|
||||||
Version: 6.8.0
|
Version: 6.9.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Source0: http://libvirt.org/sources/python/%{name}-%{version}.tar.gz
|
Source0: http://libvirt.org/sources/python/%{name}-%{version}.tar.gz
|
||||||
Patch1: 0001-fix-constructor-param-name-for-virDomainSnapshot-vir.patch
|
|
||||||
Url: http://libvirt.org
|
Url: http://libvirt.org
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
BuildRequires: libvirt-devel == %{version}
|
BuildRequires: libvirt-devel == %{version}
|
||||||
@ -57,7 +56,6 @@ of recent versions of Linux (and other OSes).
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# Unset execute bit for example scripts; it can introduce spurious
|
# Unset execute bit for example scripts; it can introduce spurious
|
||||||
# RPM dependencies, like /usr/bin/python3
|
# RPM dependencies, like /usr/bin/python3
|
||||||
@ -101,6 +99,9 @@ CFLAGS="$RPM_OPT_FLAGS" %{__python3} setup.py build
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 03 2020 Cole Robinson <crobinso@redhat.com> - 6.9.0-1
|
||||||
|
- Update to version 6.9.0
|
||||||
|
|
||||||
* Thu Oct 15 2020 Daniel P. Berrangé <berrange@redhat.com> - 6.8.0-2
|
* Thu Oct 15 2020 Daniel P. Berrangé <berrange@redhat.com> - 6.8.0-2
|
||||||
- Fix regression with snapshot handling (rhbz #1888709)
|
- Fix regression with snapshot handling (rhbz #1888709)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libvirt-python-6.8.0.tar.gz) = 6d2f82fafd414047cff16f0ad655fefd69c8c0da04be07d27da44e3ab17dd03e4e4ff102be1c30948c361268f57ea312978f9198fd128bfb54a3c1a07150e6af
|
SHA512 (libvirt-python-6.9.0.tar.gz) = d15a80de5418586f769101525464efc88154c9038f59c805030a60b4b711f11f15531f4e1fd01575e1646397342fefa38fca9371e8146157b61f607b3c286fe1
|
||||||
|
Loading…
Reference in New Issue
Block a user