Update to 3.3.0 release
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
This commit is contained in:
parent
0212090551
commit
2ffaf64438
@ -1,54 +0,0 @@
|
||||
From a99e9fe20ebce4fa208cc0f0599830facf1cc06c Mon Sep 17 00:00:00 2001
|
||||
From: "Daniel P. Berrange" <berrange@redhat.com>
|
||||
Date: Wed, 14 Dec 2016 10:58:52 +0000
|
||||
Subject: [PATCH] Fix running of nosetests on python 3
|
||||
|
||||
Previously the way Fedora installed /usr/bin/nosetests allowed it
|
||||
to be invoked with either python 2 or 3. Since Fedora 25 though,
|
||||
it contains a module name that only exists on python 2. So we need
|
||||
to be more intelligent and pick a different nosetests binary per
|
||||
version.
|
||||
|
||||
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
|
||||
---
|
||||
setup.py | 17 ++++++++++++++++-
|
||||
1 file changed, 16 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index bbcfe87..0d65763 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -277,6 +277,20 @@ class my_test(Command):
|
||||
self.build_platlib = os.path.join(self.build_base,
|
||||
'lib' + plat_specifier)
|
||||
|
||||
+ def find_nosetests_path(self):
|
||||
+ paths = [
|
||||
+ "/usr/bin/nosetests-%d.%d" % (sys.version_info[0],
|
||||
+ sys.version_info[1]),
|
||||
+ "/usr/bin/nosetests-%d" % (sys.version_info[0]),
|
||||
+ "/usr/bin/nosetests",
|
||||
+ ]
|
||||
+
|
||||
+ for path in paths:
|
||||
+ if os.path.exists(path):
|
||||
+ return path
|
||||
+
|
||||
+ raise Exception("Cannot find any nosetests binary")
|
||||
+
|
||||
def run(self):
|
||||
"""
|
||||
Run test suite
|
||||
@@ -289,7 +303,8 @@ class my_test(Command):
|
||||
else:
|
||||
os.environ["PYTHONPATH"] = self.build_platlib
|
||||
self.spawn([sys.executable, "sanitytest.py", self.build_platlib, apis[0]])
|
||||
- self.spawn([sys.executable, "/usr/bin/nosetests"])
|
||||
+ nose = self.find_nosetests_path()
|
||||
+ self.spawn([sys.executable, nose])
|
||||
|
||||
|
||||
class my_clean(clean):
|
||||
--
|
||||
2.9.3
|
||||
|
@ -1,30 +0,0 @@
|
||||
From f5edaf1ba5bc2db38ae0c7f595e17aff9d89dcfa Mon Sep 17 00:00:00 2001
|
||||
From: "Daniel P. Berrange" <berrange@redhat.com>
|
||||
Date: Wed, 21 Dec 2016 10:35:17 +0000
|
||||
Subject: [PATCH] Remove bogus \o escape in regex
|
||||
|
||||
One of the regexes has a bogus \o instead of plain 'o'. Somehow
|
||||
this magically worked on all versions of python, until 3.6 came
|
||||
along and complained
|
||||
|
||||
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
|
||||
---
|
||||
generator.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/generator.py b/generator.py
|
||||
index 730e456..2c3b667 100755
|
||||
--- a/generator.py
|
||||
+++ b/generator.py
|
||||
@@ -1091,7 +1091,7 @@ def is_integral_type (name):
|
||||
return not re.search ("^(unsigned)? ?(int|long)$", name) is None
|
||||
|
||||
def is_optional_arg(info):
|
||||
- return re.search("^\(?\optional\)?", info) is not None
|
||||
+ return re.search("^\(?optional\)?", info) is not None
|
||||
# Functions returning lists which need special rules to check for errors
|
||||
# and raise exceptions.
|
||||
functions_list_exception_test = {
|
||||
--
|
||||
2.9.3
|
||||
|
@ -6,7 +6,7 @@
|
||||
|
||||
Summary: The libvirt virtualization API python2 binding
|
||||
Name: libvirt-python
|
||||
Version: 3.2.0
|
||||
Version: 3.3.0
|
||||
Release: 1%{?dist}%{?extra_release}
|
||||
Source0: http://libvirt.org/sources/python/%{name}-%{version}.tar.gz
|
||||
Url: http://libvirt.org
|
||||
@ -86,15 +86,20 @@ rm -f %{buildroot}%{_libdir}/python*/site-packages/*egg-info
|
||||
%defattr(-,root,root)
|
||||
%doc ChangeLog AUTHORS NEWS README COPYING COPYING.LESSER examples/
|
||||
%{_libdir}/python3*/site-packages/libvirt.py*
|
||||
%{_libdir}/python3*/site-packages/libvirtaio.py*
|
||||
%{_libdir}/python3*/site-packages/libvirt_qemu.py*
|
||||
%{_libdir}/python3*/site-packages/libvirt_lxc.py*
|
||||
%{_libdir}/python3*/site-packages/__pycache__/libvirt.cpython-*.py*
|
||||
%{_libdir}/python3*/site-packages/__pycache__/libvirt_qemu.cpython-*.py*
|
||||
%{_libdir}/python3*/site-packages/__pycache__/libvirt_lxc.cpython-*.py*
|
||||
%{_libdir}/python3*/site-packages/__pycache__/libvirtaio.cpython-*.py*
|
||||
%{_libdir}/python3*/site-packages/libvirtmod*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon May 8 2017 Daniel P. Berrange <berrange@redhat.com> - 3.3.0-1
|
||||
- Update to 3.3.0 release
|
||||
|
||||
* Mon Apr 3 2017 Daniel P. Berrange <berrange@redhat.com> - 3.2.0-1
|
||||
- Update to 3.2.0 release
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libvirt-python-3.2.0.tar.gz) = d13cb0fb46844cab512931fbb85225bdd99c44eba0761caaeb13a40f8bf18700d5836f4e24300370810ee103b4f391699db13ae0523e5625a566a9c5b41d12d5
|
||||
SHA512 (libvirt-python-3.3.0.tar.gz) = 3d90e99abe813f2ba684c24631d8e8cd6a5b44564351ae3f0b75d426f80d046c00ed6358273b68ad751707a93666564dfecfb7fb7d93d2c27c71a344542fe793
|
||||
|
Loading…
Reference in New Issue
Block a user